aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-02-19 16:32:30 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-02-19 16:32:30 +0000
commit7ae73b034d4598baa8bfa02d68524b7826fb7739 (patch)
treeea3dc743a03de81c5da1e91c138a7652c71e6f3d /games
parent6d24077e4cad1a8e6963d03f44cb18af97629ffd (diff)
downloadports-7ae73b034d4598baa8bfa02d68524b7826fb7739.tar.gz
ports-7ae73b034d4598baa8bfa02d68524b7826fb7739.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/freecell-solver/Makefile15
-rw-r--r--games/freecell-solver/files/patch-CMakeLists.txt21
2 files changed, 34 insertions, 2 deletions
diff --git a/games/freecell-solver/Makefile b/games/freecell-solver/Makefile
index 242b053bd54a..b87f04cdb787 100644
--- a/games/freecell-solver/Makefile
+++ b/games/freecell-solver/Makefile
@@ -8,7 +8,7 @@
PORTNAME= freecell-solver
PORTVERSION= 2.14.0
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_BERLIOS}
MASTER_SITE_SUBDIR= fc-solve
@@ -19,7 +19,10 @@ COMMENT= A program that automatically solves games of Freecell
USE_PERL5_BUILD= yes
USE_CMAKE= yes
USE_LDCONFIG= yes
-PORTDOCS= *
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= AUTHORS README TODO USAGE README.win32.txt INSTALL
+.endif
MAN6= fc-solve-board_gen.6 \
fc-solve.6 \
@@ -29,4 +32,12 @@ MAN6= fc-solve-board_gen.6 \
make_pysol_freecell_board.py.6 \
pi-make-microsoft-freecell-board.6
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for DOCFILE in PORTDOCS
+ ${INSTALL_DATA} ${WRKSRC}/${DOCFILE}
+.endfor
+.endif
+
.include <bsd.port.mk>
diff --git a/games/freecell-solver/files/patch-CMakeLists.txt b/games/freecell-solver/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..73cc0988099b
--- /dev/null
+++ b/games/freecell-solver/files/patch-CMakeLists.txt
@@ -0,0 +1,21 @@
+--- CMakeLists.txt.orig 2009-02-19 11:27:44.292036727 -0500
++++ CMakeLists.txt 2009-02-19 11:28:03.932046002 -0500
+@@ -156,18 +156,6 @@
+
+ INSTALL(
+ FILES
+- "AUTHORS"
+- "INSTALL"
+- "README"
+- "README.win32.txt"
+- "TODO"
+- "USAGE"
+- DESTINATION
+- "share/doc/freecell-solver/"
+-)
+-
+-INSTALL(
+- FILES
+ "fcs_cl.h"
+ "fcs_enums.h"
+ "fcs_move.h"