aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2006-09-15 08:17:11 +0000
committerMark Linimon <linimon@FreeBSD.org>2006-09-15 08:17:11 +0000
commitc5aeb93cd5e4998728da54611bdf63c686a2fdfd (patch)
treef418d7aa01e7bae10fc4d0734eec45cd9e925529 /games
parentf4c5a682e5c43c1c1477307463458409ae3b3de5 (diff)
downloadports-c5aeb93cd5e4998728da54611bdf63c686a2fdfd.tar.gz
ports-c5aeb93cd5e4998728da54611bdf63c686a2fdfd.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/enigma/Makefile18
-rw-r--r--games/fillets-ng/Makefile7
-rw-r--r--games/stratagus/Makefile58
-rw-r--r--games/stratagus/files/patch-aa11
-rw-r--r--games/stratagus/files/patch-configure4
-rw-r--r--games/stratagus/pkg-message12
-rw-r--r--games/xmoto/Makefile25
7 files changed, 59 insertions, 76 deletions
diff --git a/games/enigma/Makefile b/games/enigma/Makefile
index 5e35d45dc76d..8c33648d3237 100644
--- a/games/enigma/Makefile
+++ b/games/enigma/Makefile
@@ -15,21 +15,23 @@ DISTNAME= enigma-${PORTVERSION}
MAINTAINER= anholt@FreeBSD.org
COMMENT= Enigma is a reimplementation of Oxyd, a puzzle game
-BUILD_DEPENDS= ${LOCALBASE}/bin/tolua:${PORTSDIR}/lang/tolua4
-LIB_DEPENDS= zipios.0:${PORTSDIR}/archivers/zipios++ \
- lua.4:${PORTSDIR}/lang/lua4
+LIB_DEPENDS= zipios.0:${PORTSDIR}/archivers/zipios++
USE_GCC= 3.4
-
-GNU_CONFIGURE= yes
-USE_XLIB= yes
USE_GMAKE= yes
USE_GETTEXT= yes
+USE_LUA= 4.0
+LUA_COMPS= lua tolua
USE_SDL= gfx image mixer sdl ttf
+USE_XLIB= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target="" \
--with-libintl-prefix="${LOCALBASE}"
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
- CXXFLAGS="${PTHREAD_CFLAGS} -I${X11BASE}/include"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+CPPFLAGS= -I${LOCALBASE}/include -I${LUA_INCDIR}
+CXXFLAGS= -I${X11BASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib -L${LUA_LIBDIR} ${PTHREAD_LIBS}
MAN6= enigma.6
diff --git a/games/fillets-ng/Makefile b/games/fillets-ng/Makefile
index b17c1f06a775..92286143fbc0 100644
--- a/games/fillets-ng/Makefile
+++ b/games/fillets-ng/Makefile
@@ -19,15 +19,16 @@ EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= amdmi3@mail.ru
COMMENT= A wonderful puzzle game
-LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua50
-
USE_SDL= sdl mixer image ttf
+USE_LUA= 5.0
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --datadir="${DATADIR}" --with-lua="${LOCALBASE}"
+CPPFLAGS= -I${LUA_INCDIR}
+LDFLAGS= -L${LUA_LIBDIR}
OPTIONS= FRIBIDI "Enable fribidi support" off
diff --git a/games/stratagus/Makefile b/games/stratagus/Makefile
index a61f51b833f5..55a8cacfe212 100644
--- a/games/stratagus/Makefile
+++ b/games/stratagus/Makefile
@@ -16,32 +16,21 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= tlp@liquidx.org
COMMENT= Free cross-platform real-time strategy gaming engine
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- lua.5:${PORTSDIR}/lang/lua50
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+USE_GMAKE= yes
+USE_LUA= 5.0
USE_SDL= yes
USE_XLIB= yes
-USE_GMAKE= yes
-
-WRKSRC= ${WRKDIR}/stratagus-040702
-
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include -I${LUA_INCDIR}
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -L${LUA_LIBDIR}
+WRKSRC= ${WRKDIR}/stratagus-040702
-.if defined(WITH_OPENGL)
-CONFIGURE_ARGS+= --with-opengl
-.endif
-
-.if defined(WITHOUT_VORBIS)
-CONFIGURE_ARGS+= --without-ogg
-.else
-LIB_DEPENDS+= vorbisfile.4:${PORTSDIR}/audio/libvorbis
-.endif
-
-.if defined(WITHOUT_MIKMOD)
-CONFIGURE_ARGS+= --without-mikmod
-.else
-LIB_DEPENDS+= mikmod.2:${PORTSDIR}/audio/libmikmod
-.endif
+OPTIONS= OPENGL "Enable OpenGL support" on \
+ MIKMOD "Enable Mikmod support" off \
+ VORBIS "Enable Ogg Vorbis support" off
PLIST_FILES= bin/stratagus
@@ -51,20 +40,21 @@ PLIST_FILES= bin/stratagus
IGNORE= does not run properly on FreeBSD 4.x
.endif
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Stratagus has the following tunable option(s):"
- @${ECHO_MSG} ""
- @${ECHO_MSG} " WITH_OPENGL=yes Builds Stratagus with OpenGL"
- @${ECHO_MSG} ""
- @${ECHO_MSG} " WITHOUT_VORBIS=yes Turns off Ogg Vorbis support"
- @${ECHO_MSG} " WITHOUT_MIKMOD=yes Turns off Mikmod support"
- @${ECHO_MSG} ""
+.if defined(WITH_OPENGL)
+CONFIGURE_ARGS+=--with-opengl
+.endif
+
+.if defined(WITH_MIKMOD)
+LIB_DEPENDS+= mikmod.2:${PORTSDIR}/audio/libmikmod
+.else
+CONFIGURE_ARGS+=--without-mikmod
+.endif
-post-configure:
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/Rules.make
- @${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|' ${WRKSRC}/Rules.make
+.if defined(WITH_VORBIS)
+LIB_DEPENDS+= vorbisfile.4:${PORTSDIR}/audio/libvorbis
+.else
+CONFIGURE_ARGS+=--without-ogg
+.endif
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/games/stratagus/files/patch-aa b/games/stratagus/files/patch-aa
index 18c88c4db0a5..e69de29bb2d1 100644
--- a/games/stratagus/files/patch-aa
+++ b/games/stratagus/files/patch-aa
@@ -1,11 +0,0 @@
---- Rules.make.in.orig Thu Jul 1 00:03:00 2004
-+++ Rules.make.in Thu Jul 1 00:04:55 2004
-@@ -55,7 +55,8 @@
- @OGG_CFLAGS@ @MAD_CFLAGS@ @FLAC_CFLAGS@ @CDAUDIO_CFLAGS@ \
- @MIKMOD_CFLAGS@ @LUA_CFLAGS@ $(CCL) \
- $(COMP_CFLAGS) @PLATFORM@ \
-- -I/usr/local/include
-+ -I/usr/local/include \
-+ -I/usr/X11R6/include
-
- CTAGSFLAGS=-i defptvS -a -f
diff --git a/games/stratagus/files/patch-configure b/games/stratagus/files/patch-configure
index 9f4328894777..4384cc74fdf4 100644
--- a/games/stratagus/files/patch-configure
+++ b/games/stratagus/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig Fri Jul 2 03:46:35 2004
-+++ configure Tue Nov 2 21:31:50 2004
+--- ./configure.orig Thu Jul 1 22:46:35 2004
++++ ./configure Mon Jul 17 19:23:06 2006
@@ -3229,9 +3229,6 @@
VIDEO_LIBS="$VIDEO_LIBS -lwsock32 -lws2_32 -lmingwex -lgmon"
fi
diff --git a/games/stratagus/pkg-message b/games/stratagus/pkg-message
index 4e617f7236dc..869d6ea6909c 100644
--- a/games/stratagus/pkg-message
+++ b/games/stratagus/pkg-message
@@ -1,9 +1,9 @@
--------------------------------------------------------------------------------
-NOTE: This is only the engine. If you wish to play a game that uses the
-Stratagus engine, you must manually download the Stratagus game data.
+------------------------------------------------------------------------------
+NOTE: This is only the engine. If you wish to play a game that uses the
+Stratagus engine, you must manually download the Stratagus game data.
-You can use the 'games/wargus' port to extract data from a legal copy of
-Warcraft 2 (original DOS version required, won't work with the battle.net
+You can use the 'games/wargus' port to extract data from a legal copy of
+Warcraft 2 (original DOS version required, won't work with the battle.net
edition).
For more information, please take a look at the following URL:
@@ -11,4 +11,4 @@ For more information, please take a look at the following URL:
http://stratagus.sourceforge.net/games.shtml
Enjoy!
--------------------------------------------------------------------------------
+------------------------------------------------------------------------------
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index e83a7902b6cb..07bc5fdb09f5 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -18,19 +18,19 @@ COMMENT= Challenging 2D motocross platform game
LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
-BUILD_DEPENDS= ${X11BASE}/lib/libode.a:${PORTSDIR}/devel/ode \
- ${LOCALBASE}/include/lua.hpp:${PORTSDIR}/lang/lua
+BUILD_DEPENDS= ${X11BASE}/lib/libode.a:${PORTSDIR}/devel/ode
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GL= yes
+USE_LUA= 5.1
USE_SDL= sdl mixer
USE_DOS2UNIX= src/*.cpp src/*.h
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
- CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- SDL_CONFIG="${SDL_CONFIG}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include -I${LUA_INCDIR}
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -L${LUA_LIBDIR}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -45,13 +45,14 @@ LIB_DEPENDS+= curl.3:${PORTSDIR}/ftp/curl
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/src/VCommon.h
- @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/src/image/tim_memory_crt.cpp
- @${REINPLACE_CMD} -e 's|endian.h|sys/endian.h|' ${WRKSRC}/src/VCommon.h
- @${REINPLACE_CMD} -e '/LIBS/ s|\(-lSDL_mixer\)|\1 `${SDL_CONFIG} --libs`|' ${WRKSRC}/configure
-.if !defined(WITH_CURL)
- @${REINPLACE_CMD} -e 's|test $$ac_cv_lib_curl_curl_easy_init = yes|false|' ${WRKSRC}/configure
-.endif
+ @${REINPLACE_CMD} -e 's|SDL/||; s|endian.h|sys/endian.h|' \
+ ${WRKSRC}/src/VCommon.h
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \
+ ${WRKSRC}/src/image/tim_memory_crt.cpp
+ @${REINPLACE_CMD} -e \
+ '/LIBS/ s|\(-lSDL_mixer\)|`${SDL_CONFIG} --libs` \1| ; \
+ s|test $$ac_cv_lib_curl_curl_easy_init = yes|false|' \
+ ${WRKSRC}/configure
.if !defined(NOPORTDOCS)
post-install: