aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-20 17:37:47 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-20 17:37:47 +0000
commitf554f89c4fadcd02445fcc0ef7555a0f110ac2f9 (patch)
tree0392481f5b74a8752e5aa2d7eae219957562cc98 /games
parent7eb536ae4089eb791cff87c57f4d7fde10e7d791 (diff)
Notes
Diffstat (limited to 'games')
-rw-r--r--games/barrage/Makefile7
-rw-r--r--games/briquolo/Makefile5
-rw-r--r--games/openglad/Makefile7
-rw-r--r--games/shaaft/Makefile5
4 files changed, 7 insertions, 17 deletions
diff --git a/games/barrage/Makefile b/games/barrage/Makefile
index 9eac94beb306..5e194121c4be 100644
--- a/games/barrage/Makefile
+++ b/games/barrage/Makefile
@@ -15,16 +15,13 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= krion@FreeBSD.org
COMMENT= Destroy as many targets as possible
-LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
-
USE_GMAKE= yes
-USE_SDL= yes
+USE_SDL= sdl mixer
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-profile-path=/var/games
USE_REINPLACE= yes
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
- CPPFLAGS="-I${X11BASE}/include"
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include"
post-patch:
@${REINPLACE_CMD} -e 's|applications|applnk/Applications|g' \
diff --git a/games/briquolo/Makefile b/games/briquolo/Makefile
index 029bb2a6d0a3..00d367814bde 100644
--- a/games/briquolo/Makefile
+++ b/games/briquolo/Makefile
@@ -13,8 +13,7 @@ MASTER_SITES= http://briquolo.free.fr/download/
MAINTAINER= krion@FreeBSD.org
COMMENT= Breakout clone with an OpenGL 3D representation
-LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
- GUI.0:${PORTSDIR}/graphics/guilib \
+LIB_DEPENDS= GUI.0:${PORTSDIR}/graphics/guilib \
png.5:${PORTSDIR}/graphics/png
USE_BZIP2= yes
@@ -24,7 +23,7 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-USE_SDL= yes
+USE_SDL= mixer sdl
post-patch:
@${FIND} ${WRKSRC} -name "*.cpp" | ${XARGS} \
diff --git a/games/openglad/Makefile b/games/openglad/Makefile
index e2e6d8a9a8e6..0186ccee3334 100644
--- a/games/openglad/Makefile
+++ b/games/openglad/Makefile
@@ -14,15 +14,12 @@ MASTER_SITE_SUBDIR= snowstorm
MAINTAINER= krion@FreeBSD.org
COMMENT= SDL port of an old DOS game called Gladiator
-LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
-
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_SDL= yes
+USE_SDL= sdl mixer
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
- CPPFLAGS="-I${X11BASE}/include"
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include"
PLIST_SUB= DOCDIR=share/doc/${PORTNAME}
post-configure:
diff --git a/games/shaaft/Makefile b/games/shaaft/Makefile
index b456aeee299b..d768df932991 100644
--- a/games/shaaft/Makefile
+++ b/games/shaaft/Makefile
@@ -15,11 +15,8 @@ DISTNAME= Shaaft-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Shaaft is an OpenGL 3D falling block game similar to Blockout
-LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
- SDL_image.10:${PORTSDIR}/graphics/sdl_image
-
USE_BZIP2= yes
-USE_SDL= yes
+USE_SDL= mixer image sdl
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \