aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-14 23:06:39 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-14 23:06:39 +0000
commit10ddcca177d6d91079be1d2569dae59e314d70c9 (patch)
tree99a6744dc9660c3435aa9d77234a5901dd589105 /games
parent4de56a776b06e3e1141de9f8098f35898c845484 (diff)
downloadports-10ddcca177d6d91079be1d2569dae59e314d70c9.tar.gz
ports-10ddcca177d6d91079be1d2569dae59e314d70c9.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/adgali/Makefile2
-rw-r--r--games/deng/Makefile2
-rw-r--r--games/freecell-solver/Makefile2
-rw-r--r--games/libshhcards/Makefile2
-rw-r--r--games/taxipilot/Makefile2
-rw-r--r--games/vamos/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/games/adgali/Makefile b/games/adgali/Makefile
index 0a1096503b24..3d2ef4b06cdc 100644
--- a/games/adgali/Makefile
+++ b/games/adgali/Makefile
@@ -29,7 +29,7 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-compile-optim=no
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
diff --git a/games/deng/Makefile b/games/deng/Makefile
index 770aecde99a0..53c5b6a9002e 100644
--- a/games/deng/Makefile
+++ b/games/deng/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} `${SDL_CONFIG} --cflags` -I${LOCALBASE}/include
CPPFLAGS="`${SDL_CONFIG} --cflags` -I${LOCALBASE}/include -I${X11BASE}/include"
USE_SDL= sdl mixer net
USE_GL= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
ONLY_FOR_ARCHS= i386
SUB_FILES= pkg-message
diff --git a/games/freecell-solver/Makefile b/games/freecell-solver/Makefile
index 7001cf983d00..b2723c8f1945 100644
--- a/games/freecell-solver/Makefile
+++ b/games/freecell-solver/Makefile
@@ -17,7 +17,7 @@ COMMENT= A program that automatically solves games of Freecell
GNU_CONFIGURE= yes
USE_GNOME= gnometarget
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN6= fc-solve-board_gen.6 fc-solve.6 \
freecell-solver-range-parallel-solve.6 \
diff --git a/games/libshhcards/Makefile b/games/libshhcards/Makefile
index 67a6b6573a69..16c2863b18d4 100644
--- a/games/libshhcards/Makefile
+++ b/games/libshhcards/Makefile
@@ -17,7 +17,7 @@ COMMENT= Library for displaying game cards on X Window System
USE_X_PREFIX= yes
USE_XPM= yes
MAKEFILE= ${FILESDIR}/Makefile.lib
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-install:
.if !defined(NOPORTDOCS)
diff --git a/games/taxipilot/Makefile b/games/taxipilot/Makefile
index 160bd19e5872..f89f8ed44cf6 100644
--- a/games/taxipilot/Makefile
+++ b/games/taxipilot/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= artsmodules.0:${PORTSDIR}/multimedia/kdemultimedia3
USE_KDELIBS_VER=3
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-old_configure
CONFIGURE_ENV= LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}" CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS}"
diff --git a/games/vamos/Makefile b/games/vamos/Makefile
index 247de73a5b32..000b9c3e09cb 100644
--- a/games/vamos/Makefile
+++ b/games/vamos/Makefile
@@ -30,7 +30,7 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --x-includes=${X11BASE}/include --x-libraries=${X11BASE}/lib
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
INFO= vamos