aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-11-10 18:51:28 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-11-10 18:51:28 +0000
commit554ce86c00882adf4548ca9e351ffa97fefc8786 (patch)
tree002a69ac9edb2caf6b684b0af4aaabb62158c603 /games
parent6fa25125c5ea2bd1f59bb6bc4191db428dc572e1 (diff)
downloadports-554ce86c00882adf4548ca9e351ffa97fefc8786.tar.gz
ports-554ce86c00882adf4548ca9e351ffa97fefc8786.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/vamos/Makefile6
-rw-r--r--games/vamos/distinfo2
-rw-r--r--games/vamos/files/patch-configure94
-rw-r--r--games/vamos/files/patch-track::Road_Segment.cc10
-rw-r--r--games/vamos/pkg-plist16
5 files changed, 121 insertions, 7 deletions
diff --git a/games/vamos/Makefile b/games/vamos/Makefile
index bf0ee4627eb5..93c7a69a79c2 100644
--- a/games/vamos/Makefile
+++ b/games/vamos/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= vamos
-PORTVERSION= 0.4.1
+PORTVERSION= 0.4.2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,9 +19,10 @@ BUILD_DEPENDS= ${X11BASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear \
${X11BASE}/lib/libplibul.a:${PORTSDIR}/x11-toolkits/plib
LIB_DEPENDS= sigc-1.2.5:${PORTSDIR}/devel/libsigc++12 \
sigc.1:${PORTSDIR}/devel/libsigc++ \
+ glut.3:${PORTSDIR}/graphics/libglut \
png.5:${PORTSDIR}/graphics/png
-USE_MESA= yes
+USE_GL= yes
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_GMAKE= yes
@@ -42,7 +43,6 @@ post-extract:
@${RM} -f ${WRKSRC}/doc/*.info*
post-patch:
- @${REINPLACE_CMD} -e '/^CXXFLAGS/d' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
'/^AM_CXXFLAGS/d'
diff --git a/games/vamos/distinfo b/games/vamos/distinfo
index 80f9c038325c..37726641ca7f 100644
--- a/games/vamos/distinfo
+++ b/games/vamos/distinfo
@@ -1 +1 @@
-MD5 (vamos-0.4.1.tar.gz) = 9ad34cf09ed4e4dd15df726f214172cd
+MD5 (vamos-0.4.2.tar.gz) = 99048a0bfbc528ba33fdedf8e92602d5
diff --git a/games/vamos/files/patch-configure b/games/vamos/files/patch-configure
index ac027a5c3fa6..87e80af09b23 100644
--- a/games/vamos/files/patch-configure
+++ b/games/vamos/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Thu Jun 6 09:33:15 2002
-+++ configure Fri Jun 7 05:34:40 2002
-@@ -7809,6 +7809,7 @@
+--- configure.orig Sun Nov 9 06:15:34 2003
++++ configure Mon Nov 10 13:08:47 2003
+@@ -8169,6 +8169,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
@@ -8,3 +8,91 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -8402,7 +8403,6 @@
+ fi
+
+ LIBS="$LIBS -L$x_libraries"
+-CXXFLAGS="-gstabs+ -Wall -pedantic"
+
+
+ ac_ext=cc
+@@ -10890,71 +10890,6 @@
+ opengl_LIBS="$LIBS $x_suffix"
+
+
+-echo "$as_me:$LINENO: checking for glutGetModifiers in -lfreeglut" >&5
+-echo $ECHO_N "checking for glutGetModifiers in -lfreeglut... $ECHO_C" >&6
+-if test "${ac_cv_lib_freeglut_glutGetModifiers+set}" = set; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+- ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lfreeglut $opengl_LIBS $LIBS"
+-cat >conftest.$ac_ext <<_ACEOF
+-#line $LINENO "configure"
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-
+-/* Override any gcc2 internal prototype to avoid an error. */
+-#ifdef __cplusplus
+-extern "C"
+-#endif
+-/* We use char because int might match the return type of a gcc2
+- builtin and then its argument prototype would still apply. */
+-char glutGetModifiers ();
+-int
+-main ()
+-{
+-glutGetModifiers ();
+- ;
+- return 0;
+-}
+-_ACEOF
+-rm -f conftest.$ac_objext conftest$ac_exeext
+-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+- (eval $ac_link) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } &&
+- { ac_try='test -s conftest$ac_exeext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- ac_cv_lib_freeglut_glutGetModifiers=yes
+-else
+- echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+-ac_cv_lib_freeglut_glutGetModifiers=no
+-fi
+-rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
+-LIBS=$ac_check_lib_save_LIBS
+-fi
+-echo "$as_me:$LINENO: result: $ac_cv_lib_freeglut_glutGetModifiers" >&5
+-echo "${ECHO_T}$ac_cv_lib_freeglut_glutGetModifiers" >&6
+-if test $ac_cv_lib_freeglut_glutGetModifiers = yes; then
+- cat >>confdefs.h <<_ACEOF
+-#define HAVE_LIBFREEGLUT 1
+-_ACEOF
+-
+- LIBS="-lfreeglut $LIBS"
+-
+-fi
+-
+- if test "x$ac_cv_lib_freeglut_glutGetModifiers" = "xno" ; then
+-
+ echo "$as_me:$LINENO: checking for glutGetModifiers in -lglut" >&5
+ echo $ECHO_N "checking for glutGetModifiers in -lglut... $ECHO_C" >&6
+ if test "${ac_cv_lib_glut_glutGetModifiers+set}" = set; then
+@@ -11018,7 +10953,6 @@
+
+ fi
+
+- fi
+
+ LIBS="$LIBS $x_suffix"
+ else
diff --git a/games/vamos/files/patch-track::Road_Segment.cc b/games/vamos/files/patch-track::Road_Segment.cc
new file mode 100644
index 000000000000..a315c5369996
--- /dev/null
+++ b/games/vamos/files/patch-track::Road_Segment.cc
@@ -0,0 +1,10 @@
+--- track/Road_Segment.cc.orig Mon Oct 27 10:15:10 2003
++++ track/Road_Segment.cc Mon Nov 10 02:10:01 2003
+@@ -21,6 +21,7 @@
+
+ #include <GL/glut.h>
+
++#include <algorithm>
+ #include <cmath>
+ #include <cassert>
+
diff --git a/games/vamos/pkg-plist b/games/vamos/pkg-plist
index a111907d8dfb..ac14fb0aa5cb 100644
--- a/games/vamos/pkg-plist
+++ b/games/vamos/pkg-plist
@@ -17,6 +17,7 @@ include/vamos/body/Suspension.h
include/vamos/body/Tire.h
include/vamos/body/Transmission.h
include/vamos/body/Wheel.h
+include/vamos/geometry/Ac3d.h
include/vamos/geometry/Constants.h
include/vamos/geometry/Conversions.h
include/vamos/geometry/Gl_Texture_Image.h
@@ -52,12 +53,17 @@ lib/libvamos-track.so.0
lib/libvamos-world.a
lib/libvamos-world.so
lib/libvamos-world.so.0
+share/vamos/cars/F1-1967.ac
share/vamos/cars/F1-1967.xml
+share/vamos/cars/F1.ac
share/vamos/cars/F1.xml
+share/vamos/cars/GT.ac
share/vamos/cars/GT.xml
share/vamos/cars/default-car.xml
share/vamos/cars/front-drive.xml
share/vamos/cars/trainer.xml
+share/vamos/cars/wheel-fast.ac
+share/vamos/cars/wheel.ac
share/vamos/controls/clutch-wheel.xml
share/vamos/controls/default-controls.xml
share/vamos/controls/stick.xml
@@ -95,15 +101,25 @@ share/vamos/textures/track.png
share/vamos/textures/track2.png
share/vamos/textures/wall.png
share/vamos/tracks/Albert_Park.xml
+share/vamos/tracks/Bahrain.xml
+share/vamos/tracks/Catalunya.xml
+share/vamos/tracks/Hockenheimring.xml
+share/vamos/tracks/Hungaroring.xml
+share/vamos/tracks/Imola.xml
share/vamos/tracks/Indianapolis.xml
+share/vamos/tracks/Interlagos.xml
share/vamos/tracks/Magny-Cours.xml
+share/vamos/tracks/Monaco.xml
share/vamos/tracks/Monza.xml
share/vamos/tracks/Mosport.xml
share/vamos/tracks/Nurburgring.xml
share/vamos/tracks/Peanut.xml
+share/vamos/tracks/Sepang.xml
+share/vamos/tracks/Shanghai.xml
share/vamos/tracks/Silverstone.xml
share/vamos/tracks/Spa.xml
share/vamos/tracks/Suzuka.xml
+share/vamos/tracks/Villeneuve.xml
share/vamos/tracks/default-track.xml
share/vamos/tracks/drag.xml
share/vamos/tracks/jump.xml