aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-11-21 15:01:18 +0000
committerJohn Marino <marino@FreeBSD.org>2016-11-21 15:01:18 +0000
commit97ef0f7c0e90af22d5b841d6bb503fb66f761dc8 (patch)
tree2724123780a484bbf78b8998e0031533cd722374 /games
parent217b0b61a7c9ba83a74f201941b2dbf5c38d8cf5 (diff)
downloadports-97ef0f7c0e90af22d5b841d6bb503fb66f761dc8.tar.gz
ports-97ef0f7c0e90af22d5b841d6bb503fb66f761dc8.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/gtypist/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/games/gtypist/Makefile b/games/gtypist/Makefile
index 2a47394cdac1..b04f4d5b86cb 100644
--- a/games/gtypist/Makefile
+++ b/games/gtypist/Makefile
@@ -12,8 +12,10 @@ LICENSE= GPLv3
USES= iconv ncurses shebangfix tar:xz
GNU_CONFIGURE= yes
-CONFIGURE_ENV= EMACS=no
+CONFIGURE_ENV= EMACS=no \
+ ac_cv_header_ncursesw_ncurses_h=yes
CPPFLAGS+= -I${LOCALBASE}/include -I${WRKDIR}/include
+CPPFLAGS+= -I${NCURSESINC}
LDFLAGS+= -L${LOCALBASE}/libs
INFO= gtypist gtypist.cs gtypist.es
@@ -26,9 +28,12 @@ OPTIONS_SUB= yes
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
-# wide curses header expected at <ncursesw/ncurses.h>
-pre-configure:
- @${MKDIR} ${WRKDIR}/include
- @${LN} -sf /usr/include ${WRKDIR}/include/ncursesw
+post-patch:
+ ${REINPLACE_CMD} -e 's|<ncursesw/ncurses.h>|<ncurses.h>|' \
+ ${WRKSRC}/src/error.c \
+ ${WRKSRC}/src/cursmenu.c \
+ ${WRKSRC}/src/script.c \
+ ${WRKSRC}/src/gtypist.c \
+ ${WRKSRC}/src/utf8.c
.include <bsd.port.mk>