aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2005-02-08 00:24:24 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2005-02-08 00:24:24 +0000
commite9e86b286f01bd1d98df3b77ce65557c0214b507 (patch)
treee13b3b15c33d7af7a6642636d0f6f7d82ded6f71 /games
parent1437004df76e8d2646f174b6ad8a15f7106a1453 (diff)
downloadports-e9e86b286f01bd1d98df3b77ce65557c0214b507.tar.gz
ports-e9e86b286f01bd1d98df3b77ce65557c0214b507.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/tomatoes/Makefile6
-rw-r--r--games/tomatoes/files/patch-makefile2
-rw-r--r--games/tomatoes/pkg-plist3
3 files changed, 7 insertions, 4 deletions
diff --git a/games/tomatoes/Makefile b/games/tomatoes/Makefile
index 3f298ec2367b..9e02b9f9f132 100644
--- a/games/tomatoes/Makefile
+++ b/games/tomatoes/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tomatoes
PORTVERSION= 1.5
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,6 +17,8 @@ DISTFILES= ${PORTNAME}-linux-src-${PORTVERSION}5${EXTRACT_SUFX} \
MAINTAINER= ports@FreeBSD.org
COMMENT= Tomato-smashing, Q-Bert style
+LIB_DEPENDS= mikmod:${PORTSDIR}/audio/libmikmod
+
USE_BZIP2= yes
WRKSRC= ${WRKDIR}/tomatoes-${PORTVERSION}5
TDATA= ${WRKDIR}/tomatoes-${PORTVERSION}
@@ -23,12 +26,13 @@ TDATA= ${WRKDIR}/tomatoes-${PORTVERSION}
USE_X_PREFIX= yes
MAKEFILE= makefile
USE_GMAKE= yes
-USE_SDL= mixer image
+USE_SDL= mixer image sound
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${MKDIR} ${DATADIR}/music
${INSTALL_DATA} ${TDATA}/config.cfg ${DATADIR}
${INSTALL_DATA} ${TDATA}/tomatoes.mpk ${DATADIR}
+ ${INSTALL_DATA} ${TDATA}/music/IHaveNoTomatoes.it ${DATADIR}/music
.include <bsd.port.mk>
diff --git a/games/tomatoes/files/patch-makefile b/games/tomatoes/files/patch-makefile
index fc6a95ce06e5..9a11325a1620 100644
--- a/games/tomatoes/files/patch-makefile
+++ b/games/tomatoes/files/patch-makefile
@@ -56,7 +56,7 @@
-CFLAGS = -MMD -O3 -march=$(MARCH) -Wall $(SDL_FLAGS)
-LDFLAGS = `sdl-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU -s
+CFLAGS += -MMD -march=$(MARCH) -Wall $(SDL_FLAGS) -I${X11BASE}/include
-+LDFLAGS += `sdl11-config --libs` -L${X11BASE}/lib -lSDL_image -lSDL_mixer -lGL -lGLU -s
++LDFLAGS += `sdl11-config --libs` -L${X11BASE}/lib -lSDL_image -lSDL_mixer -lGL -lGLU -s -lSDL_sound
endif
endif
diff --git a/games/tomatoes/pkg-plist b/games/tomatoes/pkg-plist
index 773991606e11..c4a93a7d5805 100644
--- a/games/tomatoes/pkg-plist
+++ b/games/tomatoes/pkg-plist
@@ -1,7 +1,6 @@
bin/tomatoes
-etc/tomatoes/config.cfg
+share/tomatoes/config.cfg
share/tomatoes/music/IHaveNoTomatoes.it
share/tomatoes/tomatoes.mpk
@dirrm share/tomatoes/music
@dirrm share/tomatoes
-@dirrm etc/tomatoes