aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-10-11 05:33:04 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-10-11 05:33:04 +0000
commited37e288852c87e2552a3745d778ef9c71edb099 (patch)
tree3859497dc5b88cdf305c395b6ffd97ab51f783da /games
parent5dba370feddbbb244984161d0b89f83ce50aea8b (diff)
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/smashbattle/Makefile54
-rw-r--r--games/smashbattle/distinfo2
-rw-r--r--games/smashbattle/files/patch-Makefile11
-rw-r--r--games/smashbattle/files/smashbattle.in6
-rw-r--r--games/smashbattle/pkg-descr6
6 files changed, 80 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 64cc24d9cd05..44528ae27e92 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -847,6 +847,7 @@
SUBDIR += slashem-tty
SUBDIR += slump
SUBDIR += slune
+ SUBDIR += smashbattle
SUBDIR += smiley
SUBDIR += sokoban
SUBDIR += sol
diff --git a/games/smashbattle/Makefile b/games/smashbattle/Makefile
new file mode 100644
index 000000000000..27756d18d2b8
--- /dev/null
+++ b/games/smashbattle/Makefile
@@ -0,0 +1,54 @@
+# Created by: nemysis@gmx.ch
+#
+# $FreeBSD$
+
+PORTNAME= smashbattle
+PORTVERSION= 110224
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/beta-${PORTVERSION}
+DISTNAME= ${PORTNAME}-${DISTVERSION}-src
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= 8-bit style platform battle game
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/battle/Battle
+
+USE_ZIP= yes
+EXTRACT_AFTER_ARGS= -d ${WRKDIR}/${DISTNAME}
+USE_GMAKE= yes
+USE_DOS2UNIX= *.cpp *.h *.ini Makefile
+ALL_TARGET= battle
+USE_SDL= sdl image mixer
+MAKE_JOBS_SAFE= yes
+
+pre-extract:
+ @${MKDIR} ${WRKDIR}/${DISTNAME}
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/applications/${PORTNAME}.desktop \
+ share/applications/${PORTNAME}fs.desktop \
+ share/pixmaps/${PORTNAME}.png
+PLIST_DIRSTRY= share/applications
+
+PORTDATA= *
+
+SUB_FILES= ${PORTNAME}
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share/games/smashbattle/gfx/SB.png|${PORTNAME}|' \
+ -e 's|/usr/local/bin/smashbattle|${PORTNAME}|' \
+ ${WRKSRC}/linux/${PORTNAME}.desktop ${WRKSRC}/linux/${PORTNAME}fs.desktop
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/battle ${DATADIR}/${PORTNAME}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} "gfx music sfx stage" ${DATADIR})
+ ${INSTALL_DATA} ${WRKSRC}/gfx/SB.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/linux/${PORTNAME}.desktop ${PREFIX}/share/applications/
+ ${INSTALL_DATA} ${WRKSRC}/linux/${PORTNAME}fs.desktop ${PREFIX}/share/applications/
+
+.include <bsd.port.mk>
diff --git a/games/smashbattle/distinfo b/games/smashbattle/distinfo
new file mode 100644
index 000000000000..09565f912bcc
--- /dev/null
+++ b/games/smashbattle/distinfo
@@ -0,0 +1,2 @@
+SHA256 (smashbattle-110224-src.zip) = 3856d97bf09e63b203c997190299e0aacfb9f947e9529e634046e7596e1e8ad1
+SIZE (smashbattle-110224-src.zip) = 12238568
diff --git a/games/smashbattle/files/patch-Makefile b/games/smashbattle/files/patch-Makefile
new file mode 100644
index 000000000000..ffed56f3c7a6
--- /dev/null
+++ b/games/smashbattle/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2012-05-11 15:51:06.000000000 +0200
++++ Makefile 2012-05-11 16:34:16.000000000 +0200
+@@ -1,6 +1,6 @@
+ CC=g++
+-CFLAGS=-c -Wall
+-LDFLAGS=-lSDL -lSDL_mixer -lz -lstdc++
++CFLAGS += $(shell sdl-config --cflags) -c -Wall
++LDFLAGS += $(shell sdl-config --libs) -lSDL -lSDL_mixer -lz -lstdc++ -lm
+ SRCS=Airstrike.cpp\
+ AirstrikePowerUp.cpp\
+ AmmoPowerUp.cpp\
diff --git a/games/smashbattle/files/smashbattle.in b/games/smashbattle/files/smashbattle.in
new file mode 100644
index 000000000000..b9d105b6794d
--- /dev/null
+++ b/games/smashbattle/files/smashbattle.in
@@ -0,0 +1,6 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+cd "%%DATADIR%%"
+exec ./smashbattle "${@}"
diff --git a/games/smashbattle/pkg-descr b/games/smashbattle/pkg-descr
new file mode 100644
index 000000000000..858225b7df59
--- /dev/null
+++ b/games/smashbattle/pkg-descr
@@ -0,0 +1,6 @@
+Smash Battle is a cross platform, 8-bit style game where two,
+three or four player face off against each other.
+The game was inspired by the mario battle minigame from mario 3
+when we started developing, but changed a lot over time.
+
+WWW: http://smashbattle.condor.tv/