aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-12-15 13:02:44 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-12-15 13:02:44 +0000
commit89f138370e4c0369985d69b2d283194620773929 (patch)
treefcbca727b0371006a3aec44a6f7d08c02f16218a /games
parentcf442d730193abb79831b80244a824a472ca71ea (diff)
downloadports-89f138370e4c0369985d69b2d283194620773929.tar.gz
ports-89f138370e4c0369985d69b2d283194620773929.zip
Diffstat (limited to 'games')
-rw-r--r--games/enigma/Makefile3
-rw-r--r--games/openspades/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/games/enigma/Makefile b/games/enigma/Makefile
index 9cb448453776..26758c47be45 100644
--- a/games/enigma/Makefile
+++ b/games/enigma/Makefile
@@ -14,12 +14,13 @@ LIB_DEPENDS= libxerces-c.so.3:textproc/xerces-c3 \
libpng.so:graphics/png \
libenet.so:net/enet \
libcurl.so:ftp/curl
+BUILD_DEPENDS= convert:graphics/ImageMagick6
USE_GITHUB= yes
GH_ACCOUNT= Enigma-Game
GH_PROJECT= Enigma
-USES= autoreconf:build gettext gmake iconv localbase magick:6,build pkgconfig sdl
+USES= autoreconf:build gettext gmake iconv localbase pkgconfig sdl
GNU_CONFIGURE= yes
USE_SDL= sdl2 image2 mixer2 ttf2
CONFIGURE_ARGS= --with-system-enet
diff --git a/games/openspades/Makefile b/games/openspades/Makefile
index 48f79b74fc3f..cd5f8606416e 100644
--- a/games/openspades/Makefile
+++ b/games/openspades/Makefile
@@ -15,6 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
ONLY_FOR_ARCHS= amd64 powerpc64 powerpc64le
ONLY_FOR_ARCHS_REASON= bundles non-portable AngelScript
+BUILD_DEPENDS= convert:graphics/ImageMagick6 # for building icons
LIB_DEPENDS= libcurl.so:ftp/curl \
libopusfile.so:audio/opusfile
@@ -22,7 +23,7 @@ USE_GITHUB= yes
GH_ACCOUNT= yvt
USES= cmake:insource compiler:c++11-lib desktop-file-utils dos2unix \
- gl gnome magick:6,build openal sdl xorg
+ gl gnome openal sdl xorg
CMAKE_ARGS= -DOPENSPADES_RESOURCES=OFF \
-DOPENSPADES_INSTALL_MAN="man/man6" \
-DOPENSPADES_INSTALL_BINARY="bin" \