aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-12-17 14:05:48 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-12-17 14:06:06 +0000
commitb788897da19b5a85343fb73040f85f2efb788d04 (patch)
tree7961ab69f623df6819728a2509a4bf815c4e3abc /games
parent87da00f2fdaaed3dc22f19ecfe7e617ac81717a9 (diff)
downloadports-b788897da19b5a85343fb73040f85f2efb788d04.tar.gz
ports-b788897da19b5a85343fb73040f85f2efb788d04.zip
games/iortcw: port to riscv64
Diffstat (limited to 'games')
-rw-r--r--games/iortcw/Makefile2
-rw-r--r--games/iortcw/files/patch-MP_code_qcommon_q__platform.h4
-rw-r--r--games/iortcw/files/patch-SP_code_qcommon_q__platform.h4
3 files changed, 7 insertions, 3 deletions
diff --git a/games/iortcw/Makefile b/games/iortcw/Makefile
index 5a623072aac1..3aeb52255db1 100644
--- a/games/iortcw/Makefile
+++ b/games/iortcw/Makefile
@@ -9,7 +9,7 @@ COMMENT= Game engine for Return to Castle Wolfenstein
LICENSE= GPLv3
-NOT_FOR_ARCHS= aarch64 armv6 armv7 riscv64
+NOT_FOR_ARCHS= aarch64 armv6 armv7
NOT_FOR_ARCHS_REASON= fails to configure: Architecture not supported
LIB_DEPENDS= libcurl.so:ftp/curl \
diff --git a/games/iortcw/files/patch-MP_code_qcommon_q__platform.h b/games/iortcw/files/patch-MP_code_qcommon_q__platform.h
index 20bd2d05a3e6..770e384a9750 100644
--- a/games/iortcw/files/patch-MP_code_qcommon_q__platform.h
+++ b/games/iortcw/files/patch-MP_code_qcommon_q__platform.h
@@ -12,7 +12,7 @@
#if (defined(powerc) || defined(powerpc) || defined(ppc) || \
defined(__ppc) || defined(__ppc__)) && !defined(C_ONLY)
-@@ -224,11 +220,13 @@ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
+@@ -224,11 +220,15 @@ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
#ifdef __i386__
#define ARCH_STRING "i386"
#elif defined __amd64__
@@ -25,6 +25,8 @@
+#define ARCH_STRING "powerpc64"
+#elif defined __powerpc__
+#define ARCH_STRING "powerpc"
++#elif defined __riscv
++#define ARCH_STRING "riscv64"
#endif
#if BYTE_ORDER == BIG_ENDIAN
diff --git a/games/iortcw/files/patch-SP_code_qcommon_q__platform.h b/games/iortcw/files/patch-SP_code_qcommon_q__platform.h
index deecff300c60..84d7ad28d17e 100644
--- a/games/iortcw/files/patch-SP_code_qcommon_q__platform.h
+++ b/games/iortcw/files/patch-SP_code_qcommon_q__platform.h
@@ -12,7 +12,7 @@
#if (defined(powerc) || defined(powerpc) || defined(ppc) || \
defined(__ppc) || defined(__ppc__)) && !defined(C_ONLY)
-@@ -224,11 +220,13 @@ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
+@@ -224,11 +220,15 @@ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
#ifdef __i386__
#define ARCH_STRING "i386"
#elif defined __amd64__
@@ -25,6 +25,8 @@
+#define ARCH_STRING "powerpc64"
+#elif defined __powerpc__
+#define ARCH_STRING "powerpc"
++#elif defined __riscv
++#define ARCH_STRING "riscv64"
#endif
#if BYTE_ORDER == BIG_ENDIAN