aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-03-22 20:06:14 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-03-22 20:06:14 +0000
commitffd97a0193e0238aa21bc32b570fd052292e0fe5 (patch)
treeb368198f913179c06dafd19ac72527fcf9836f6d /games
parentccbdf54cacb9796580726f8d5278fe3fa53d5e53 (diff)
downloadports-ffd97a0193e0238aa21bc32b570fd052292e0fe5.tar.gz
ports-ffd97a0193e0238aa21bc32b570fd052292e0fe5.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/arx-libertatis/Makefile2
-rw-r--r--games/asteroid/Makefile3
-rw-r--r--games/blinkensisters/Makefile2
-rw-r--r--games/blobby/Makefile2
-rw-r--r--games/corsix-th/Makefile2
-rw-r--r--games/flare/Makefile2
-rw-r--r--games/flightgear/Makefile2
-rw-r--r--games/freecell-solver/Makefile2
-rw-r--r--games/gemrb/Makefile2
-rw-r--r--games/golly/Makefile3
-rw-r--r--games/hedgewars/Makefile2
-rw-r--r--games/intensityengine/Makefile2
-rw-r--r--games/jvgs/Makefile2
-rw-r--r--games/kmancala/Makefile2
-rw-r--r--games/knights-kde4/Makefile2
-rw-r--r--games/ksudoku/Makefile2
-rw-r--r--games/meandmyshadow/Makefile2
-rw-r--r--games/megaglest/Makefile2
-rw-r--r--games/memonix/Makefile2
-rw-r--r--games/minetest/Makefile2
-rw-r--r--games/odamex/Makefile2
-rw-r--r--games/openastromenace/Makefile2
-rw-r--r--games/openlierox/Makefile2
-rw-r--r--games/opensonic/Makefile2
-rw-r--r--games/palomino/Makefile2
-rw-r--r--games/plee-the-bear/Makefile2
-rw-r--r--games/spring/Makefile2
-rw-r--r--games/springlobby/Makefile2
-rw-r--r--games/stratagus/Makefile3
-rw-r--r--games/sumwars/Makefile3
-rw-r--r--games/supertux-devel/Makefile2
-rw-r--r--games/supertuxkart/Makefile2
-rw-r--r--games/tmw/Makefile2
-rw-r--r--games/valyriatear/Makefile2
-rw-r--r--games/vavoom/Makefile2
-rw-r--r--games/violetland/Makefile2
-rw-r--r--games/wesnoth/Makefile2
-rw-r--r--games/widelands/Makefile3
38 files changed, 38 insertions, 43 deletions
diff --git a/games/arx-libertatis/Makefile b/games/arx-libertatis/Makefile
index 550bdab1d09b..e805603040a9 100644
--- a/games/arx-libertatis/Makefile
+++ b/games/arx-libertatis/Makefile
@@ -22,7 +22,7 @@ USE_XZ= yes
USE_OPENAL= yes
USE_SDL= sdl
USE_GL= gl glu
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR="man" -DDATA_DIR=arx
MAKE_JOBS_SAFE= yes
diff --git a/games/asteroid/Makefile b/games/asteroid/Makefile
index cccd6ab558d7..ed89840a8710 100644
--- a/games/asteroid/Makefile
+++ b/games/asteroid/Makefile
@@ -21,8 +21,7 @@ USE_SDL= mixer sdl
USE_GNOME= gtk20
USE_XORG= xmu
INSTALLS_ICONS= yes
-USE_CMAKE= yes
-CMAKE_VERBOSE= yes
+USES= cmake
PORTDOCS= AUTHORS NEWS README.md
diff --git a/games/blinkensisters/Makefile b/games/blinkensisters/Makefile
index bf85c339960e..409a766db315 100644
--- a/games/blinkensisters/Makefile
+++ b/games/blinkensisters/Makefile
@@ -16,7 +16,7 @@ COMMENT= Parallax-style 2D scrolling platform game
USE_SDL= sdl image ttf
USE_PERL5_BUILD= yes
-USE_CMAKE= yes
+USES= cmake
CFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -I${LOCALBASE}/include
diff --git a/games/blobby/Makefile b/games/blobby/Makefile
index 36a7279c85b2..dcecc29e170f 100644
--- a/games/blobby/Makefile
+++ b/games/blobby/Makefile
@@ -24,7 +24,7 @@ BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
USE_XORG= ice x11 xext xxf86vm xdamage xfixes xau xdmcp xrandr xrender
USE_SDL= sdl
USE_GL= glu
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS+= -DDATADIR:PATH="${DATADIR}"
WRKSRC= ${WRKDIR}/blobby-1.0rc1
diff --git a/games/corsix-th/Makefile b/games/corsix-th/Makefile
index 713161ad8240..58e8dd64def7 100644
--- a/games/corsix-th/Makefile
+++ b/games/corsix-th/Makefile
@@ -16,7 +16,7 @@ LICENSE= MIT
LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
-USE_CMAKE= yes
+USES= cmake
USE_LUA= yes
USE_SDL= mixer
diff --git a/games/flare/Makefile b/games/flare/Makefile
index f22c7dbd1549..26896e0e94f6 100644
--- a/games/flare/Makefile
+++ b/games/flare/Makefile
@@ -17,7 +17,7 @@ COMMENT= Free Libre Action Roleplaying Engine
LICENSE= GPLv3
-USE_CMAKE= yes
+USES= cmake
USE_SDL= sdl mixer image ttf
MAKE_JOBS_SAFE= yes
CMAKE_BUILD_TYPE= #empty
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index 4afd3d6e5b9a..3db2b92878c5 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -30,7 +30,7 @@ USE_BZIP2= yes
USE_XORG= ice sm x11 xext xft xi xinerama xt xmu
USE_GL= gl glu glut
USE_OPENAL= al alut
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS+= -DJPEG_FACTORY:BOOL=ON \
-DFG_DATA_DIR:PATH=${LOCALBASE}/share/${PORTNAME} \
-DCMAKE_INSTALL_MANDIR:PATH=${MANPREFIX}/man
diff --git a/games/freecell-solver/Makefile b/games/freecell-solver/Makefile
index 29fdf71250a6..3bf50ddcd8ef 100644
--- a/games/freecell-solver/Makefile
+++ b/games/freecell-solver/Makefile
@@ -17,7 +17,7 @@ TCMALLOC_DESC= Use Google's TCMalloc
USE_BZIP2= yes
USE_PERL5_BUILD=yes
-USE_CMAKE= yes
+USES= cmake
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
diff --git a/games/gemrb/Makefile b/games/gemrb/Makefile
index a8d998d1eec5..785973467499 100644
--- a/games/gemrb/Makefile
+++ b/games/gemrb/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
vorbis:${PORTSDIR}/audio/libvorbis
-USE_CMAKE= yes
+USES= cmake
USE_SDL= sdl mixer ttf
USE_OPENAL= al alut
USE_LDCONFIG= yes
diff --git a/games/golly/Makefile b/games/golly/Makefile
index 1ca6c3b4eae4..2060416b3fb2 100644
--- a/games/golly/Makefile
+++ b/games/golly/Makefile
@@ -10,11 +10,10 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= makc@FreeBSD.org
COMMENT= Conway's Game of Life and other cellular automata
-USE_CMAKE= yes
+USES= cmake:outsource
USE_PERL5= yes
USE_PYTHON= 2.7+
USE_WX= 2.8+
-CMAKE_OUTSOURCE= yes
MAKE_JOBS_SAFE= yes
DESKTOP_ENTRIES= "Golly" "${COMMENT}" "${PREFIX}/share/pixmaps/golly.xpm" \
diff --git a/games/hedgewars/Makefile b/games/hedgewars/Makefile
index da0bf2dbd53e..95238bc1a831 100644
--- a/games/hedgewars/Makefile
+++ b/games/hedgewars/Makefile
@@ -20,7 +20,7 @@ ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= depends on fpc which is only available for i386 and amd64
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
USE_SDL= sdl mixer image ttf net
USE_FPC= opengl
USE_LUA= 5.1+
diff --git a/games/intensityengine/Makefile b/games/intensityengine/Makefile
index e06f7cef4ea0..d9725bb912f7 100644
--- a/games/intensityengine/Makefile
+++ b/games/intensityengine/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
USE_BZIP2= yes
USE_SDL= sdl mixer image
USE_GL= gl glu
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
SUB_FILES= intensity_client
USE_GCC= 4.2+
diff --git a/games/jvgs/Makefile b/games/jvgs/Makefile
index ab46429feccb..399ec4e51010 100644
--- a/games/jvgs/Makefile
+++ b/games/jvgs/Makefile
@@ -14,7 +14,7 @@ COMMENT= A minimalistic platform game
BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
-USE_CMAKE= yes
+USES= cmake
USE_SDL= sdl mixer
USE_GL= gl glu
USE_LUA= 5.1+
diff --git a/games/kmancala/Makefile b/games/kmancala/Makefile
index c2f39ce4d539..e4fd6dfd0cfb 100644
--- a/games/kmancala/Makefile
+++ b/games/kmancala/Makefile
@@ -14,7 +14,7 @@ COMMENT= Board game for KDE, also known as Mancala or Kalah
LIB_DEPENDS= kdegames:${PORTSDIR}/games/kdegames4
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
USE_KDE4= kdelibs kdeprefix automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
diff --git a/games/knights-kde4/Makefile b/games/knights-kde4/Makefile
index 6bccdc8231db..63d05b64c80d 100644
--- a/games/knights-kde4/Makefile
+++ b/games/knights-kde4/Makefile
@@ -15,7 +15,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/gnuchess:${PORTSDIR}/games/gnuchess
LATEST_LINK= ${PORTNAME}-kde4
MAKE_JOBS_SAFE= yes
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
USE_KDE4= kdelibs kdehier kdeprefix automoc4 workspace
USE_QT4= qmake_build moc_build rcc_build uic_build
diff --git a/games/ksudoku/Makefile b/games/ksudoku/Makefile
index c9b15f66b314..b0b508b81748 100644
--- a/games/ksudoku/Makefile
+++ b/games/ksudoku/Makefile
@@ -20,6 +20,6 @@ EXPIRATION_DATE= 2013-07-01
USE_KDELIBS_VER=3
USE_GMAKE= yes
USE_GL= yes
-USE_CMAKE= yes
+USES= cmake
.include <bsd.port.mk>
diff --git a/games/meandmyshadow/Makefile b/games/meandmyshadow/Makefile
index 76591c3f7d6c..91fa46d61cb0 100644
--- a/games/meandmyshadow/Makefile
+++ b/games/meandmyshadow/Makefile
@@ -17,7 +17,7 @@ COMMENT= Me and My Shadow puzzle/platform game
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
-USE_CMAKE= yes
+USES= cmake
USE_SDL= sdl ttf image mixer image gfx
MAKE_JOBS_SAFE= yes
diff --git a/games/megaglest/Makefile b/games/megaglest/Makefile
index 8de4185d10a6..85d1350fe696 100644
--- a/games/megaglest/Makefile
+++ b/games/megaglest/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${DATADIR}/tutorials/2_basic_tutorial/2_basic_tutorial.xml:${PORTSD
SUB_FILES= pkg-message
USE_XZ= yes
-USE_CMAKE= yes
+USES= cmake
USE_DOS2UNIX= yes
USE_GL= glew gl glu
USE_LUA= 5.1
diff --git a/games/memonix/Makefile b/games/memonix/Makefile
index c160295b6be4..f9e4313c354d 100644
--- a/games/memonix/Makefile
+++ b/games/memonix/Makefile
@@ -27,7 +27,7 @@ LICENSE_DISTFILE_unknown= memx16.tar.gz
LICENSE_DISTFILE_GPLv2= ${DISTNAME}${EXTRACT_SUFX}
LICENSE_FILE_GPLv2= ${WRKSRC}/License.txt
-USE_CMAKE= yes
+USES= cmake
USE_ZIP= yes
USE_SDL= sdl mixer image
USE_GL= yes
diff --git a/games/minetest/Makefile b/games/minetest/Makefile
index 96164a7d0805..ad3fb3cec1d8 100644
--- a/games/minetest/Makefile
+++ b/games/minetest/Makefile
@@ -18,7 +18,7 @@ GH_ACCOUNT= celeron55
GH_TAGNAME= 0.4.4
GH_COMMIT= ab06fca
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -DCUSTOM_MANDIR="${PREFIX}/man" \
-DCUSTOM_EXAMPLE_CONF_DIR="${EXAMPLESDIR}"
MAKE_JOBS_SAFE= yes
diff --git a/games/odamex/Makefile b/games/odamex/Makefile
index 06a709142432..f22c43c568bc 100644
--- a/games/odamex/Makefile
+++ b/games/odamex/Makefile
@@ -12,7 +12,7 @@ COMMENT= The Standard in Online Multiplayer Doom
USE_BZIP2= yes
USE_SDL= sdl mixer
-USE_CMAKE= yes
+USES= cmake
USE_DOS2UNIX= CMakeLists.txt odalaunch/CMakeLists.txt common/d_main.cpp
OPTIONS_DEFINE= LAUNCHER
diff --git a/games/openastromenace/Makefile b/games/openastromenace/Makefile
index 6f13f543d74c..1af806263ccc 100644
--- a/games/openastromenace/Makefile
+++ b/games/openastromenace/Makefile
@@ -27,7 +27,7 @@ USE_GL= gl glu
USE_OPENAL= al alut
WANT_SDL= yes
USE_SDL= sdl
-USE_CMAKE= yes
+USES= cmake
WRKSRC= ${WRKDIR}/OpenAstroMenaceSVN
USE_DOS2UNIX= yes
diff --git a/games/openlierox/Makefile b/games/openlierox/Makefile
index 414cdc72365e..8844516fb5c4 100644
--- a/games/openlierox/Makefile
+++ b/games/openlierox/Makefile
@@ -26,7 +26,7 @@ CFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -DHAWKNL_BUILTIN=YES \
-DLIBZIP_BUILTIN=YES \
-DBREAKPAD=NO \
diff --git a/games/opensonic/Makefile b/games/opensonic/Makefile
index 2bd7daf18436..b2228f60bab5 100644
--- a/games/opensonic/Makefile
+++ b/games/opensonic/Makefile
@@ -22,7 +22,7 @@ DESKTOP_ENTRIES="${PORTNAME}" \
"Game;KidsGame;" \
"false"
-USE_CMAKE= yes
+USES= cmake
CMAKE_ENV+= OPENSNC_ALLEGRO_LIBS="`allegro-config --libs`" OPENSNC_ALLEGRO_VERSION="`allegro-config --version`"
CFLAGS+= -I${LOCALBASE}/include
diff --git a/games/palomino/Makefile b/games/palomino/Makefile
index 3f32c741fe7a..7a312ae52385 100644
--- a/games/palomino/Makefile
+++ b/games/palomino/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= osg:${PORTSDIR}/graphics/osg
USE_BZIP2= yes
USE_XZ= yes
USE_GL= gl
-USE_CMAKE= yes
+USES= cmake
USE_LUA= 5.1
LUA_COMPS= lua:build
MAKE_JOBS_SAFE= yes
diff --git a/games/plee-the-bear/Makefile b/games/plee-the-bear/Makefile
index 15514d1aa23f..2efaf95f1b3b 100644
--- a/games/plee-the-bear/Makefile
+++ b/games/plee-the-bear/Makefile
@@ -22,7 +22,7 @@ USE_GETTEXT= yes
MAKE_JOBS_SAFE= yes
USE_GCC= 4.6+
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -Dlibclaw_DIR="${LOCALBASE}/share/libclaw/cmake" \
-DBEAR_NO_EDITOR=YES
diff --git a/games/spring/Makefile b/games/spring/Makefile
index 11d3abea4824..6d3272303891 100644
--- a/games/spring/Makefile
+++ b/games/spring/Makefile
@@ -31,7 +31,7 @@ USE_XORG= x11 xcursor
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -DDATADIR:STRING="share/${PORTNAME}" \
-DMARCH_FLAG:STRING= \
-DAI_TYPES:STRING="NATIVE" \
diff --git a/games/springlobby/Makefile b/games/springlobby/Makefile
index cd073da8826b..ef83efd7f68f 100644
--- a/games/springlobby/Makefile
+++ b/games/springlobby/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= spring:${PORTSDIR}/games/spring
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -DwxWidgets_CONFIG_EXECUTABLE="${WX_CONFIG}" \
-DENABLE_DEBUG_REPORT=FALSE
USE_WX= 2.8+
diff --git a/games/stratagus/Makefile b/games/stratagus/Makefile
index 69ed6d91fa0b..1db79643d36f 100644
--- a/games/stratagus/Makefile
+++ b/games/stratagus/Makefile
@@ -22,8 +22,7 @@ USE_SDL= sdl
USE_SQLITE= 3
USE_LUA= 5.0+
LUA_COMPS= toluaxx
-USE_CMAKE= yes
-CMAKE_OUTSOURCE= yes
+USES= cmake:outsource
CMAKE_ARGS= -DGAMEDIR:STRING="bin" \
-DTOLUA++_APP:STRING="${TOLUAXX_CMD}" \
-DTOLUA++_INCLUDE_DIR:STRING="${LUA_INCDIR}" \
diff --git a/games/sumwars/Makefile b/games/sumwars/Makefile
index 0355d2cdda02..3dfcde165acf 100644
--- a/games/sumwars/Makefile
+++ b/games/sumwars/Makefile
@@ -27,7 +27,7 @@ LIB_DEPENDS= CEGUIBase-0.7.9.0:${PORTSDIR}/graphics/cegui \
physfs.1:${PORTSDIR}/devel/physfs
USE_GMAKE= yes
-USE_CMAKE= yes
+USES= cmake
USE_GL= gl glu
USE_GETTEXT= yes
USE_BZIP2= yes
@@ -38,7 +38,6 @@ MAKE_JOBS_SAFE= yes
FETCH_ARGS?= -pRr
-CMAKE_VERBOSE= yes
CMAKE_ARGS+= -DGETTEXT_SEARCH_PATH=${LOCALBASE}/lib
post-patch:
diff --git a/games/supertux-devel/Makefile b/games/supertux-devel/Makefile
index 1c2584701e3a..20ea6cf57ff6 100644
--- a/games/supertux-devel/Makefile
+++ b/games/supertux-devel/Makefile
@@ -18,7 +18,7 @@ USE_BZIP2= yes
USE_SDL= image mixer
USE_OPENAL= al
USE_GL= glew
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
post-patch:
diff --git a/games/supertuxkart/Makefile b/games/supertuxkart/Makefile
index b96ebea7ed85..9d0b3aef4196 100644
--- a/games/supertuxkart/Makefile
+++ b/games/supertuxkart/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= vorbisfile:${PORTSDIR}/audio/libvorbis \
USE_BZIP2= yes
USE_GL= gl glu glut
USE_OPENAL= al alut
-USE_CMAKE= yes
+USES= cmake
USE_GMAKE= yes
USE_SDL= sdl
USE_GETTEXT= yes
diff --git a/games/tmw/Makefile b/games/tmw/Makefile
index 28d257d5d0ba..bc7364d5fb12 100644
--- a/games/tmw/Makefile
+++ b/games/tmw/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
BUILD_DEPENDS= guichan>=0.8.1:${PORTSDIR}/devel/guichan
RUN_DEPENDS= guichan>=0.8.1:${PORTSDIR}/devel/guichan
-USE_CMAKE= yes
+USES= cmake
USE_SDL= sdl gfx image mixer net ttf
USE_BZIP2= yes
USE_GETTEXT= yes
diff --git a/games/valyriatear/Makefile b/games/valyriatear/Makefile
index 436e3af9d661..5e2f1d9cca42 100644
--- a/games/valyriatear/Makefile
+++ b/games/valyriatear/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs \
png15:${PORTSDIR}/graphics/png \
jpeg:${PORTSDIR}/graphics/jpeg
-USE_CMAKE= yes
+USES= cmake
USE_SDL= sdl image ttf
USE_GL= gl
USE_OPENAL= yes
diff --git a/games/vavoom/Makefile b/games/vavoom/Makefile
index d6217f0f3851..6bb578f9d77b 100644
--- a/games/vavoom/Makefile
+++ b/games/vavoom/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
OPTIONS_SINGLE= HWAPI
OPTIONS_SINGLE_HWAPI= ALLEGRO SDL
diff --git a/games/violetland/Makefile b/games/violetland/Makefile
index a9941a07a4e6..be06985ef924 100644
--- a/games/violetland/Makefile
+++ b/games/violetland/Makefile
@@ -18,7 +18,7 @@ USE_ZIP= yes
USE_SDL= sdl mixer image ttf
USE_GL= gl glu
MAKE_JOBS_SAFE= yes
-USE_CMAKE= yes
+USES= cmake
USE_GETTEXT= yes
USE_DOS2UNIX= yes
CMAKE_ARGS= -DDATA_INSTALL_DIR="${DATADIR}"
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index cc0aa487b0ac..991f4d2bcff1 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -22,7 +22,7 @@ USE_SDL= image mixer net ttf
USE_GNOME= pango desktopfileutils
MAKE_JOBS_SAFE= yes
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -DMANDIR="man"
MAN6= wesnoth.6
diff --git a/games/widelands/Makefile b/games/widelands/Makefile
index 6f678ff9eb4e..31128f4ebe9c 100644
--- a/games/widelands/Makefile
+++ b/games/widelands/Makefile
@@ -18,9 +18,8 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake:outsource
USE_GETTEXT= yes
-CMAKE_OUTSOURCE=yes
CMAKE_ARGS= -DWL_INSTALL_PREFIX="${PREFIX}" \
-DWL_INSTALL_DATADIR="share/widelands" \
-DWL_INSTALL_BINDIR="bin" \