aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2020-11-06 15:38:52 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2020-11-06 15:38:52 +0000
commit14c4513aced21c7589cf2e9a34d2ea5278f04915 (patch)
tree6dbaf63e2cda18679f2af635234c0dce7ee65070 /games
parent46dddf9e9345f52b8bc41d5bfcc4abb5346ad0c4 (diff)
Notes
Diffstat (limited to 'games')
-rw-r--r--games/pentobi/Makefile35
-rw-r--r--games/pentobi/distinfo6
-rw-r--r--games/pentobi/files/patch-pentobi_unix_CMakeLists.txt26
-rw-r--r--games/pentobi/files/patch-src_pentobi_MainWindow.cpp14
-rw-r--r--games/pentobi/files/patch-src_pentobi_RatingDialog.cpp16
-rw-r--r--games/pentobi/files/patch-src_pentobi_RatingGraph.cpp10
-rw-r--r--games/pentobi/pkg-plist62
7 files changed, 84 insertions, 85 deletions
diff --git a/games/pentobi/Makefile b/games/pentobi/Makefile
index 7910b8aac802..0e8f9f7093a0 100644
--- a/games/pentobi/Makefile
+++ b/games/pentobi/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pentobi
-PORTVERSION= 15.0
-PORTREVISION= 2
+PORTVERSION= 18.3
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
@@ -11,21 +10,41 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Computer opponent for the board game Blokus
LICENSE= GPLv3+
-LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
-USES= cmake compiler:c++11-lang desktop-file-utils qt:5 \
+BUILD_DEPENDS= itstool:textproc/itstool \
+ rsvg-convert:graphics/librsvg2 \
+ xsltproc:textproc/libxslt \
+ ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:textproc/docbook-xsl
+
+USES= compiler:c++14-lang cmake desktop-file-utils gettext-tools qt:5 \
shared-mime-info tar:xz
-USE_QT= core gui widgets svg concurrent \
+USE_QT= core gui widgets svg concurrent quickcontrols2 \
+ declarative network \
qmake_build buildtools_build linguisttools_build
+CMAKE_ARGS= -DDOCBOOK_XSL=${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl
+
+PORTDOCS= AUTHORS.md HACKING.md NEWS.md README.md
+PORTDATA= *
-PORTDOCS= NEWS
+OPTIONS_DEFINE= DOCS TEST GNOME KDE EXTERNAL_HELP
+OPTIONS_DEFAULT=EXTERNAL_HELP
+OPTIONS_SUB= yes
-OPTIONS_DEFINE= DOCS TEST
TEST_CMAKE_BOOL= PENTOBI_BUILD_TESTS
TEST_TEST_TARGET= test
+GNOME_DESC= Build Gnome thumbnailer
+GNOME_CMAKE_BOOL= PENTOBI_BUILD_THUMBNAILER
+KDE_CMAKE_BOOL= PENTOBI_BUILD_KDE_THUMBNAILER
+KDE_USES= kde:5
+KDE_USE= KDE=kio
+KDE_DESC= Build KDE thumbnailer
+EXTERNAL_HELP_DESC= Open help in web browser instead of build-in webview
+EXTERNAL_HELP_CMAKE_BOOL= PENTOBI_OPEN_HELP_EXTERNALLY
+EXTERNAL_HELP_USE_OFF= QT=webview
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/NEWS ${STAGEDIR}${DOCSDIR}/
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>
diff --git a/games/pentobi/distinfo b/games/pentobi/distinfo
index 1da02deab945..5fc9f07ceb4f 100644
--- a/games/pentobi/distinfo
+++ b/games/pentobi/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1530205156
-SHA256 (pentobi-15.0.tar.xz) = a3b25a2dd92d6bd5805466e6a4ca8837c60c8440ef91202360ed02729f70ced3
-SIZE (pentobi-15.0.tar.xz) = 421464
+TIMESTAMP = 1604576026
+SHA256 (pentobi-18.3.tar.xz) = 2bdadd21965cb8b7f580c0970900147eda3ccf866516ca9062c9305d6c68a1f7
+SIZE (pentobi-18.3.tar.xz) = 460092
diff --git a/games/pentobi/files/patch-pentobi_unix_CMakeLists.txt b/games/pentobi/files/patch-pentobi_unix_CMakeLists.txt
new file mode 100644
index 000000000000..e56a6869fd15
--- /dev/null
+++ b/games/pentobi/files/patch-pentobi_unix_CMakeLists.txt
@@ -0,0 +1,26 @@
+Disable bogus file detection
+
+- It doesn't work and there's no trivial way to fix
+ it as the path is dependent on gettext version
+ (e.g. ${LOCALBASE}/share/gettext-0.21/its/metainfo.its)
+- It's not used anywhere
+
+--- pentobi/unix/CMakeLists.txt.orig 2020-11-04 07:37:40 UTC
++++ pentobi/unix/CMakeLists.txt
+@@ -6,16 +6,6 @@ if(NOT ITSTOOL)
+ endif()
+ get_filename_component(GETTEXT_BIN_DIR ${GETTEXT_MSGFMT_EXECUTABLE} DIRECTORY)
+ get_filename_component(GETTEXT_INSTALL_DIR ${GETTEXT_BIN_DIR} DIRECTORY)
+-find_file(METAINFO_ITS NAMES metainfo.its appdata.its
+- HINTS ${GETTEXT_INSTALL_DIR}/share/gettext/its
+- )
+-if(NOT METAINFO_ITS)
+- message(FATAL_ERROR
+- "metainfo.its not found. Install appstream and/or use"
+- " -DMETAINFO_ITS=<file> to define the location of the metainfo.its"
+- " or appdata.its file."
+- )
+-endif()
+ find_program(RSVG_CONVERT rsvg-convert)
+ if(NOT RSVG_CONVERT)
+ message(FATAL_ERROR "rsvg-convert not found (install librsvg2-bin)")
diff --git a/games/pentobi/files/patch-src_pentobi_MainWindow.cpp b/games/pentobi/files/patch-src_pentobi_MainWindow.cpp
deleted file mode 100644
index 17dee5792636..000000000000
--- a/games/pentobi/files/patch-src_pentobi_MainWindow.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/pentobi/MainWindow.cpp.orig 2020-04-04 16:11:20 UTC
-+++ src/pentobi/MainWindow.cpp
-@@ -3453,7 +3453,11 @@ void MainWindow::veryGoodMove(bool checked)
-
- void MainWindow::wheelEvent(QWheelEvent* event)
- {
-+#if (QT_VERSION < QT_VERSION_CHECK(5, 14, 0))
- int delta = event->delta() / 8 / 15;
-+#else
-+ int delta = event->angleDelta().y() / 8 / 15;
-+#endif
- if (delta > 0)
- {
- if (! m_guiBoard->getSelectedPiece().is_null())
diff --git a/games/pentobi/files/patch-src_pentobi_RatingDialog.cpp b/games/pentobi/files/patch-src_pentobi_RatingDialog.cpp
deleted file mode 100644
index 16dfc95237bb..000000000000
--- a/games/pentobi/files/patch-src_pentobi_RatingDialog.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/pentobi/RatingDialog.cpp.orig 2019-09-01 15:41:49 UTC
-+++ src/pentobi/RatingDialog.cpp
-@@ -56,11 +56,11 @@ RatingDialog::RatingDialog(QWidget* parent, RatingHist
- formLayout->addRow(tr("Rated games:"), m_labelNuGames);
- m_labelBestRating = createSelectableLabel();
- formLayout->addRow(tr("Best previous rating:"), m_labelBestRating);
-- layout->addSpacing(layout->margin());
-+ layout->addSpacing(layout->spacing());
- layout->addWidget(new QLabel(tr("Recent development:")));
- m_graph = new RatingGraph;
- layout->addWidget(m_graph, 1);
-- layout->addSpacing(layout->margin());
-+ layout->addSpacing(layout->spacing());
- layout->addWidget(new QLabel(tr("Recent games:")));
- m_list = new RatedGamesList;
- layout->addWidget(m_list, 1);
diff --git a/games/pentobi/files/patch-src_pentobi_RatingGraph.cpp b/games/pentobi/files/patch-src_pentobi_RatingGraph.cpp
deleted file mode 100644
index 159340e27580..000000000000
--- a/games/pentobi/files/patch-src_pentobi_RatingGraph.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/pentobi/RatingGraph.cpp.orig 2020-05-21 09:54:38 UTC
-+++ src/pentobi/RatingGraph.cpp
-@@ -13,6 +13,7 @@
- #include <QApplication>
- #include <QDesktopWidget>
- #include <QPainter>
-+#include <QPainterPath>
- #include <QPen>
-
- //-----------------------------------------------------------------------------
diff --git a/games/pentobi/pkg-plist b/games/pentobi/pkg-plist
index d42fac7f1539..4e0d6b5b88ad 100644
--- a/games/pentobi/pkg-plist
+++ b/games/pentobi/pkg-plist
@@ -1,7 +1,14 @@
bin/pentobi
-bin/pentobi-thumbnailer
-man/man6/pentobi-thumbnailer.6.gz
+%%GNOME%%bin/pentobi-thumbnailer
+%%KDE%%%%QT_PLUGINDIR%%/pentobi-thumbnail.so
+%%GNOME%%man/de/man6/pentobi-thumbnailer.6.gz
+%%GNOME%%man/es/man6/pentobi-thumbnailer.6.gz
+%%GNOME%%man/man6/pentobi-thumbnailer.6.gz
+%%GNOME%%man/ru/man6/pentobi-thumbnailer.6.gz
+man/de/man6/pentobi.6.gz
+man/es/man6/pentobi.6.gz
man/man6/pentobi.6.gz
+man/ru/man6/pentobi.6.gz
share/applications/io.sourceforge.pentobi.desktop
share/help/C/pentobi/analysis.jpg
share/help/C/pentobi/become_stronger.html
@@ -19,6 +26,7 @@ share/help/C/pentobi/index.html
share/help/C/pentobi/junior_rules.html
share/help/C/pentobi/license.html
share/help/C/pentobi/nexos_rules.html
+share/help/C/pentobi/overview.html
share/help/C/pentobi/pieces.png
share/help/C/pentobi/pieces_callisto.png
share/help/C/pentobi/pieces_gembloq.jpg
@@ -47,46 +55,32 @@ share/help/de/pentobi/index.html
share/help/de/pentobi/junior_rules.html
share/help/de/pentobi/license.html
share/help/de/pentobi/nexos_rules.html
+share/help/de/pentobi/overview.html
share/help/de/pentobi/shortcuts.html
share/help/de/pentobi/system.html
share/help/de/pentobi/trigon_rules.html
share/help/de/pentobi/user_interface.html
share/help/de/pentobi/window_menu.html
-share/icons/hicolor/16x16/apps/pentobi.png
-share/icons/hicolor/16x16/mimetypes/application-x-blokus-sgf.png
-share/icons/hicolor/32x32/apps/pentobi.png
-share/icons/hicolor/32x32/mimetypes/application-x-blokus-sgf.png
+share/help/es/pentobi/become_stronger.html
+share/help/es/pentobi/callisto_rules.html
+share/help/es/pentobi/classic_rules.html
+share/help/es/pentobi/duo_rules.html
+share/help/es/pentobi/gembloq_rules.html
+share/help/es/pentobi/index.html
+share/help/es/pentobi/junior_rules.html
+share/help/es/pentobi/license.html
+share/help/es/pentobi/nexos_rules.html
+share/help/es/pentobi/overview.html
+share/help/es/pentobi/shortcuts.html
+share/help/es/pentobi/system.html
+share/help/es/pentobi/trigon_rules.html
+share/help/es/pentobi/user_interface.html
+share/help/es/pentobi/window_menu.html
share/icons/hicolor/48x48/apps/pentobi.png
share/icons/hicolor/48x48/mimetypes/application-x-blokus-sgf.png
-share/icons/hicolor/64x64/apps/pentobi.png
-share/icons/hicolor/64x64/mimetypes/application-x-blokus-sgf.png
share/icons/hicolor/scalable/apps/pentobi.svg
share/icons/hicolor/scalable/mimetypes/application-x-blokus-sgf.svg
+%%KDE%%share/kservices5/pentobi-thumbnail.desktop
share/metainfo/io.sourceforge.pentobi.appdata.xml
share/mime/packages/pentobi-mime.xml
-%%DATADIR%%/books/book_callisto.blksgf
-%%DATADIR%%/books/book_callisto_2.blksgf
-%%DATADIR%%/books/book_callisto_3.blksgf
-%%DATADIR%%/books/book_classic.blksgf
-%%DATADIR%%/books/book_classic_2.blksgf
-%%DATADIR%%/books/book_classic_3.blksgf
-%%DATADIR%%/books/book_duo.blksgf
-%%DATADIR%%/books/book_gembloq.blksgf
-%%DATADIR%%/books/book_gembloq_2.blksgf
-%%DATADIR%%/books/book_gembloq_2_4.blksgf
-%%DATADIR%%/books/book_gembloq_3.blksgf
-%%DATADIR%%/books/book_junior.blksgf
-%%DATADIR%%/books/book_nexos.blksgf
-%%DATADIR%%/books/book_nexos_2.blksgf
-%%DATADIR%%/books/book_trigon.blksgf
-%%DATADIR%%/books/book_trigon_2.blksgf
-%%DATADIR%%/books/book_trigon_3.blksgf
-%%DATADIR%%/translations/libpentobi_gui_de.qm
-%%DATADIR%%/translations/libpentobi_gui_fr.qm
-%%DATADIR%%/translations/libpentobi_gui_nb_NO.qm
-%%DATADIR%%/translations/pentobi.qm
-%%DATADIR%%/translations/pentobi_de.qm
-%%DATADIR%%/translations/pentobi_fr.qm
-%%DATADIR%%/translations/pentobi_nb_NO.qm
-%%DATADIR%%/translations/qtbase_minimal_nb_NO.qm
-share/thumbnailers/pentobi.thumbnailer
+%%GNOME%%share/thumbnailers/pentobi.thumbnailer