aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-05-27 00:43:10 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-05-27 00:43:10 +0000
commit618664c5071d9b5113c68a880f83556295645eab (patch)
tree3b64c3c13188381f53f4a25d165cf28f5e4bafe0 /games
parentc3f4d5b9940c67219da6a995af9aa43e944b475a (diff)
downloadports-618664c5071d9b5113c68a880f83556295645eab.tar.gz
ports-618664c5071d9b5113c68a880f83556295645eab.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/ivan/Makefile2
-rw-r--r--games/nazghul/Makefile5
2 files changed, 5 insertions, 2 deletions
diff --git a/games/ivan/Makefile b/games/ivan/Makefile
index a4a1169b31e9..5432d98ec718 100644
--- a/games/ivan/Makefile
+++ b/games/ivan/Makefile
@@ -13,6 +13,8 @@ COMMENT= Graphical roguelike game
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_armv6= fails to compile: use of overloaded operator '<<' is ambiguous
+
USE_SDL= sdl
USES= gmake
GNU_CONFIGURE= yes
diff --git a/games/nazghul/Makefile b/games/nazghul/Makefile
index d47d1dee7f2f..fef0a19fad77 100644
--- a/games/nazghul/Makefile
+++ b/games/nazghul/Makefile
@@ -14,12 +14,13 @@ LICENSE= GPLv2+ # GPLv3 text bundled, but sources mention GPLv2+
LIB_DEPENDS= libpng.so:graphics/png
+BROKEN_aarch64= fails to compile: no matching function for call to cmdwin_vpush
+BROKEN_armv6= fails to compile: no matching function for call to cmdwin_vpush
+
USE_SDL= sdl image mixer
GNU_CONFIGURE= yes
USES= gmake
-BROKEN_aarch64= Fails to compile: error: no matching function for call to cmdwin_vpush
-
post-patch:
${REINPLACE_CMD} -i "" 's|malloc.h|stdlib.h|g' ${WRKSRC}/src/scheme.c