aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-02-17 01:16:11 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-02-17 01:16:11 +0000
commit6ad2f33fe108735e763c0ed87f06c0fcda93cbfb (patch)
tree630d104267fa577614960f87cf306f2773684dd2 /games
parentcd2b2ce72cd81b8c86558e9e32712d2f8cc62a17 (diff)
downloadports-6ad2f33fe108735e763c0ed87f06c0fcda93cbfb.tar.gz
ports-6ad2f33fe108735e763c0ed87f06c0fcda93cbfb.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/wesnoth/Makefile148
-rw-r--r--games/wesnoth/distinfo4
-rw-r--r--games/wesnoth/pkg-plist104
3 files changed, 82 insertions, 174 deletions
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index 35c22dc14b15..700c331688f3 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -1,13 +1,11 @@
# $FreeBSD$
PORTNAME= wesnoth
-PORTVERSION= 1.12.0
+PORTVERSION= 1.12.1
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}/${PORTNAME}-${PORTVERSION:R} \
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}/${PORTNAME}-${PORTVERSION} \
http://files.wesnoth.org/ \
- http://ports.toco-domains.de
-
-DISTNAME= ${PORTNAME}-${PORTVERSION:R}
+ http://ports.toco-domains.de/
MAINTAINER= ports@toco-domains.de
COMMENT= Fantasy turn-based strategy game
@@ -16,152 +14,62 @@ LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
- libpng.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libpng.so:${PORTSDIR}/graphics/png \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
LDFLAGS+= -L${LOCALBASE}/lib -lboost_system
USE_SDL= image mixer net ttf
USE_GNOME= pango
USES= cmake pkgconfig tar:bzip2
-CMAKE_ARGS= -DMANDIR="man"
+CMAKE_ARGS= -DMANDIR="man" -DENABLE_STRICT_COMPILATION=off
PORTDOCS= *
PORTDATA= *
-OPTIONS_DEFINE= ANA CAMPAIGN FRIBIDI LOWMEM NOTIFY OPENMP POOLALLOC PYTHON \
- RAWSOCKETS SERVER TESTS TOOLS DOCS
-
+OPTIONS_DEFINE= ANA CAMPAIGN DOCS FRIBIDI LOWMEM NLS \
+ NOTIFY OPENMP RAWSOCKETS SERVER TEST TOOLS
OPTIONS_DEFAULT= CAMPAIGN FRIBIDI NOTIFY SERVER TOOLS
+OPTIONS_SUB= yes
ANA_DESC= Asynchronous Network API (WIP)
+ANA_CMAKE_ON= -DUSE_ANA_NETWORK=on
CAMPAIGN_DESC= Campaign server
+CAMPAIGN_CMAKE_ON=-DENABLE_CAMPAIGN_SERVER=on
+DOCS_CMAKE_OFF= -DDOCDIR=none
FRIBIDI_DESC= Bidirectional support
+FRIBIDI_LIB_DEPENDS=libfribidi.so:${PORTSDIR}/converters/fribidi
+FRIBIDI_CMAKE_OFF=-DENABLE_FRIBIDI=off
LOWMEM_DESC= Reduce memory usage (disables animations)
+LOWMEM_CMAKE_ON=-DENABLE_LOW_MEM=on
+NLS_USES= gettext
+NLS_CMAKE_ON= -DLOCALEDIR=${PREFIX}/share/locale
+NLS_CMAKE_OFF= -DENABLE_NLS=off
NOTIFY_DESC= Desktop notifications
+NOTIFY_LIB_DEPENDS=libdbus-1.so:${PORTSDIR}/devel/dbus
+NOTIFY_CMAKE_OFF=-DENABLE_NOTIFICATIONS=off
OPENMP_DESC= OpenMP support
-POOLALLOC_DESC= Use wesnoth own memory allocator
-PYTHON_DESC= Python developer tools
+OPENMP_CMAKE_ON=-DENABLE_OMP=on
RAWSOCKETS_DESC= Use raw receiving sockets in multiplayer
+RAWSOCKETS_CFLAGS=-DNETWORK_USE_RAW_SOCKETS
SERVER_DESC= Server
-TESTS_DESC= Unit tests
+SERVER_CMAKE_OFF=-DENABLE_SERVER=off
+TEST_CMAKE_ON= -DENABLE_TESTS=on
TOOLS_DESC= Extra tools for artists and translators
+TOOLS_CMAKE_ON= -DENABLE_TOOLS=on
.include <bsd.port.options.mk>
-# disable strict compilation, because it will break the build
-CMAKE_ARGS+= -DENABLE_STRICT_COMPILATION=off
-
-.if ${PORT_OPTIONS:MANA}
-CMAKE_ARGS+= -DUSE_ANA_NETWORK=on
-PLIST_SUB+= ANA=""
-.else
-CMAKE_ARGS+= -DUSE_ANA_NETWORK=off
-PLIST_SUB+= ANA="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MCAMPAIGN}
-CMAKE_ARGS+= -DENABLE_CAMPAIGN_SERVER=on
-PLIST_SUB+= CAMPAIGN=""
-.else
-CMAKE_ARGS+= -DENABLE_CAMPAIGN_SERVER=off
-PLIST_SUB+= CAMPAIGN="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MFRIBIDI}
-CMAKE_ARGS+= -DENABLE_FRIBIDI=on
-LIB_DEPENDS+= libfribidi.so:${PORTSDIR}/converters/fribidi
-.else
-CMAKE_ARGS+= -DENABLE_FRIBIDI=off
-.endif
-
-.if ${PORT_OPTIONS:MLOWMEM}
-CMAKE_ARGS+= -DENABLE_LOW_MEM=on
-.else
-CMAKE_ARGS+= -DENABLE_LOW_MEM=off
-.endif
-
-.if ${PORT_OPTIONS:MNOTIFY}
-CMAKE_ARGS+= -DENABLE_NOTIFICATIONS=on
-LIB_DEPENDS+= libdbus-1.so:${PORTSDIR}/devel/dbus
-.else
-CMAKE_ARGS+= -DENABLE_NOTIFICATIONS=off
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-CMAKE_ARGS+= -DENABLE_NLS=on -DLOCALEDIR=${PREFIX}/share/locale
-USES+= gettext
-MANLANG= "" cs de en_GB es et fi fr gl hu id it lt pl ru sk \
- sr sr@ijekavian sr@ijekavianlatin sr@latin tr uk vi zh_CN zh_TW
-.if ${PORT_OPTIONS:MSERVER}
-_MANPAGES+= ${PREFIX}/man/ja/man6/wesnothd.6 \
- ${PREFIX}/man/pt_BR/man6/wesnothd.6 \
- ${PREFIX}/man/tr/man6/wesnothd.6
-.endif
-PLIST_SUB+= NLS=""
-.else
-CMAKE_ARGS+= -DENABLE_NLS=off
-PLIST_SUB+= NLS="@comment "
-.endif
-
.if ${PORT_OPTIONS:MOPENMP}
BROKEN= compilation fails with OpenMP
-CMAKE_ARGS+= -DENABLE_OMP=on
-.else
-CMAKE_ARGS+= -DENABLE_OMP=off
-.endif
-
-.if ${PORT_OPTIONS:MPOOLALLOC}
-CMAKE_ARGS+= -DENABLE_POOL_ALLOC=on
-.else
-CMAKE_ARGS+= -DENABLE_POOL_ALLOC=off
-.endif
-
-.if ${PORT_OPTIONS:MPYTHON}
-USES+= python
-CONFIGURE_ENV+= PYTHON_PREFIX=${PREFIX} \
- PYTHON_VERSION=${PYTHON_VERSION:S/python//}
-CONFIGURE_ARGS+=--enable-python-install
-PLIST_SUB+= PYTHON=""
-.else
-PLIST_SUB+= PYTHON="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MRAWSOCKETS}
-CFLAGS+= -DNETWORK_USE_RAW_SOCKETS
.endif
-.if ${PORT_OPTIONS:MSERVER}
-CMAKE_ARGS+= -DENABLE_SERVER=on
-PLIST_SUB+= SERVER=""
-.else
-CMAKE_ARGS+= -DENABLE_SERVER=off
-PLIST_SUB+= SERVER="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MTESTS}
-CMAKE_ARGS+= -DENABLE_TESTS=on
-PLIST_SUB+= TESTS=""
+.if ${PORT_OPTIONS:MTEST}
BROKEN= compilations fails with enabled TEST option
-.else
-CMAKE_ARGS+= -DENABLE_TESTS=off
-PLIST_SUB+= TESTS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MTOOLS}
-CMAKE_ARGS+= -DENABLE_TOOLS=on
-PLIST_SUB+= TOOLS=""
-.else
-CMAKE_ARGS+= -DENABLE_TOOLS=off
-PLIST_SUB+= TOOLS="@comment "
.endif
-.if empty(PORT_OPTIONS:MDOCS)
-CMAKE_ARGS+= -DDOCDIR=none
-.endif
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
post-install:
${FIND} ${STAGEDIR}${PREFIX}/man -type d -empty -delete
diff --git a/games/wesnoth/distinfo b/games/wesnoth/distinfo
index 9a5a6fadca05..2147f1adaf01 100644
--- a/games/wesnoth/distinfo
+++ b/games/wesnoth/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wesnoth-1.12.tar.bz2) = 9e2b15cf6196ae7059fc48b5483aa6973473688602958dd64211b1775b513e0a
-SIZE (wesnoth-1.12.tar.bz2) = 385428948
+SHA256 (wesnoth-1.12.1.tar.bz2) = 70404764370db05e496a4e033e09c26cdc47fa6558271d803a44c4ebb7b6efe8
+SIZE (wesnoth-1.12.1.tar.bz2) = 384386961
diff --git a/games/wesnoth/pkg-plist b/games/wesnoth/pkg-plist
index ead7c7e75fca..8296353f7d28 100644
--- a/games/wesnoth/pkg-plist
+++ b/games/wesnoth/pkg-plist
@@ -13,7 +13,7 @@ bin/wesnoth
%%TOOLS%%bin/schema_generator
%%TOOLS%%bin/schema_validator
%%TOOLS%%bin/wesmage
-%%TESTS%%bin/wesnoth_test
+%%TEST%%bin/wesnoth_test
%%SERVER%%bin/wesnothd
share/applications/wesnoth.desktop
share/applications/wesnoth_editor.desktop
@@ -1615,56 +1615,56 @@ share/applications/wesnoth_editor.desktop
%%NLS%%share/locale/zh_TW/LC_MESSAGES/wesnoth.mo
share/pixmaps/wesnoth-icon.png
share/pixmaps/wesnoth_editor-icon.png
-man/cs/man6/wesnoth.6.gz
-man/cs/man6/wesnothd.6.gz
-man/de/man6/wesnoth.6.gz
-man/de/man6/wesnothd.6.gz
-man/en_GB/man6/wesnoth.6.gz
-man/en_GB/man6/wesnothd.6.gz
-man/es/man6/wesnoth.6.gz
-man/es/man6/wesnothd.6.gz
-man/et/man6/wesnoth.6.gz
-man/et/man6/wesnothd.6.gz
-man/fi/man6/wesnoth.6.gz
-man/fi/man6/wesnothd.6.gz
-man/fr/man6/wesnoth.6.gz
-man/fr/man6/wesnothd.6.gz
-man/gl/man6/wesnoth.6.gz
-man/gl/man6/wesnothd.6.gz
-man/hu/man6/wesnoth.6.gz
-man/hu/man6/wesnothd.6.gz
-man/id/man6/wesnoth.6.gz
-man/id/man6/wesnothd.6.gz
-man/it/man6/wesnoth.6.gz
-man/it/man6/wesnothd.6.gz
-man/ja/man6/wesnothd.6.gz
-man/lt/man6/wesnoth.6.gz
-man/lt/man6/wesnothd.6.gz
+%%NLS%%man/cs/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/cs/man6/wesnothd.6.gz
+%%NLS%%man/de/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/de/man6/wesnothd.6.gz
+%%NLS%%man/en_GB/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/en_GB/man6/wesnothd.6.gz
+%%NLS%%man/es/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/es/man6/wesnothd.6.gz
+%%NLS%%man/et/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/et/man6/wesnothd.6.gz
+%%NLS%%man/fi/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/fi/man6/wesnothd.6.gz
+%%NLS%%man/fr/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/fr/man6/wesnothd.6.gz
+%%NLS%%man/gl/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/gl/man6/wesnothd.6.gz
+%%NLS%%man/hu/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/hu/man6/wesnothd.6.gz
+%%NLS%%man/id/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/id/man6/wesnothd.6.gz
+%%NLS%%man/it/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/it/man6/wesnothd.6.gz
+%%NLS%%%%SERVER%%man/ja/man6/wesnothd.6.gz
+%%NLS%%man/lt/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/lt/man6/wesnothd.6.gz
man/man6/wesnoth.6.gz
-man/man6/wesnothd.6.gz
-man/pl/man6/wesnoth.6.gz
-man/pl/man6/wesnothd.6.gz
-man/pt/man6/wesnoth.6.gz
-man/pt/man6/wesnothd.6.gz
-man/pt_BR/man6/wesnothd.6.gz
-man/ru/man6/wesnoth.6.gz
-man/ru/man6/wesnothd.6.gz
-man/sk/man6/wesnoth.6.gz
-man/sk/man6/wesnothd.6.gz
-man/sr/man6/wesnoth.6.gz
-man/sr/man6/wesnothd.6.gz
-man/sr@ijekavian/man6/wesnoth.6.gz
-man/sr@ijekavian/man6/wesnothd.6.gz
-man/sr@ijekavianlatin/man6/wesnoth.6.gz
-man/sr@ijekavianlatin/man6/wesnothd.6.gz
-man/sr@latin/man6/wesnoth.6.gz
-man/sr@latin/man6/wesnothd.6.gz
-man/tr/man6/wesnothd.6.gz
-man/uk/man6/wesnoth.6.gz
-man/uk/man6/wesnothd.6.gz
-man/vi/man6/wesnoth.6.gz
-man/vi/man6/wesnothd.6.gz
-man/zh_CN/man6/wesnoth.6.gz
-man/zh_CN/man6/wesnothd.6.gz
-man/zh_TW/man6/wesnothd.6.gz
+%%SERVER%%man/man6/wesnothd.6.gz
+%%NLS%%man/pl/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/pl/man6/wesnothd.6.gz
+%%NLS%%man/pt/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/pt/man6/wesnothd.6.gz
+%%NLS%%%%SERVER%%man/pt_BR/man6/wesnothd.6.gz
+%%NLS%%man/ru/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/ru/man6/wesnothd.6.gz
+%%NLS%%man/sk/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/sk/man6/wesnothd.6.gz
+%%NLS%%man/sr/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/sr/man6/wesnothd.6.gz
+%%NLS%%man/sr@ijekavian/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/sr@ijekavian/man6/wesnothd.6.gz
+%%NLS%%man/sr@ijekavianlatin/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/sr@ijekavianlatin/man6/wesnothd.6.gz
+%%NLS%%man/sr@latin/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/sr@latin/man6/wesnothd.6.gz
+%%NLS%%%%SERVER%%man/tr/man6/wesnothd.6.gz
+%%NLS%%man/uk/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/uk/man6/wesnothd.6.gz
+%%NLS%%man/vi/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/vi/man6/wesnothd.6.gz
+%%NLS%%man/zh_CN/man6/wesnoth.6.gz
+%%NLS%%%%SERVER%%man/zh_CN/man6/wesnothd.6.gz
+%%NLS%%%%SERVER%%man/zh_TW/man6/wesnothd.6.gz
%%SERVER%%@unexec rmdir /var/run/wesnothd 2>/dev/null || echo "If you are permanently removing this port, you should do a 'rm -rf /var/run/wesnothd' to remove it." | fmt