aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-02 09:45:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-02 09:45:05 +0000
commit6d09df8162ed48857b6d31be0186d831ce96b7a7 (patch)
tree22593070e0d133d3907eb78912315d035a3140d1 /games
parent8009e03e6f4437b5247d35cc1b38857cb4ff68d4 (diff)
downloadports-6d09df8162ed48857b6d31be0186d831ce96b7a7.tar.gz
ports-6d09df8162ed48857b6d31be0186d831ce96b7a7.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/chromium-bsu/Makefile1
-rw-r--r--games/glest/Makefile1
-rw-r--r--games/megaglest/Makefile2
-rw-r--r--games/openlierox/Makefile2
-rw-r--r--games/scorched3d/Makefile3
-rw-r--r--games/vavoom-extras/Makefile4
-rw-r--r--games/xteddy/Makefile8
7 files changed, 9 insertions, 12 deletions
diff --git a/games/chromium-bsu/Makefile b/games/chromium-bsu/Makefile
index 57808c8b1f61..7e5ff94c058e 100644
--- a/games/chromium-bsu/Makefile
+++ b/games/chromium-bsu/Makefile
@@ -14,6 +14,7 @@ LIB_DEPENDS= glpng:${PORTSDIR}/graphics/glpng \
fontconfig:${PORTSDIR}/x11-fonts/fontconfig
GNU_CONFIGURE= yes
+USES= pkgconfig
USE_GL= gl glu
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/games/glest/Makefile b/games/glest/Makefile
index 90bd487f72f1..a5975ff3fbb7 100644
--- a/games/glest/Makefile
+++ b/games/glest/Makefile
@@ -17,6 +17,7 @@ LIB_DEPENDS= xerces-c.27:${PORTSDIR}/textproc/xerces-c2 \
BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
RUN_DEPENDS= ${DATADIR}/servers.ini:${PORTSDIR}/games/glest-data
+USES= pkgconfig
USE_AUTOTOOLS= automake:env autoconf:env
USE_ZIP= yes
USE_OPENAL= al alut
diff --git a/games/megaglest/Makefile b/games/megaglest/Makefile
index e60f8ce93d8f..21e6f41d0de8 100644
--- a/games/megaglest/Makefile
+++ b/games/megaglest/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= ${DATADIR}/tutorials/2_basic_tutorial/2_basic_tutorial.xml:${PORTSD
SUB_FILES= pkg-message
USE_XZ= yes
-USES= cmake
+USES= cmake pkgconfig
USE_DOS2UNIX= yes
USE_GL= glew gl glu
USE_LUA= 5.1
diff --git a/games/openlierox/Makefile b/games/openlierox/Makefile
index 26d67a91b7e8..1af4bc47e0de 100644
--- a/games/openlierox/Makefile
+++ b/games/openlierox/Makefile
@@ -26,7 +26,7 @@ CFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USES= cmake
+USES= cmake pkgconfig
CMAKE_ARGS= -DHAWKNL_BUILTIN=YES \
-DLIBZIP_BUILTIN=YES \
-DBREAKPAD=NO \
diff --git a/games/scorched3d/Makefile b/games/scorched3d/Makefile
index 91da1f1fb03e..1a667c25b07b 100644
--- a/games/scorched3d/Makefile
+++ b/games/scorched3d/Makefile
@@ -30,8 +30,7 @@ USE_OPENAL= al alut
USE_SDL= mixer net sdl
USE_WX= 2.4+
WX_CONF_ARGS= absolute
-USES= iconv perl5
-USE_GMAKE= yes
+USES= iconv perl5 gmake pkgconfig
USE_AUTOTOOLS= aclocal automake autoconf
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= --add-missing --copy --force --foreign
diff --git a/games/vavoom-extras/Makefile b/games/vavoom-extras/Makefile
index a4b0c28774c7..0d7c3b1d41a4 100644
--- a/games/vavoom-extras/Makefile
+++ b/games/vavoom-extras/Makefile
@@ -26,8 +26,8 @@ NO_BUILD= yes
NO_WRKSUBDIR= yes
NO_PACKAGE= package could be up to 661MB; set FORCE_PACKAGE if you really want it
-OPTIONS_MULTI= EXTRA
-OPTIONS_MULTI_EXTRA= MODELS SOUNDTRACKS TEXTURES DHTP
+OPTIONS_GROUP= EXTRA
+OPTIONS_GROUP_EXTRA= MODELS SOUNDTRACKS TEXTURES DHTP
MODELS_DESC= Install 3D models (17MB)
SOUNDTRACKS_DESC= Install enhanced soundtracks (482MB)
diff --git a/games/xteddy/Makefile b/games/xteddy/Makefile
index 57504ffbe3cf..c8e7a4a9fbf8 100644
--- a/games/xteddy/Makefile
+++ b/games/xteddy/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xteddy
-# Date created: 3 June 1998
-# Whom: Eckart "Isegrim" Hofmann
-#
+# Created by: Eckart "Isegrim" Hofmann
# $FreeBSD$
-# $MCom: ports/games/xteddy/Makefile,v 1.1 2006/10/04 13:16:56 ahze Exp $
PORTNAME= xteddy
PORTVERSION= 2.2
@@ -11,7 +7,7 @@ CATEGORIES= games
MASTER_SITES= http://webstaff.itn.liu.se/~stegu/xteddy/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A cuddlesome teddy for the X desktop
+COMMENT= Cuddlesome teddy for the X desktop
LICENSE= GPLv2