aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-05-20 16:58:10 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-05-20 16:58:10 +0000
commit74fa808d34ee655874151e5c38668b44f18bf58e (patch)
tree90ebb8bfb4c745a5dab712147ae21ed72a316bdb /games
parent7d974a64029f97d59fdfd74c399477c951bb6e15 (diff)
downloadports-74fa808d34ee655874151e5c38668b44f18bf58e.tar.gz
ports-74fa808d34ee655874151e5c38668b44f18bf58e.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/endless-sky/Makefile2
-rw-r--r--games/py-fife/Makefile6
-rw-r--r--games/stratagus/Makefile2
3 files changed, 8 insertions, 2 deletions
diff --git a/games/endless-sky/Makefile b/games/endless-sky/Makefile
index abf868df28f5..1d7a1ed471f6 100644
--- a/games/endless-sky/Makefile
+++ b/games/endless-sky/Makefile
@@ -17,6 +17,8 @@ LICENSE_FILE_GPLv3+ = ${WRKSRC}/license.txt
LIB_DEPENDS= libpng.so:graphics/png \
libmad.so:audio/libmad
+BROKEN_powerpc64= fails to compile: Dialog.h: 'to_string' is not a member of 'std'
+
USE_GITHUB= yes
USES= compiler:c++11-lib jpeg localbase:ldflags openal scons
diff --git a/games/py-fife/Makefile b/games/py-fife/Makefile
index 8c6e979bc239..49aeb8c78b6c 100644
--- a/games/py-fife/Makefile
+++ b/games/py-fife/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fife
PORTVERSION= 0.4.1
-PORTREVISION= 1
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= https://github.com/fifengine/fifengine/archive/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,6 +19,8 @@ LIB_DEPENDS= libvorbisfile.so:audio/libvorbis \
libboost_filesystem.so:devel/boost-libs \
libpng.so:graphics/png
+BROKEN_powerpc64= fails to compile: fifePYTHON_wrap.cxx: relocation truncated to fit
+
USES= openal:al pkgconfig cmake:outsource
USE_GL= gl
USE_SDL= sdl2 ttf2 image2
@@ -43,7 +45,7 @@ LOGGING_DESC= Logging
OPTIONS_MULTI_COMP= PYTHON LIBRARY
COMP_DESC= Building components
PYTHON_DESC= Build python extension module (need for unknown-horizons)
-LIBRARY_DESC= Build and install files for directly develop with C++
+LIBRARY_DESC= Build and install files for directly develop with C++
OPTIONS_DEFAULT= FIFECHAN ZIP LOGGING PYTHON
diff --git a/games/stratagus/Makefile b/games/stratagus/Makefile
index a903ade6e04f..ccd00f3895f7 100644
--- a/games/stratagus/Makefile
+++ b/games/stratagus/Makefile
@@ -15,6 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png \
libtolua++-${LUA_VER}.so:lang/tolua++
+BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=gnu++0x"
+
USE_GITHUB= yes
GH_ACCOUNT= Wargus