aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-06 12:12:00 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-06 12:12:00 +0000
commit7a0f4abe2be429be794564fa0ba30727d6458ef0 (patch)
treecb47117e55d8b3cfa8e1d039d125b1106964ca6e /games
parent60dbc060c34744dd55726fe83163eee3d49b4efe (diff)
downloadports-7a0f4abe2be429be794564fa0ba30727d6458ef0.tar.gz
ports-7a0f4abe2be429be794564fa0ba30727d6458ef0.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/critterding/Makefile1
-rw-r--r--games/lander/Makefile2
-rw-r--r--games/lordsawar/Makefile3
-rw-r--r--games/monkeybubble/Makefile3
4 files changed, 4 insertions, 5 deletions
diff --git a/games/critterding/Makefile b/games/critterding/Makefile
index 0a2c8bb3b210..70a6e0b4e07b 100644
--- a/games/critterding/Makefile
+++ b/games/critterding/Makefile
@@ -13,6 +13,7 @@ COMMENT= Evolving Artificial Life
LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
USE_BZIP2= yes
+USES= pkgconfig
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf:env aclocal:env automake:env libtool
USE_SDL= sdl
diff --git a/games/lander/Makefile b/games/lander/Makefile
index b4e2844f1b7f..880e12bbe81b 100644
--- a/games/lander/Makefile
+++ b/games/lander/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
boost_filesystem:${PORTSDIR}/devel/boost-libs
GNU_CONFIGURE= yes
-USES= gettext
+USES= gettext pkgconfig
USE_SDL= sdl image mixer
USE_GL= gl glu
USE_GCC= 4.2+
diff --git a/games/lordsawar/Makefile b/games/lordsawar/Makefile
index cc69772e01aa..18bb1cf5a0c8 100644
--- a/games/lordsawar/Makefile
+++ b/games/lordsawar/Makefile
@@ -16,11 +16,10 @@ LIB_DEPENDS= tar:${PORTSDIR}/devel/libtar \
uuid:${PORTSDIR}/misc/e2fsprogs-libuuid \
gnet-2:${PORTSDIR}/net/gnet2
-USES= gettext
+USES= gettext gmake pkgconfig
USE_GNOME= gnomehier gtkmm24
USE_SDL= sdl image mixer
USE_GCC= any
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-boost-includedir=${LOCALBASE}/include
diff --git a/games/monkeybubble/Makefile b/games/monkeybubble/Makefile
index 4020cdd374fa..a948ca6a1420 100644
--- a/games/monkeybubble/Makefile
+++ b/games/monkeybubble/Makefile
@@ -11,11 +11,10 @@ DISTNAME= monkey-bubble-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK2 Puzzle Bobble clone with monkeys
-USES= pathfix
+USES= pathfix gmake pkgconfig
USE_GNOME= gnomedocutils gnomeprefix intlhack \
librsvg2 libgnomeui
USE_GSTREAMER= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib