aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-05-13 23:21:37 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-05-13 23:21:37 +0000
commit7e4f41c6908ce98d98c9a87bb0998ff78c715166 (patch)
tree4ae3b8a2f12ec648a3f08b6e08e43bdddbde045b /games
parentaaf8b327e5095da79cd603bcd11cc3bb1af0e5b5 (diff)
downloadports-7e4f41c6908ce98d98c9a87bb0998ff78c715166.tar.gz
ports-7e4f41c6908ce98d98c9a87bb0998ff78c715166.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/bunnysay/Makefile2
-rw-r--r--games/crafty-tablebase-no-pawn/Makefile1
-rw-r--r--games/crafty-tablebase-pawn/Makefile1
-rw-r--r--games/flightgear-mb339-pan/Makefile2
-rw-r--r--games/redorblack/Makefile2
-rw-r--r--games/rubix/Makefile4
6 files changed, 9 insertions, 3 deletions
diff --git a/games/bunnysay/Makefile b/games/bunnysay/Makefile
index 0fdd96426f7b..2c583bc9cca8 100644
--- a/games/bunnysay/Makefile
+++ b/games/bunnysay/Makefile
@@ -12,6 +12,8 @@ COMMENT= Bunny Sign for terminals with UTF-8 support
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to compile: cc1plus: error: unrecognized command line option -std=c++11
+
USES= gmake
ALL_TARGET= bunnysay
diff --git a/games/crafty-tablebase-no-pawn/Makefile b/games/crafty-tablebase-no-pawn/Makefile
index 125c22ad7353..aae4034c9132 100644
--- a/games/crafty-tablebase-no-pawn/Makefile
+++ b/games/crafty-tablebase-no-pawn/Makefile
@@ -52,6 +52,7 @@ NO_BUILD= yes
BROKEN_aarch64= Fails to install: runaway process
BROKEN_armv6= Fails to install: runaway process
BROKEN_mips64= Fails to install: runaway process
+BROKEN_powerpc64= Fails to install: runaway process
.if !defined(WITH_TBDIR)
WITH_TBDIR= ${PREFIX}/lib/crafty/TB
diff --git a/games/crafty-tablebase-pawn/Makefile b/games/crafty-tablebase-pawn/Makefile
index 842536533730..49c2c27b46d3 100644
--- a/games/crafty-tablebase-pawn/Makefile
+++ b/games/crafty-tablebase-pawn/Makefile
@@ -44,6 +44,7 @@ NO_ARCH= yes
BROKEN_aarch64= Fails to install: runaway process
BROKEN_armv6= Fails to install: runaway process
BROKEN_mips64= Fails to install: runaway process
+BROKEN_powerpc64= Fails to install: runaway process
.if !defined(WITH_TBDIR)
WITH_TBDIR= ${PREFIX}/lib/crafty/TB
diff --git a/games/flightgear-mb339-pan/Makefile b/games/flightgear-mb339-pan/Makefile
index e698097918f8..9aa76563fd4c 100644
--- a/games/flightgear-mb339-pan/Makefile
+++ b/games/flightgear-mb339-pan/Makefile
@@ -15,6 +15,8 @@ RUN_DEPENDS= ${LOCALBASE}/share/flightgear/version:games/flightgear-data
RESTRICTED= Redistribution prohibited
+BROKEN_powerpc64= fails to build: runaway process
+
NO_BUILD= yes
USES= zip
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/games/redorblack/Makefile b/games/redorblack/Makefile
index bb58a5b4769d..4e5804f22dc9 100644
--- a/games/redorblack/Makefile
+++ b/games/redorblack/Makefile
@@ -11,6 +11,8 @@ COMMENT= Simple card game to test fortune and probability theory
LICENSE= BSD2CLAUSE
+BROKEN_powerpc64= fails to compile: deckClass.h: error: random: No such file or directory
+
PLIST_FILES= bin/redorblack
do-build:
diff --git a/games/rubix/Makefile b/games/rubix/Makefile
index 5eb7ec481339..10f120011f50 100644
--- a/games/rubix/Makefile
+++ b/games/rubix/Makefile
@@ -11,8 +11,6 @@ MASTER_SITES= http://sed.free.fr/rubix/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Another Rubik's cube game with a rather interesting interface
-BROKEN_powerpc64= Does not build
-
USES= compiler:nestedfct gmake tar:bzip2
USE_XORG= x11
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DENGLISH" \
@@ -26,7 +24,7 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
-.if (${ARCH} == mips || ${ARCH} == mips64) && ${COMPILER_TYPE} == gcc
+.if (${ARCH} == mips || ${ARCH} == mips64 || ${ARCH} == powerpc || ${ARCH} == powerpc64) && ${COMPILER_TYPE} == gcc
CFLAGS+= -fnested-functions
.endif