aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorBarbara Guida <bar@FreeBSD.org>2014-05-11 11:08:53 +0000
committerBarbara Guida <bar@FreeBSD.org>2014-05-11 11:08:53 +0000
commit8aba233f959b2306850de12a561a16eb066ee2c2 (patch)
tree6f448b14dc6a46bcfaaadc73c1776767ea83c653 /games
parentcf7a281f89b62debd4b886df5020e23a4f6961e7 (diff)
downloadports-8aba233f959b2306850de12a561a16eb066ee2c2.tar.gz
ports-8aba233f959b2306850de12a561a16eb066ee2c2.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/vavoom-extras/Makefile62
-rw-r--r--games/vavoom-extras/pkg-descr2
2 files changed, 28 insertions, 36 deletions
diff --git a/games/vavoom-extras/Makefile b/games/vavoom-extras/Makefile
index e41dd5731e5b..7d3525375be9 100644
--- a/games/vavoom-extras/Makefile
+++ b/games/vavoom-extras/Makefile
@@ -16,6 +16,8 @@ MASTER_SITES= SF/vavoom/Resources/vmodels-doom/1.4.3:vmd \
MAINTAINER= bar@FreeBSD.org
COMMENT= Doom, Doom II, Heretic, Hexen, and Strife source port (extras)
+LICENSE= GPLv2
+
RUN_DEPENDS= vavoom:${PORTSDIR}/games/vavoom
DATADIR= ${PREFIX}/share/vavoom
@@ -23,7 +25,8 @@ DATADIR= ${PREFIX}/share/vavoom
USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
-NO_PACKAGE= package could be up to 655MB; set FORCE_PACKAGE if you really want it
+LEGAL_PACKAGE= package could be up to 655MB; set FORCE_PACKAGE if you really want it
+NO_PACKAGE= ${LEGAL_PACKAGE}
OPTIONS_MULTI= EXTRA
OPTIONS_MULTI_EXTRA= MODELS SOUNDTRACKS TEXTURES
@@ -33,45 +36,34 @@ MODELS_DESC= Install 3D models (17MB)
SOUNDTRACKS_DESC= Install enhanced soundtracks (482MB)
TEXTURES_DESC= Install high resolution textures (157MB)
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+.for f in doom heretic hexen strife
+MODELS_DISTFILES+= vmodels-${f}-1.4.3${EXTRACT_SUFX}:vmd \
+ vmodels-${f}-1.4.3${EXTRACT_SUFX}:vmhr \
+ vmodels-${f}-1.4.3${EXTRACT_SUFX}:vmhx \
+ vmodels-${f}-1.4.3${EXTRACT_SUFX}:vms
+.endfor
+
+.for f in doom doom1 doom2
+TEXTURES_DISTFILES+= vtextures-${f}-1.1${EXTRACT_SUFX}:vt11
+.endfor
+
+.for f in heretic hexen plutonia strife tnt
+TEXTURES_DISTFILES+= vtextures-${f}-1.0${EXTRACT_SUFX}:vt10
+.endfor
-.if ${PORT_OPTIONS:MMODELS}
-DISTFILES+= vmodels-doom-1.4.3.zip:vmd
-DISTFILES+= vmodels-heretic-1.4.3.zip:vmhr
-DISTFILES+= vmodels-hexen-1.4.3.zip:vmhx
-DISTFILES+= vmodels-strife-1.4.3.zip:vms
-PLIST_SUB+= MODELS=""
-.else
-PLIST_SUB+= MODELS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MTEXTURES}
-. for f in doom doom1 doom2
-DISTFILES+= vtextures-${f}-1.1${EXTRACT_SUFX}:vt11
-. endfor
-. for f in heretic hexen plutonia strife tnt
-DISTFILES+= vtextures-${f}-1.0${EXTRACT_SUFX}:vt10
-. endfor
-PLIST_SUB+= TEXTURES=""
-.else
-PLIST_SUB+= TEXTURES="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MSOUNDTRACKS}
-. for f in doom1 doom2 heretic hexen tnt plutonia
-DISTFILES+= vmusic-${f}-1.0${EXTRACT_SUFX}:vmu
-. endfor
-PLIST_SUB+= SOUNDTRACKS=""
-.else
-PLIST_SUB+= SOUNDTRACKS="@comment "
-.endif
+.for f in doom1 doom2 heretic hexen tnt plutonia
+SOUNDTRACKS_DISTFILES+= vmusic-${f}-1.0${EXTRACT_SUFX}:vmu
+.endfor
+
+OPTIONS_SUB= yes
+
+.include <bsd.port.options.mk>
post-extract:
@${FIND} ${WRKSRC} -type f -name "*.txt" -delete
do-install:
- cd ${WRKSRC} && ${FIND} basev -type f \
- -exec ${INSTALL_DATA} {} ${DATADIR}/{} \;
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} basev ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>
diff --git a/games/vavoom-extras/pkg-descr b/games/vavoom-extras/pkg-descr
index 6699c841cb89..7bd334119c0d 100644
--- a/games/vavoom-extras/pkg-descr
+++ b/games/vavoom-extras/pkg-descr
@@ -6,4 +6,4 @@ This port optionally installs the following Vavoom engine additions:
For the supported games.
-WWW: http://www.vavoom-engine.com/
+WWW: http://www.vavoom-engine.com/