aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-08-02 19:39:16 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-08-02 19:39:16 +0000
commit6afbd67bd963161d75b628146d17f2da3350f432 (patch)
tree3b05e3332f17aa2192e01909a9bf6351220f818f /games
parent5e58e941e8602258375a3c26160f2d9b886af809 (diff)
downloadports-6afbd67bd963161d75b628146d17f2da3350f432.tar.gz
ports-6afbd67bd963161d75b628146d17f2da3350f432.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/windstille/Makefile47
-rw-r--r--games/windstille/distinfo3
-rw-r--r--games/windstille/files/patch-SConstruct15
-rw-r--r--games/windstille/files/patch-src-SConstruct29
-rw-r--r--games/windstille/files/patch-src-tinygettext-tinygettext.cpp11
-rw-r--r--games/windstille/files/patch-tools-SConscript20
-rw-r--r--games/windstille/pkg-descr13
-rw-r--r--games/windstille/pkg-plist299
9 files changed, 438 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index ea34aa98c76a..15862ef4649e 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -801,6 +801,7 @@
SUBDIR += warzone2100
SUBDIR += wesnoth
SUBDIR += widelands
+ SUBDIR += windstille
SUBDIR += wmeyes
SUBDIR += wmfortune
SUBDIR += wmminichess
diff --git a/games/windstille/Makefile b/games/windstille/Makefile
new file mode 100644
index 000000000000..934034448793
--- /dev/null
+++ b/games/windstille/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: windstille
+# Date created: 14 Jun 2007
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= windstille
+PORTVERSION= 0.3.0
+CATEGORIES= games
+MASTER_SITES= BERLIOS CENKES
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= Classic 2D jump-n-shoot game
+
+LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
+ physfs-1.0.1:${PORTSDIR}/devel/physfs \
+ ogg.5:${PORTSDIR}/audio/libogg \
+ vorbis.4:${PORTSDIR}/audio/libvorbis \
+ png.5:${PORTSDIR}/graphics/png \
+ GLEW.1:${PORTSDIR}/graphics/glew \
+ squirrel.0:${PORTSDIR}/lang/squirrel
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost
+
+USE_BZIP2= yes
+USE_SCONS= yes
+USE_GL= yes
+USE_SDL= sdl image
+USE_BISON= yes
+
+post-extract:
+ @${RM} -rf ${WRKSRC}/lib
+
+post-patch:
+ @cd ${WRKSRC}/src/ && ${REINPLACE_CMD} -e 's|data/|${DATADIR}/|' \
+ particles/deform_drawer.cpp windstille_main.cpp objects/shockwave.cpp
+ @${REINPLACE_CMD} -e "s|glew|GLEW|;/LIBS/s|'squirrel'|'squirrel', 'sqstdlib'|"\
+ ${WRKSRC}/src/SConscript
+ @${REINPLACE_CMD} -e 's|PHYSFS_getBaseDir()|""|' ${WRKSRC}/src/windstille_main.cpp
+ @${REINPLACE_CMD} -e 's|bison|${LOCALBASE}/bin/&|' ${WRKSRC}/tools/SConscript
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/windstille ${PREFIX}/bin/
+ ${INSTALL} -d ${DATADIR}/
+ @cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${DATADIR}/
+
+.include <bsd.port.mk>
diff --git a/games/windstille/distinfo b/games/windstille/distinfo
new file mode 100644
index 000000000000..b630d28d4da8
--- /dev/null
+++ b/games/windstille/distinfo
@@ -0,0 +1,3 @@
+MD5 (windstille-0.3.0.tar.bz2) = 8957c343fbc9d89217b00a36dd19acfd
+SHA256 (windstille-0.3.0.tar.bz2) = e1cdef80ace70a6be7beceb60e7c2d2f81860eb4262e5df88f8ecda9aee1f7e4
+SIZE (windstille-0.3.0.tar.bz2) = 11926694
diff --git a/games/windstille/files/patch-SConstruct b/games/windstille/files/patch-SConstruct
new file mode 100644
index 000000000000..9ffcdcdf605c
--- /dev/null
+++ b/games/windstille/files/patch-SConstruct
@@ -0,0 +1,15 @@
+--- SConstruct.orig Thu Jun 14 15:59:31 2007
++++ SConstruct Thu Jun 14 16:03:28 2007
+@@ -99,7 +99,11 @@
+ return output
+
+
+-conf_env = Environment()
++conf_env = Environment(**ARGUMENTS)
++conf_env.Replace(CCFLAGS = conf_env['CCFLAGS'].split())
++conf_env.Replace(CXXFLAGS = conf_env['CXXFLAGS'].split())
++conf_env.Replace(CPPPATH = conf_env['CPPPATH'].split())
++conf_env.Replace(LIBPATH = conf_env['LIBPATH'].split())
+ conf = Configure(conf_env, custom_tests = { 'Check32bit' : Check32bit })
+ if conf.Check32bit() == "64bit":
+ conf.env.Append(CXXFLAGS="-D_SQ64")
diff --git a/games/windstille/files/patch-src-SConstruct b/games/windstille/files/patch-src-SConstruct
new file mode 100644
index 000000000000..0a0e942aeafd
--- /dev/null
+++ b/games/windstille/files/patch-src-SConstruct
@@ -0,0 +1,29 @@
+--- src/SConscript.orig Wed Jun 13 07:04:35 2007
++++ src/SConscript Thu Jun 14 15:51:17 2007
+@@ -26,11 +26,10 @@
+
+ Import('conf_env')
+
+-env = Environment(CC = 'gcc',
+- CXX = 'g++',
+- CXXFLAGS = ['-O0', '-Wall', '-Werror', '-g', '-DDEBUG'] + conf_env['CXXFLAGS'])
+-
+-env.Append(CXXFLAGS = conf_env['CXXFLAGS'])
++env = conf_env.Copy()
++env.Append(LIBS = ['GL', 'GLU', 'squirrel', 'physfs', 'SDL_image', 'openal', 'glew', 'ogg', 'vorbis', 'vorbisfile', 'png'])
++env.Append(LIBPATH = ['../lib/'] )
++env.Append(CPPPATH = ['.', '..', '../lib/SQUIRREL2/include/', '../lib/glew'])
+
+ # env.Copy(LIBS = ['a', 'b'])
+
+@@ -184,9 +183,6 @@
+ 'sprite3d/sprite3d.cpp',
+ 'tinygettext/gettext.cpp',
+ 'tinygettext/tinygettext.cpp'
+-],
+-LIBS = ['GL', 'GLU', 'squirrel', 'physfs', 'SDL_image', 'openal', 'glew', 'ogg', 'vorbis', 'vorbisfile', 'png'] + env['LIBS'],
+-LIBPATH = ['../lib/'],
+-CPPPATH = env['CPPPATH'] + ['.', '..', '../lib/SQUIRREL2/include/', '../lib/glew'])
++])
+
+ # EOF #
diff --git a/games/windstille/files/patch-src-tinygettext-tinygettext.cpp b/games/windstille/files/patch-src-tinygettext-tinygettext.cpp
new file mode 100644
index 000000000000..db289b32adca
--- /dev/null
+++ b/games/windstille/files/patch-src-tinygettext-tinygettext.cpp
@@ -0,0 +1,11 @@
+--- src/tinygettext/tinygettext.cpp.orig Sat Jul 2 19:58:07 2005
++++ src/tinygettext/tinygettext.cpp Thu Jun 14 16:12:51 2007
+@@ -50,7 +50,7 @@
+ strcpy(in_orig, text.c_str());
+
+ char* out = out_orig;
+- ICONV_CONST char* in = in_orig;
++ const char* in = in_orig;
+ size_t out_len_temp = out_len; // iconv is counting down the bytes it has
+ // written from this...
+
diff --git a/games/windstille/files/patch-tools-SConscript b/games/windstille/files/patch-tools-SConscript
new file mode 100644
index 000000000000..6730fd0caab3
--- /dev/null
+++ b/games/windstille/files/patch-tools-SConscript
@@ -0,0 +1,20 @@
+--- tools/SConscript.orig Thu Jun 22 19:15:05 2006
++++ tools/SConscript Fri Jun 15 00:09:36 2007
+@@ -2,9 +2,14 @@
+
+ import glob
+
+-env = Environment(CPPPATH=['../..'],
+- CXXFILESUFFIX = ".cpp",
+- YACCFLAGS=['-d', '--no-lines'])
++Import('conf_env')
++
++env = conf_env.Copy()
++env.Append(CPPPATH=['../..'])
++env.Replace(CXXFILESUFFIX = ".cpp")
++env.Replace(YACCFLAGS = ['-d', '--no-lines'])
++env.Replace(YACC = 'bison')
++
+ miniswig = env.Program('miniswig/miniswig',
+ ['miniswig/parser.yy',
+ 'miniswig/lexer.ll',
diff --git a/games/windstille/pkg-descr b/games/windstille/pkg-descr
new file mode 100644
index 000000000000..0a5777d62292
--- /dev/null
+++ b/games/windstille/pkg-descr
@@ -0,0 +1,13 @@
+In Windstille the player will be placed in a foreign alien world
+and has to find its way back into safety. Special focus will be on
+getting the foreign world and the players character itself believable.
+Exploration will be more needed than plain shoot action, even so
+the players-character will be equipped with a multifunctional
+war-suit, so he will be far from defenseless. The game will have
+slow placed explore and seak sequences as well as more rough section
+that will feature fast shoot and jump action. The game world should
+be presented in a consistent state, enemies once destroyed should
+not respawn automatically. The player is free to go forward and
+backward in the world as long as the level design allows it.
+
+WWW: http://windstille.berlios.de
diff --git a/games/windstille/pkg-plist b/games/windstille/pkg-plist
new file mode 100644
index 000000000000..f6e52936c689
--- /dev/null
+++ b/games/windstille/pkg-plist
@@ -0,0 +1,299 @@
+bin/windstille
+%%DATADIR%%/Jamfile
+%%DATADIR%%/addcolor.scm
+%%DATADIR%%/controller/gamepad.scm
+%%DATADIR%%/controller/gamepad2.scm
+%%DATADIR%%/controller/keyboard.scm
+%%DATADIR%%/coroutine.rb
+%%DATADIR%%/fonts/COPYRIGHT.TXT
+%%DATADIR%%/fonts/Vera.ttf
+%%DATADIR%%/fonts/VeraMoBd.ttf
+%%DATADIR%%/fonts/VeraMono.ttf
+%%DATADIR%%/game.rb
+%%DATADIR%%/game.scm
+%%DATADIR%%/helper.scm
+%%DATADIR%%/images/.cvsignore
+%%DATADIR%%/images/404.png
+%%DATADIR%%/images/arrow.png
+%%DATADIR%%/images/arrow.sprite
+%%DATADIR%%/images/black.png
+%%DATADIR%%/images/bomb.png
+%%DATADIR%%/images/bomb1.png
+%%DATADIR%%/images/bombhighlight.png
+%%DATADIR%%/images/bomblight.png
+%%DATADIR%%/images/caustic/01.png
+%%DATADIR%%/images/caustic/02.png
+%%DATADIR%%/images/caustic/03.png
+%%DATADIR%%/images/caustic/04.png
+%%DATADIR%%/images/caustic/05.png
+%%DATADIR%%/images/caustic/06.png
+%%DATADIR%%/images/caustic/07.png
+%%DATADIR%%/images/caustic/08.png
+%%DATADIR%%/images/caustic/09.png
+%%DATADIR%%/images/caustic/10.png
+%%DATADIR%%/images/caustic/11.png
+%%DATADIR%%/images/caustic/12.png
+%%DATADIR%%/images/caustic/13.png
+%%DATADIR%%/images/caustic/14.png
+%%DATADIR%%/images/caustic/15.png
+%%DATADIR%%/images/caustic/16.png
+%%DATADIR%%/images/caustic/17.png
+%%DATADIR%%/images/caustic/18.png
+%%DATADIR%%/images/caustic/19.png
+%%DATADIR%%/images/caustic/20.png
+%%DATADIR%%/images/caustic/21.png
+%%DATADIR%%/images/caustic/22.png
+%%DATADIR%%/images/caustic/23.png
+%%DATADIR%%/images/caustic/24.png
+%%DATADIR%%/images/caustic/25.png
+%%DATADIR%%/images/caustic/26.png
+%%DATADIR%%/images/caustic/27.png
+%%DATADIR%%/images/caustic/28.png
+%%DATADIR%%/images/caustic/29.png
+%%DATADIR%%/images/caustic/30.png
+%%DATADIR%%/images/caustic/31.png
+%%DATADIR%%/images/caustic/32.png
+%%DATADIR%%/images/colltest.png
+%%DATADIR%%/images/colltest2.png
+%%DATADIR%%/images/controldialog.png
+%%DATADIR%%/images/energy_bar.png
+%%DATADIR%%/images/exit.png
+%%DATADIR%%/images/explolight.png
+%%DATADIR%%/images/explosion.png
+%%DATADIR%%/images/flashlighthighlight.png
+%%DATADIR%%/images/flashlighthighlight.sprite
+%%DATADIR%%/images/flashlightlight.png
+%%DATADIR%%/images/flashlightlight.sprite
+%%DATADIR%%/images/greychess.png
+%%DATADIR%%/images/groundset.png
+%%DATADIR%%/images/groundset2.png
+%%DATADIR%%/images/hedgehog.png
+%%DATADIR%%/images/hedgehog1.png
+%%DATADIR%%/images/hedgehog_die1.png
+%%DATADIR%%/images/hedgehog_die2.png
+%%DATADIR%%/images/hedgehog_die3.png
+%%DATADIR%%/images/hedgehog_die4.png
+%%DATADIR%%/images/hedgehog_die5.png
+%%DATADIR%%/images/hedgehog_highlight.png
+%%DATADIR%%/images/hedgehog_light.png
+%%DATADIR%%/images/industrialset.png
+%%DATADIR%%/images/inventory/flashlight.png
+%%DATADIR%%/images/inventory/granate.png
+%%DATADIR%%/images/inventory/keycard.png
+%%DATADIR%%/images/inventory/pda.png
+%%DATADIR%%/images/inventory/slot.png
+%%DATADIR%%/images/inventory/slot.sprite
+%%DATADIR%%/images/inventory/slothighlight.png
+%%DATADIR%%/images/inventory/slothighlight.sprite
+%%DATADIR%%/images/inventory/stone.png
+%%DATADIR%%/images/laserpointer.png
+%%DATADIR%%/images/laserpointer.sprite
+%%DATADIR%%/images/laserpointer_light.png
+%%DATADIR%%/images/laserpointer_light.sprite
+%%DATADIR%%/images/light.png
+%%DATADIR%%/images/light1.png
+%%DATADIR%%/images/light2.png
+%%DATADIR%%/images/light3.png
+%%DATADIR%%/images/light3.sprite
+%%DATADIR%%/images/logo.png
+%%DATADIR%%/images/logo_black.png
+%%DATADIR%%/images/logo_large.png
+%%DATADIR%%/images/menu_background.jpg
+%%DATADIR%%/images/nightvision.png
+%%DATADIR%%/images/noise.png
+%%DATADIR%%/images/noise2.png
+%%DATADIR%%/images/noise3.png
+%%DATADIR%%/images/objects/apartmentlamp.png
+%%DATADIR%%/images/objects/apartmentlamp.sprite
+%%DATADIR%%/images/objects/apartmentlamp_highlight.png
+%%DATADIR%%/images/objects/apartmentlamp_highlight.sprite
+%%DATADIR%%/images/objects/apartmentlamp_light.png
+%%DATADIR%%/images/objects/apartmentlamp_light.sprite
+%%DATADIR%%/images/objects/bar.png
+%%DATADIR%%/images/objects/box.png
+%%DATADIR%%/images/objects/box.sprite
+%%DATADIR%%/images/objects/cabinet.png
+%%DATADIR%%/images/objects/elevatordoor.png
+%%DATADIR%%/images/objects/elevatordoor_left.png
+%%DATADIR%%/images/objects/elevatordoor_right.png
+%%DATADIR%%/images/objects/northernstar.svg
+%%DATADIR%%/images/objects/northernstarjoinnow.png
+%%DATADIR%%/images/objects/painting1.png
+%%DATADIR%%/images/objects/painting1.sprite
+%%DATADIR%%/images/objects/painting2.png
+%%DATADIR%%/images/objects/painting2.sprite
+%%DATADIR%%/images/objects/painting3.png
+%%DATADIR%%/images/objects/painting3.sprite
+%%DATADIR%%/images/objects/painting4.png
+%%DATADIR%%/images/objects/plant.png
+%%DATADIR%%/images/objects/showerdoors.png
+%%DATADIR%%/images/objects/vrdoor-color.png
+%%DATADIR%%/images/objects/vrdoor-color.sprite
+%%DATADIR%%/images/objects/vrdoor-highlight.png
+%%DATADIR%%/images/objects/vrdoor-highlight.sprite
+%%DATADIR%%/images/particles/deform.png
+%%DATADIR%%/images/particles/deform2.png
+%%DATADIR%%/images/particles/fire_light.png
+%%DATADIR%%/images/particles/smoke.png
+%%DATADIR%%/images/particles/smoke2.png
+%%DATADIR%%/images/particles/snow.png
+%%DATADIR%%/images/particles/snow.xcf
+%%DATADIR%%/images/particles/snow2.png
+%%DATADIR%%/images/planet.jpg
+%%DATADIR%%/images/planet.sprite
+%%DATADIR%%/images/portrait.png
+%%DATADIR%%/images/portraits/barrobot.png
+%%DATADIR%%/images/portraits/bob.png
+%%DATADIR%%/images/portraits/jane.png
+%%DATADIR%%/images/portraits/monster.png
+%%DATADIR%%/images/portraits/powersuit.png
+%%DATADIR%%/images/portraits/sophie.png
+%%DATADIR%%/images/portraits/worker.png
+%%DATADIR%%/images/portraits/yagor.png
+%%DATADIR%%/images/spider_mine.png
+%%DATADIR%%/images/spider_mine.sprite
+%%DATADIR%%/images/streetlamp-highlight.png
+%%DATADIR%%/images/streetlamp-highlight.sprite
+%%DATADIR%%/images/streetlamp-light.png
+%%DATADIR%%/images/streetlamp-light.sprite
+%%DATADIR%%/images/streetlamp.png
+%%DATADIR%%/images/streetlamp.sprite
+%%DATADIR%%/images/textures/water.png
+%%DATADIR%%/images/tiles/apartment-background.png
+%%DATADIR%%/images/tiles/apartment-foreground.png
+%%DATADIR%%/images/tiles/bluestone.png
+%%DATADIR%%/images/tiles/forestground.png
+%%DATADIR%%/images/tiles/groundset.png
+%%DATADIR%%/images/tiles/industrial.png
+%%DATADIR%%/images/tiles/notile.png
+%%DATADIR%%/images/tiles/tile23.png
+%%DATADIR%%/images/tiles/tile40.png
+%%DATADIR%%/images/tiles/tile41.png
+%%DATADIR%%/images/tiles/tile42.png
+%%DATADIR%%/images/tiles/tile43.png
+%%DATADIR%%/images/tiles/tile44.png
+%%DATADIR%%/images/tiles/tile45.png
+%%DATADIR%%/images/tiles/tile46.png
+%%DATADIR%%/images/tiles/virtualreality-background.png
+%%DATADIR%%/images/tiles/virtualreality-foreground.png
+%%DATADIR%%/images/tiles/virtualreality-highlight.png
+%%DATADIR%%/images/titlescreen.png
+%%DATADIR%%/images/unknown.png
+%%DATADIR%%/images/verdana11_blue.png
+%%DATADIR%%/images/verdana32_blue.png
+%%DATADIR%%/images/verdana32_blueh.png
+%%DATADIR%%/images/verdana48_blue.png
+%%DATADIR%%/images/verdana48_blueh.png
+%%DATADIR%%/images/virtualreality-background.png
+%%DATADIR%%/images/virtualreality-highlight.png
+%%DATADIR%%/images/virtualreality.png
+%%DATADIR%%/images/wallpaper.png
+%%DATADIR%%/images/watersplash.png
+%%DATADIR%%/levels/apartment.wst
+%%DATADIR%%/levels/bluestone.wst
+%%DATADIR%%/levels/forest.wst
+%%DATADIR%%/levels/industrial.wst
+%%DATADIR%%/levels/intro.nut
+%%DATADIR%%/levels/intro.wst
+%%DATADIR%%/levels/newformat2.nut
+%%DATADIR%%/levels/newformat2.wst
+%%DATADIR%%/levels/virtualreality.wst
+%%DATADIR%%/locale/de.po
+%%DATADIR%%/models/characters/bob/bob.wsprite
+%%DATADIR%%/models/characters/bob/body.png
+%%DATADIR%%/models/characters/bob/head.png
+%%DATADIR%%/models/characters/jane/jane.wsprite
+%%DATADIR%%/models/characters/jane/suit2-texture.png
+%%DATADIR%%/models/characters/jane/texture1.png
+%%DATADIR%%/models/characters/monster/monster.wsprite
+%%DATADIR%%/models/characters/monster/monstertexture.png
+%%DATADIR%%/models/characters/powersuit/powersuit.wsprite
+%%DATADIR%%/models/characters/powersuit/powersuittexture.png
+%%DATADIR%%/models/characters/sophie/headtexture.png
+%%DATADIR%%/models/characters/sophie/sophie.wsprite
+%%DATADIR%%/models/characters/sophie/sophietexture.png
+%%DATADIR%%/models/characters/spider/spider.wsprite
+%%DATADIR%%/models/characters/spider/spidertexture.png
+%%DATADIR%%/models/characters/vrdummy/vrdummy.wsprite
+%%DATADIR%%/models/characters/vrdummy/vrdummytexture.png
+%%DATADIR%%/models/characters/yagor/clothtexture.png
+%%DATADIR%%/models/characters/yagor/facetexture.png
+%%DATADIR%%/models/characters/yagor/yagor.wsprite
+%%DATADIR%%/models/objects/barrobot/barrobotsprite.png
+%%DATADIR%%/models/objects/grenade/grenade.wsprite
+%%DATADIR%%/models/objects/grenade/grenadetexture.png
+%%DATADIR%%/models/objects/pistol/pistol.wsprite
+%%DATADIR%%/models/objects/pistol/pistoltexture.png
+%%DATADIR%%/models/vehicles/shuttle/shuttle.wsprite
+%%DATADIR%%/models/vehicles/train/texture.png
+%%DATADIR%%/models/vehicles/train/train.wsprite
+%%DATADIR%%/music/Windstille_Ralph_Weinert.ogg
+%%DATADIR%%/music/jingle.ogg
+%%DATADIR%%/music/nightfall.ogg
+%%DATADIR%%/music/silence_wip.ogg
+%%DATADIR%%/music/techdemo.ogg
+%%DATADIR%%/particlesystems/deform.particles
+%%DATADIR%%/particlesystems/fire.particles
+%%DATADIR%%/scripts/apartment/barrobot.nut
+%%DATADIR%%/scripts/apartment/init.nut
+%%DATADIR%%/scripts/apartment/yagor.nut
+%%DATADIR%%/scripts/init.nut
+%%DATADIR%%/scripts/init_script_vars.nut
+%%DATADIR%%/scripts/newformat2/bob.nut
+%%DATADIR%%/scripts/newformat2/frank.nut
+%%DATADIR%%/scripts/windstille.nut
+%%DATADIR%%/shader/blacknwhite.frag
+%%DATADIR%%/shader/particledeform.frag
+%%DATADIR%%/shader/shockwave.frag
+%%DATADIR%%/shader/shockwave2.frag
+%%DATADIR%%/shader/simple.frag
+%%DATADIR%%/shader/wooble.frag
+%%DATADIR%%/sounds/README
+%%DATADIR%%/sounds/elevator.ogg
+%%DATADIR%%/sounds/fizzle.wav
+%%DATADIR%%/sounds/menu_change.wav
+%%DATADIR%%/sounds/menu_click.wav
+%%DATADIR%%/sounds/speech/vr_intro.ogg
+%%DATADIR%%/sounds/steps_dirt.ogg
+%%DATADIR%%/tiles.scm
+%%DATADIR%%/windstille.scm
+%%DATADIR%%/windstille.scr
+@dirrm %%DATADIR%%/sounds/speech
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/shader
+@dirrm %%DATADIR%%/scripts/newformat2
+@dirrm %%DATADIR%%/scripts/apartment
+@dirrm %%DATADIR%%/scripts
+@dirrm %%DATADIR%%/particlesystems
+@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/models/weapons
+@dirrm %%DATADIR%%/models/vehicles/train
+@dirrm %%DATADIR%%/models/vehicles/shuttle
+@dirrm %%DATADIR%%/models/vehicles
+@dirrm %%DATADIR%%/models/objects/pistol
+@dirrm %%DATADIR%%/models/objects/grenade
+@dirrm %%DATADIR%%/models/objects/barrobot
+@dirrm %%DATADIR%%/models/objects
+@dirrm %%DATADIR%%/models/characters/yagor
+@dirrm %%DATADIR%%/models/characters/vrdummy
+@dirrm %%DATADIR%%/models/characters/spider
+@dirrm %%DATADIR%%/models/characters/sophie
+@dirrm %%DATADIR%%/models/characters/powersuit
+@dirrm %%DATADIR%%/models/characters/monster
+@dirrm %%DATADIR%%/models/characters/jane
+@dirrm %%DATADIR%%/models/characters/bob
+@dirrm %%DATADIR%%/models/characters
+@dirrm %%DATADIR%%/models
+@dirrm %%DATADIR%%/locale
+@dirrm %%DATADIR%%/levels
+@dirrm %%DATADIR%%/images/tiles
+@dirrm %%DATADIR%%/images/textures
+@dirrm %%DATADIR%%/images/portraits
+@dirrm %%DATADIR%%/images/particles
+@dirrm %%DATADIR%%/images/objects
+@dirrm %%DATADIR%%/images/inventory
+@dirrm %%DATADIR%%/images/caustic
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%/fonts
+@dirrm %%DATADIR%%/controller
+@dirrm %%DATADIR%%