aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-21 11:43:24 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-21 11:43:24 +0000
commitdd784984e0f798ac9d5d83a86f95a44a75963765 (patch)
tree2d5f9e30e963774d86684afbf77953ae24b1ac9f /games
parent9a4699d84b53240982b41f0c7b79b09f2eaecfda (diff)
downloadports-dd784984e0f798ac9d5d83a86f95a44a75963765.tar.gz
ports-dd784984e0f798ac9d5d83a86f95a44a75963765.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/randomshooter/Makefile11
-rw-r--r--games/randomshooter/distinfo6
-rw-r--r--games/randomshooter/files/patch-makefile23
-rw-r--r--games/randomshooter/pkg-plist2
4 files changed, 20 insertions, 22 deletions
diff --git a/games/randomshooter/Makefile b/games/randomshooter/Makefile
index 06648cad11eb..a0d09b55180d 100644
--- a/games/randomshooter/Makefile
+++ b/games/randomshooter/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= randomshooter
-DISTVERSION= 0.1-1
+DISTVERSION= 0.3-1
CATEGORIES= games
# original url: http://parallelrealities.co.uk/download.php?proj=randomShooter&file=${DISTNAME}&type=zip
MASTER_SITES= http://www.amdmi3.ru/distfiles/
-DISTNAME= RandomShooter-${DISTVERSION}
+DISTNAME= randomshooter-${DISTVERSION}
MAINTAINER= amdmi3@amdmi3.ru
COMMENT= A simple shoot'em up with online scoring and replays
@@ -18,16 +18,15 @@ COMMENT= A simple shoot'em up with online scoring and replays
USE_GMAKE= yes
USE_SDL= sdl mixer image ttf net
-WRKSRC= ${WRKDIR}/RandomShooter
+WRKSRC= ${WRKDIR}/${DISTNAME:S/-1$$//}
PORTDOCS= *
MAKEFILE= makefile
-MAKE_ENV= CXX="${CXX}"
-CXXFLAGS+= -DINSTALL_DIR=\\\"${DATADIR}/\\\"
+MAKE_ENV= CXX="${CXX}" DATADIR=${DATADIR}/
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.for dir in font gfx music
+.for dir in font gfx help music
${MKDIR} ${DATADIR}/${dir}
${INSTALL_DATA} ${WRKSRC}/${dir}/* ${DATADIR}/${dir}
.endfor
diff --git a/games/randomshooter/distinfo b/games/randomshooter/distinfo
index 8188798e950d..191cb6707789 100644
--- a/games/randomshooter/distinfo
+++ b/games/randomshooter/distinfo
@@ -1,3 +1,3 @@
-MD5 (RandomShooter-0.1-1.tar.gz) = 710d334ebaaea7336bb08cfdf61f5839
-SHA256 (RandomShooter-0.1-1.tar.gz) = 7dea906bf6573784953075a81f795451f9dcc158a834c555651698094103a759
-SIZE (RandomShooter-0.1-1.tar.gz) = 362257
+MD5 (randomshooter-0.3-1.tar.gz) = 8204901f92a9f78f17da80949e592741
+SHA256 (randomshooter-0.3-1.tar.gz) = c97eb6792b4c59036cfc440dac05c2b16ab55bdc4002a3d06409fe32e905411c
+SIZE (randomshooter-0.3-1.tar.gz) = 364623
diff --git a/games/randomshooter/files/patch-makefile b/games/randomshooter/files/patch-makefile
index 0a0eb18378a2..ab8c8e6cb70f 100644
--- a/games/randomshooter/files/patch-makefile
+++ b/games/randomshooter/files/patch-makefile
@@ -1,11 +1,15 @@
---- makefile.orig 2008-02-26 00:44:53.000000000 +0300
-+++ makefile 2008-02-27 23:28:42.000000000 +0300
-@@ -1,19 +1,19 @@
- VERSION = 0.1
+--- makefile.orig 2008-03-02 14:32:18.000000000 +0300
++++ makefile 2008-03-18 23:20:03.000000000 +0300
+@@ -1,22 +1,20 @@
+-RELEASE = 0
++RELEASE = 1
+ VERSION = 0.2
+-BINDIR = /usr/games
+-DATADIR = /usr/share/games/randomshooter/
--CFLAGS = -Wall -pedantic -Werror -DUNIX -DVERSION=$(VERSION)
+-CFLAGS = -Wall -pedantic -Werror -DUNIX -DVERSION=$(VERSION) -DINSTALL_DIR=\"$(DATADIR)\" -DRELEASE=$(RELEASE)
-LFLAGS = `sdl-config --libs` -lSDL -lSDL_mixer -lSDL_image -lSDL_ttf -lSDL_net
-+CXXFLAGS += -Wall -DUNIX -DVERSION=$(VERSION) `${SDL_CONFIG} --cflags`
++CXXFLAGS += -Wall -DUNIX -DVERSION=$(VERSION) -DINSTALL_DIR=\"$(DATADIR)\" -DRELEASE=$(RELEASE) `${SDL_CONFIG} --cflags`
+LFLAGS = `${SDL_CONFIG} --libs` -lSDL_mixer -lSDL_image -lSDL_ttf -lSDL_net
OBJS = animation.o audio.o bullets.o collisions.o colors.o draw.o enemies.o entities.o font.o game.o highscores.o
OBJS += init.o input.o main.o menu.o movement.o particles.o player.o random.o replay.o score.o screenshot.o
@@ -24,10 +28,3 @@
# linking the program.
$(PROG): $(OBJS)
-@@ -24,4 +24,4 @@
- rm $(PROG) *.o
-
- install:
-- echo "make install isn't supported yet..."
-\ No newline at end of file
-+ echo "make install isn't supported yet..."
diff --git a/games/randomshooter/pkg-plist b/games/randomshooter/pkg-plist
index 6ea4ea35f6b8..2e44066079cc 100644
--- a/games/randomshooter/pkg-plist
+++ b/games/randomshooter/pkg-plist
@@ -48,8 +48,10 @@ bin/randomshooter
%%DATADIR%%/gfx/points_frame0013.png
%%DATADIR%%/gfx/points_frame0014.png
%%DATADIR%%/gfx/points_frame0015.png
+%%DATADIR%%/help/help.txt
%%DATADIR%%/music/17.mod
@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/help
@dirrm %%DATADIR%%/gfx
@dirrm %%DATADIR%%/font
@dirrm %%DATADIR%%