aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2004-03-10 21:14:15 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2004-03-10 21:14:15 +0000
commit2fb291c94c8ead8007b1429fc3ccaa61bb4658af (patch)
treec74de3d24e15b20885a48e1176eebf56878a9ac8 /games
parent4c59237f06348a6a4c83be581d363b6536c2ea69 (diff)
downloadports-2fb291c94c8ead8007b1429fc3ccaa61bb4658af.tar.gz
ports-2fb291c94c8ead8007b1429fc3ccaa61bb4658af.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/zoom/Makefile16
-rw-r--r--games/zoom/files/patch-src_hash.c25
2 files changed, 29 insertions, 12 deletions
diff --git a/games/zoom/Makefile b/games/zoom/Makefile
index 6ae86e0a9787..baacaedaee48 100644
--- a/games/zoom/Makefile
+++ b/games/zoom/Makefile
@@ -10,33 +10,25 @@ PORTVERSION= 1.0.1a
PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.logicalshift.demon.co.uk/unix/${PORTNAME}/
-DISTFILES= ${DISTFILE_SRC} ${DISTFILE_PATCH}
-EXTRACT_ONLY= ${DISTFILE_SRC}
+DISTFILES= ${PORTNAME}-1.0.1.tar.gz
+
+PATCHFILES= zoom-1.0.1-1.0.1a.patch
+PATCH_DIST_STRIP=-p1
MAINTAINER= Jan.Stocker@t-online.de
COMMENT= Z-Interpreter for X with full V6 support
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
-NOT_FOR_ARCHS= sparc64
-
USE_PERL5= yes
USE_XLIB= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-DISTFILE_SRC= ${PORTNAME}-1.0.1.tar.gz
-DISTFILE_PATCH= zoom-1.0.1-1.0.1a.patch
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
-MAKE_ENV= ${CONFIGURE_ENV}
-
post-extract:
${MV} ${WRKDIR}/${PORTNAME}-1.0.1 ${WRKSRC}
- @cd ${WRKDIR} && \
- ${PATCH} < ${DISTDIR}/${DISTFILE_PATCH}
.include <bsd.port.mk>
diff --git a/games/zoom/files/patch-src_hash.c b/games/zoom/files/patch-src_hash.c
new file mode 100644
index 000000000000..cc00d058a048
--- /dev/null
+++ b/games/zoom/files/patch-src_hash.c
@@ -0,0 +1,25 @@
+
+$FreeBSD$
+
+--- src/hash.c.orig Thu Jul 25 20:10:02 2002
++++ src/hash.c Wed Mar 10 16:00:01 2004
+@@ -81,7 +81,7 @@
+ for (i = 0; i < 256; ++i) {
+ for (c = i << 24, j = 8; j > 0; --j)
+ c = c & 0x80000000 ? (c << 1) ^ CRC32_POLY : (c << 1);
+- crc32_table[i] = c;
++ crc32_table[i] = c & 0xffffffff;
+ }
+ }
+
+@@ -95,8 +95,8 @@
+ init_crc32(); /* build table */
+ crc = 0xffffffff; /* preload shift register, per CRC-32 spec */
+ for (p = buf; len > 0; ++p, --len)
+- crc = (crc << 8) ^ crc32_table[(crc >> 24) ^ *p];
+- return ~crc; /* transmit complement, per CRC-32 spec */
++ crc = ((crc << 8) ^ crc32_table[(crc >> 24) ^ *p]) & 0xffffffff;
++ return ~crc & 0xffffffff; /* transmit complement, per CRC-32 spec */
+ }
+
+ static struct bucket *hash_lookup(hash hash,