aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-20 14:47:26 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-20 14:47:26 +0000
commit3fed30f05651774b99f6bc8800991ea32c91ef2c (patch)
tree015f19242d308ebf8615354ac80dcab80276c2a9 /games
parentf5fb66d67899d9d036e2438269c4d9ab66bc0566 (diff)
downloadports-3fed30f05651774b99f6bc8800991ea32c91ef2c.tar.gz
ports-3fed30f05651774b99f6bc8800991ea32c91ef2c.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/quakeforge/Makefile37
-rw-r--r--games/quakeforge/pkg-plist108
2 files changed, 67 insertions, 78 deletions
diff --git a/games/quakeforge/Makefile b/games/quakeforge/Makefile
index b88a6acd8904..3723b9ca9d1f 100644
--- a/games/quakeforge/Makefile
+++ b/games/quakeforge/Makefile
@@ -37,6 +37,8 @@ USE_REINPLACE= yes
INSTALLS_SHLIB= yes
WANT_SDL= yes
+MAN1= pak.1 qfcc.1 qflight.1 qfvis.1 wad.1
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
@@ -48,7 +50,7 @@ CONFIGURE_ARGS+=--with-global-cfg=${PREFIX}/etc/quakeforge.conf \
--with-sharepath=${PREFIX}/share/quakeforge \
--disable-optimize
-BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison
+BUILD_DEPENDS+= bison:${PORTSDIR}/devel/bison
.if defined(WITH_OPTIMIZED_CFLAGS) && !defined(WITHOUT_OPTIMIZED_CFLAGS)
CFLAGS+= -O3 -funroll-loops -fomit-frame-pointer -fno-common \
@@ -74,21 +76,6 @@ WITH_XMMS= yes
WITH_VORBIS= yes
.endif
-.if defined(WITHOUT_SERVERS)
-CONFIGURE_ARGS+=--without-servers
-PLIST_SUB+= SERVER="@comment "
-.else
-PLIST_SUB+= SERVER=""
-.endif
-
-.if defined(WITHOUT_TOOLS)
-CONFIGURE_ARGS+=--without-tools
-PLIST_SUB+= TOOL="@comment "
-.else
-PLIST_SUB+= TOOL=""
-MAN1= pak.1 qfcc.1 qflight.1 qfvis.1 wad.1
-.endif
-
.if defined(WITHOUT_CLIENTS)
CONFIGURE_ARGS+=--without-clients
PLIST_SUB+= CLIENT="@comment "
@@ -137,6 +124,13 @@ CONFIGURE_ARGS+=--disable-sdl --disable-sdltest
PLIST_SUB+= SDL="@comment "
.endif
+.if defined(WITH_STATIC_PLUGINS)
+PLIST_SUB+= PLUGIN="@comment "
+CONFIGURE_ARGS+=--with-static-plugins
+.else
+PLIST_SUB+= PLUGIN=""
+.endif
+
.if !defined(NO_WAD)
PLIST_SUB+= WAD=""
.else
@@ -172,15 +166,12 @@ pre-everything::
.if !defined(WITH_SDL)
@${ECHO_MSG} "Define WITH_SDL to use SDL"
.endif
-.if !defined(WITHOUT_TOOLS)
- @${ECHO_MSG} "Define WITHOUT_TOOLS to disable building of additional tools"
-.endif
-.if !defined(WITHOUT_SERVERS)
- @${ECHO_MSG} "Define WITHOUT_SERVERS to disable building of the servers"
-.endif
.if !defined(WITHOUT_CLIENTS)
@${ECHO_MSG} "Define WITHOUT_CLIENTS to disable building of the clients"
.endif
+.if !defined(WITH_STATIC_PLUGINS)
+ @${ECHO_MSG} "Define WITH_STATIC_PLUGINS to disable building plugins as shared objects"
+.endif
post-patch:
@${REINPLACE_CMD} -e 's/-lpthread/${PTHREAD_LIBS}/g' ${WRKSRC}/configure
@@ -191,9 +182,7 @@ do-install:
${MKDIR} ${PREFIX}/share/quakeforge/id1 && \
${TAR} xzf ${DISTDIR}/${WADFILE} -C ${PREFIX}/share/quakeforge --no-same-owner id1/pak0.pak
.endif
-.if !defined(WITHOUT_SERVERS)
${TAR} xzf ${DISTDIR}/${PROGFILE} -C ${PREFIX}/share/quakeforge qw/
-.endif
.if !defined(NO_SKINS)
.for file in ${SKINFILES}
${UNZIP_CMD} -n ${DISTDIR}/${file} -d ${PREFIX}/share/quakeforge/qw/skins
diff --git a/games/quakeforge/pkg-plist b/games/quakeforge/pkg-plist
index 7475cc1f08bb..ada45395dc26 100644
--- a/games/quakeforge/pkg-plist
+++ b/games/quakeforge/pkg-plist
@@ -1,23 +1,23 @@
-%%TOOL%%bin/bsp2img
-%%SERVER%%bin/hw-master
+bin/bsp2img
+bin/hw-master
%%CLIENT%%%%SVGA%%bin/nq-3dfx
%%CLIENT%%bin/nq-glx
%%CLIENT%%%%SDL%%bin/nq-sdl
%%CLIENT%%%%SDL%%bin/nq-sdl32
-%%SERVER%%bin/nq-server
+bin/nq-server
%%CLIENT%%%%SDL%%bin/nq-sgl
%%CLIENT%%%%SVGA%%bin/nq-svga
%%CLIENT%%bin/nq-x11
-%%TOOL%%bin/pak
-%%TOOL%%bin/qfbsp
-%%TOOL%%bin/qfcc
-%%TOOL%%bin/qflight
-%%TOOL%%bin/qfmodelgen
-%%TOOL%%bin/qfpreqcc
-%%TOOL%%bin/qfprogs
-%%TOOL%%bin/qfvis
-%%TOOL%%bin/qfwavinfo
-%%SERVER%%bin/qtv
+bin/pak
+bin/qfbsp
+bin/qfcc
+bin/qflight
+bin/qfmodelgen
+bin/qfpreqcc
+bin/qfprogs
+bin/qfvis
+bin/qfwavinfo
+bin/qtv
%%CLIENT%%%%SVGA%%bin/qw-client-3dfx
%%CLIENT%%bin/qw-client-glx
%%CLIENT%%%%SDL%%bin/qw-client-sdl
@@ -25,10 +25,10 @@
%%CLIENT%%%%SDL%%bin/qw-client-sgl
%%CLIENT%%%%SVGA%%bin/qw-client-svga
%%CLIENT%%bin/qw-client-x11
-%%SERVER%%bin/qw-master
-%%SERVER%%bin/qw-server
-%%TOOL%%bin/wad
-%%TOOL%%bin/zpak
+bin/qw-master
+bin/qw-server
+bin/wad
+bin/zpak
%%CLIENT%%lib/libQFcd.a
%%CLIENT%%lib/libQFcd.so
%%CLIENT%%lib/libQFcd.so.1
@@ -74,43 +74,43 @@ lib/libQFruamoko.so.1
lib/libQFutil.a
lib/libQFutil.so
lib/libQFutil.so.1
-%%CLIENT%%lib/quakeforge/cd_file.so
-%%CLIENT%%%%SDL%%lib/quakeforge/cd_sdl.so
-%%CLIENT%%%%XMMS%%lib/quakeforge/cd_xmms.so
-lib/quakeforge/console_client.so
-lib/quakeforge/console_server.so
-%%CLIENT%%lib/quakeforge/snd_output_disk.so
-%%CLIENT%%lib/quakeforge/snd_output_oss.so
-%%CLIENT%%%%SDL%%lib/quakeforge/snd_output_sdl.so
-%%CLIENT%%lib/quakeforge/snd_render_default.so
-%%TOOL%%lib/ruamoko/libcsqc.a
-%%TOOL%%lib/ruamoko/libgui.a
-%%TOOL%%lib/ruamoko/libnq.a
-%%TOOL%%lib/ruamoko/libqw.a
-%%TOOL%%lib/ruamoko/libr.a
-%%TOOL%%share/quakeforge/QF/menu.dat.gz
+%%PLUGIN%%%%CLIENT%%lib/quakeforge/cd_file.so
+%%PLUGIN%%%%CLIENT%%%%SDL%%lib/quakeforge/cd_sdl.so
+%%PLUGIN%%%%CLIENT%%%%XMMS%%lib/quakeforge/cd_xmms.so
+%%PLUGIN%%lib/quakeforge/console_client.so
+%%PLUGIN%%lib/quakeforge/console_server.so
+%%PLUGIN%%%%CLIENT%%lib/quakeforge/snd_output_disk.so
+%%PLUGIN%%%%CLIENT%%lib/quakeforge/snd_output_oss.so
+%%PLUGIN%%%%CLIENT%%%%SDL%%lib/quakeforge/snd_output_sdl.so
+%%PLUGIN%%%%CLIENT%%lib/quakeforge/snd_render_default.so
+lib/ruamoko/libcsqc.a
+lib/ruamoko/libgui.a
+lib/ruamoko/libnq.a
+lib/ruamoko/libqw.a
+lib/ruamoko/libr.a
+share/quakeforge/QF/menu.dat.gz
%%WAD%%share/quakeforge/id1/pak0.pak
-%%SERVER%%share/quakeforge/qw/buttons.qc
-%%SERVER%%share/quakeforge/qw/client.qc
-%%SERVER%%share/quakeforge/qw/combat.qc
-%%SERVER%%share/quakeforge/qw/defs.qc
-%%SERVER%%share/quakeforge/qw/doors.qc
-%%SERVER%%share/quakeforge/qw/items.qc
-%%SERVER%%share/quakeforge/qw/misc.qc
-%%SERVER%%share/quakeforge/qw/models.qc
-%%SERVER%%share/quakeforge/qw/plats.qc
-%%SERVER%%share/quakeforge/qw/player.qc
-%%SERVER%%share/quakeforge/qw/progdefs.h
-%%SERVER%%share/quakeforge/qw/progs.src
-%%SERVER%%share/quakeforge/qw/qwprogs.dat
-%%SERVER%%share/quakeforge/qw/server.qc
-%%SERVER%%share/quakeforge/qw/spectate.qc
-%%SERVER%%share/quakeforge/qw/sprites.qc
-%%SERVER%%share/quakeforge/qw/subs.qc
-%%SERVER%%share/quakeforge/qw/triggers.qc
-%%SERVER%%share/quakeforge/qw/weapons.qc
-%%SERVER%%share/quakeforge/qw/world.qc
-%%SERVER%%share/quakeforge/qw/skins/fixskins.sh
+share/quakeforge/qw/buttons.qc
+share/quakeforge/qw/client.qc
+share/quakeforge/qw/combat.qc
+share/quakeforge/qw/defs.qc
+share/quakeforge/qw/doors.qc
+share/quakeforge/qw/items.qc
+share/quakeforge/qw/misc.qc
+share/quakeforge/qw/models.qc
+share/quakeforge/qw/plats.qc
+share/quakeforge/qw/player.qc
+share/quakeforge/qw/progdefs.h
+share/quakeforge/qw/progs.src
+share/quakeforge/qw/qwprogs.dat
+share/quakeforge/qw/server.qc
+share/quakeforge/qw/spectate.qc
+share/quakeforge/qw/sprites.qc
+share/quakeforge/qw/subs.qc
+share/quakeforge/qw/triggers.qc
+share/quakeforge/qw/weapons.qc
+share/quakeforge/qw/world.qc
+share/quakeforge/qw/skins/fixskins.sh
%%SKIN%%share/quakeforge/qw/skins/311.pcx
%%SKIN%%share/quakeforge/qw/skins/311.txt
%%SKIN%%share/quakeforge/qw/skins/amish.pcx
@@ -474,7 +474,7 @@ include/QF/ruamoko/gui/View.h
@dirrm include/QF/ruamoko/gui
@dirrm include/QF/ruamoko
@dirrm include/QF
-%%TOOL%%@dirrm lib/ruamoko
+@dirrm lib/ruamoko
@dirrm lib/quakeforge
@unexec rmdir %D/share/quakeforge/QF/ 2>/dev/null || true
@unexec rmdir %D/share/quakeforge/id1/ 2>/dev/null || true