aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-20 21:27:10 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-20 21:27:10 +0000
commit123a1077ae94b118796367b40d8d74f2d00a814c (patch)
tree5e0235912fe722d880c5b8094907c6d9ad7285c3 /games
parentffc486df06c7eda230c428c1f8761c13ee97e83c (diff)
downloadports-123a1077ae94b118796367b40d8d74f2d00a814c.tar.gz
ports-123a1077ae94b118796367b40d8d74f2d00a814c.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/crossfire-client/Makefile3
-rw-r--r--games/freedroid/Makefile7
-rw-r--r--games/jfk/Makefile4
-rw-r--r--games/pengpong/Makefile6
-rw-r--r--games/pipenightdreams/Makefile6
-rw-r--r--games/senken/Makefile4
-rw-r--r--games/uqm/Makefile5
7 files changed, 10 insertions, 25 deletions
diff --git a/games/crossfire-client/Makefile b/games/crossfire-client/Makefile
index a4b38b592905..af48e3f275a7 100644
--- a/games/crossfire-client/Makefile
+++ b/games/crossfire-client/Makefile
@@ -45,8 +45,7 @@ CONFIGURE_ARGS+= --disable-gtk
.if defined(WITHOUT_SDL)
CONFIGURE_ARGS+= --disable-sdl
.else
-LIB_DEPENDS+= SDL_image.10:${PORTSDIR}/graphics/sdl_image
-USE_SDL= yes
+USE_SDL= image sdl
.endif
post-install:
diff --git a/games/freedroid/Makefile b/games/freedroid/Makefile
index dd4a23fccf4d..46a8f15f8de0 100644
--- a/games/freedroid/Makefile
+++ b/games/freedroid/Makefile
@@ -15,15 +15,12 @@ MASTER_SITE_SUBDIR= freedroid
MAINTAINER= benlutz@datacomm.ch
COMMENT= Freedroid is a clone of the classic game "Paradroid"
-LIB_DEPENDS= SDL-1.1:${PORTSDIR}/devel/sdl12 \
- jpeg:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
png:${PORTSDIR}/graphics/png \
- SDL_image:${PORTSDIR}/graphics/sdl_image \
- SDL_mixer:${PORTSDIR}/audio/sdl_mixer \
vorbis.3:${PORTSDIR}/audio/libvorbis
USE_XLIB= yes
-USE_SDL= yes
+USE_SDL= mixer image sdl
USE_REINPLACE= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/games/jfk/Makefile b/games/jfk/Makefile
index 929e8f591c5b..55a1d2f6feff 100644
--- a/games/jfk/Makefile
+++ b/games/jfk/Makefile
@@ -13,11 +13,9 @@ MASTER_SITES= http://relax.ath.cx/jfk/
MAINTAINER= stefan@fafoe.narf.at
COMMENT= A multiplayer 2D shoot'em up game
-LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image
-
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
GNU_CONFIGURE= yes
-USE_SDL= yes
+USE_SDL= image sdl
.include <bsd.port.pre.mk>
diff --git a/games/pengpong/Makefile b/games/pengpong/Makefile
index f3ab10d46842..2219fa168216 100644
--- a/games/pengpong/Makefile
+++ b/games/pengpong/Makefile
@@ -14,12 +14,8 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= pat@FreeBSD.org
COMMENT= A cross-platform pong game written in SDL
-LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image
-
-SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
-
+USE_SDL= image sdl
NO_WRKSUBDIR= yes
-MAKE_ENV= SDL_CONFIG="${SDL_CONFIG}"
USE_PERL5_BUILD=yes
DATAFILES= 24P_Copperplate_Blue.png ball.tga logo.jpg \
diff --git a/games/pipenightdreams/Makefile b/games/pipenightdreams/Makefile
index 08d30978502b..90893265f9f5 100644
--- a/games/pipenightdreams/Makefile
+++ b/games/pipenightdreams/Makefile
@@ -13,13 +13,11 @@ MASTER_SITES= http://www.libsdl.org/projects/pipenightdreams/packages/
MAINTAINER= markp@FreeBSD.org
COMMENT= A puzzle game similar to PipeMania
-LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image
-
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+USE_SDL= image sdl
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" CPPFLAGS="-I${LOCALBASE}/include"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
USE_REINPLACE= yes
MAN6= pipenightdreams.6
diff --git a/games/senken/Makefile b/games/senken/Makefile
index 3e0d0500a5e3..8b498be91538 100644
--- a/games/senken/Makefile
+++ b/games/senken/Makefile
@@ -12,10 +12,8 @@ MASTER_SITES= http://www.contrib.andrew.cmu.edu/~tmartin/senken/download/
MAINTAINER= tmartin@andrew.cmu.edu
COMMENT= A city simulation game
-LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image
-
GNU_CONFIGURE= yes
-USE_SDL= yes
+USE_SDL= image sdl
USE_GNOME= gtk12
.include <bsd.port.mk>
diff --git a/games/uqm/Makefile b/games/uqm/Makefile
index 9b8a763193e5..345c452c81a4 100644
--- a/games/uqm/Makefile
+++ b/games/uqm/Makefile
@@ -26,12 +26,11 @@ COMMENT= A port of the original Star Control 2 for 3DO consoles
ONLY_FOR_ARCHS= i386
-LIB_DEPENDS= SDL_image:${PORTSDIR}/graphics/sdl_image \
- vorbis.3:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis
USE_XLIB= yes
USE_GMAKE= yes
-USE_SDL= yes
+USE_SDL= image sdl
USE_REINPLACE= yes
NO_INSTALL_MANPAGES= yes