aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-04 21:43:30 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-04 21:43:30 +0000
commit22e5c30b8f0384d7bc7cdb268bbd964f7eb4758b (patch)
tree3e3d4e08fce94f853db067086ad111f02dacd8ae /games
parent4ee6863913010e61cf9e2592f6efba8ae982a6f9 (diff)
downloadports-22e5c30b8f0384d7bc7cdb268bbd964f7eb4758b.tar.gz
ports-22e5c30b8f0384d7bc7cdb268bbd964f7eb4758b.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/linux-uplink-demo/Makefile72
-rw-r--r--games/linux-uplink-demo/distinfo3
-rw-r--r--games/linux-uplink-demo/files/uplink.in12
-rw-r--r--games/linux-uplink-demo/pkg-descr13
-rw-r--r--games/linux-uplink-demo/pkg-message14
-rw-r--r--games/linux-uplink-demo/pkg-plist18
7 files changed, 133 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 79409bc1ea0d..08e03e3d2ede 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -435,6 +435,7 @@
SUBDIR += linux-savage
SUBDIR += linux-spheresofchaos-demo
SUBDIR += linux-steam
+ SUBDIR += linux-uplink-demo
SUBDIR += linux-ut
SUBDIR += linux-ut2003-demo
SUBDIR += linux-ut2004-demo
diff --git a/games/linux-uplink-demo/Makefile b/games/linux-uplink-demo/Makefile
new file mode 100644
index 000000000000..c36e71933bc5
--- /dev/null
+++ b/games/linux-uplink-demo/Makefile
@@ -0,0 +1,72 @@
+# New ports collection makefile for: linux-uplink-demo
+# Date created: 25 May 2007
+# Whom: Marcus von Appen <mva@sysfault.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uplink-demo
+PORTVERSION= 1.55
+CATEGORIES= games linux
+MASTER_SITES= http://uplink.co.uk/test/
+PKGNAMEPREFIX= linux-
+DISTNAME= ${PORTNAME}-${PORTVERSION}DEMO
+EXTRACT_SUFX= .sh
+
+MAINTAINER= mva@sysfault.org
+COMMENT= High tech computer crime and industrial espionage on the Internet
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12 \
+ ${LINUXBASE}/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg \
+ ${LINUXBASE}/usr/lib/libSDL_mixer-1.2.so.0:${PORTSDIR}/audio/linux-sdl_mixer \
+ ${LINUXBASE}/usr/lib/libmikmod.so.2:${PORTSDIR}/audio/linux-mikmod
+
+ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_XLIB= yes
+USE_LDCONFIG= yes
+NO_CDROM= Redistribution is limited, see license
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+DATADIR= ${PREFIX}/lib/${PKGNAMEPREFIX}${PORTNAME}
+SUB_FILES= uplink
+SUB_LIST= LINUXBASE=${LINUXBASE}
+DOCFILES= license.txt mods.txt Readme-UplinkSupport.txt readme.txt
+
+OPTIONS= NVIDIA "Install support for nvidia" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_NVIDIA)
+RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver \
+ ${LINUXBASE}/usr/X11R6/lib/libGLU.so.1:${PORTSDIR}/graphics/linux-libGLU
+.else
+RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+.endif
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @cd ${WRKDIR} && ${TAIL} +376 ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | \
+ ${TAR} zxf -
+
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/lib/uplink.bin.x86
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ @cd ${WRKSRC}/lib && \
+ ${INSTALL_PROGRAM} uplink.bin.x86 libftgl.so.0 ${DATADIR} && \
+ ${INSTALL_DATA} *.dat ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKDIR}/uplink ${PREFIX}/bin/${PKGNAMEPREFIX}uplink
+.if !defined (NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for file in ${DOCFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}/${file}
+.endfor
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/games/linux-uplink-demo/distinfo b/games/linux-uplink-demo/distinfo
new file mode 100644
index 000000000000..115d8deee3b9
--- /dev/null
+++ b/games/linux-uplink-demo/distinfo
@@ -0,0 +1,3 @@
+MD5 (uplink-demo-1.55DEMO.sh) = dc2c3f732c71af597de442e44b28f0b0
+SHA256 (uplink-demo-1.55DEMO.sh) = d00de7891a7ee47afb5b39345d14afdad3563bc17c9ef356284f3edffbe515e8
+SIZE (uplink-demo-1.55DEMO.sh) = 10545660
diff --git a/games/linux-uplink-demo/files/uplink.in b/games/linux-uplink-demo/files/uplink.in
new file mode 100644
index 000000000000..bf5e24e76d57
--- /dev/null
+++ b/games/linux-uplink-demo/files/uplink.in
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+LD_PRELOAD_FTGL=%%LINUXBASE%%/usr/lib/libfreetype.so.6:%%DATADIR%%/libftgl.so.0
+
+if [ -n "$LD_PRELOAD" ]; then
+ export LD_PRELOAD="$LD_PRELOAD_FTGL:$LD_PRELOAD"
+else
+ export LD_PRELOAD="$LD_PRELOAD_FTGL"
+fi
+
+cd %%DATADIR%% || exit 1
+exec ./uplink.bin.x86 "$@"
diff --git a/games/linux-uplink-demo/pkg-descr b/games/linux-uplink-demo/pkg-descr
new file mode 100644
index 000000000000..f19eeb81e8f8
--- /dev/null
+++ b/games/linux-uplink-demo/pkg-descr
@@ -0,0 +1,13 @@
+From the homepage: You play an Uplink Agent who makes a living by performing
+jobs for major corporations. Your tasks involve hacking into rival computer
+systems, stealing research data, sabotaging other companies, laundering money,
+erasing evidence, or framing innocent people.
+You use the money you earn to upgrade your computer systems, and to buy new
+software and tools. As your experience level increases you find more
+dangerous and profitable missions become available. You can speculate on a
+fully working stock market (and even influence its outcome). You can modify
+peoples academic or criminal records. You can divert money from bank transfers
+into your own accounts. You can even take part in the construction of the most
+deadly computer virus ever designed.
+
+WWW: http://uplink.co.uk
diff --git a/games/linux-uplink-demo/pkg-message b/games/linux-uplink-demo/pkg-message
new file mode 100644
index 000000000000..e282f248e3f7
--- /dev/null
+++ b/games/linux-uplink-demo/pkg-message
@@ -0,0 +1,14 @@
+======================================================================
+This game will attempt to obtain some system information by
+accessing files in linux's procfs. You must install the Linux
+emulation procfs filesystem for this to work correctly. This can be
+accomplished by adding the following line to your /etc/fstab file:
+
+ linprocfs /compat/linux/proc linprocfs rw 0 0
+
+and then, as root, executing the commands:
+
+kldload linprocfs
+mount /compat/linux/proc
+
+======================================================================
diff --git a/games/linux-uplink-demo/pkg-plist b/games/linux-uplink-demo/pkg-plist
new file mode 100644
index 000000000000..ce549d854eff
--- /dev/null
+++ b/games/linux-uplink-demo/pkg-plist
@@ -0,0 +1,18 @@
+bin/linux-uplink
+%%DATADIR%%/uplink.bin.x86
+%%DATADIR%%/libftgl.so.0
+%%DATADIR%%/data.dat
+%%DATADIR%%/fonts.dat
+%%DATADIR%%/graphics.dat
+%%DATADIR%%/loading.dat
+%%DATADIR%%/music.dat
+%%DATADIR%%/patch.dat
+%%DATADIR%%/patch2.dat
+%%DATADIR%%/patch3.dat
+%%DATADIR%%/sounds.dat
+%%PORTDOCS%%%%DOCSDIR%%/license.txt
+%%PORTDOCS%%%%DOCSDIR%%/mods.txt
+%%PORTDOCS%%%%DOCSDIR%%/Readme-UplinkSupport.txt
+%%PORTDOCS%%%%DOCSDIR%%/readme.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%