aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-04-12 18:24:55 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-04-12 18:24:55 +0000
commit257c5e19dcd9c6488af22a9c104967bc4209d885 (patch)
tree276f1a33b1e1a4380655690df3444a8914ec9486 /games
parent0e2a619b3493ea63667946992571f7ddbe548068 (diff)
downloadports-257c5e19dcd9c6488af22a9c104967bc4209d885.tar.gz
ports-257c5e19dcd9c6488af22a9c104967bc4209d885.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/qmars/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/games/qmars/Makefile b/games/qmars/Makefile
index 11f4a838e97f..8979c06cd9da 100644
--- a/games/qmars/Makefile
+++ b/games/qmars/Makefile
@@ -11,17 +11,16 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Quicker Mars - heavily optimized mars simulator
-LICENSE= BSD
+LICENSE= BSD4CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_BZIP2= yes
+USES= tar:bzip2
MAKE_JOBS_UNSAFE= yes
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|g++|$${CXX}| ; \
s|-O3|$${CXXFLAGS}|' ${WRKSRC}/${MAKEFILE}
@@ -31,11 +30,10 @@ post-patch:
@${REINPLACE_CMD} -e 's|Parser::||' ${WRKSRC}/parser.hpp
do-install:
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PORTNAME} ${PREFIX}/bin)
- @${MKDIR} ${DATADIR}
-.for i in bench.exhaust bench.exmars bench.pmars bench.qmars
- (cd ${WRKSRC} && ${INSTALL_SCRIPT} ${i} ${DATADIR})
-.endfor
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} warriors ${DATADIR})
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PORTNAME} ${STAGEDIR}${PREFIX}/bin)
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC} && ${INSTALL_SCRIPT} bench.exhaust bench.exmars \
+ bench.pmars bench.qmars ${STAGEDIR}${DATADIR})
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} warriors ${STAGEDIR}${DATADIR})
.include <bsd.port.mk>