aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2023-07-04 15:21:08 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2023-07-04 20:07:03 +0000
commit36fb8a7d629381c4657e5f6e079c791ffd931b64 (patch)
treec0c3c9b941c53a9bbf52ce4bf62ef92a39b930c6 /games
parent5ed0cb6e57bdf3ea6858c822506761937fafda93 (diff)
downloadports-36fb8a7d629381c4657e5f6e079c791ffd931b64.tar.gz
ports-36fb8a7d629381c4657e5f6e079c791ffd931b64.zip
Diffstat (limited to 'games')
-rw-r--r--games/xonotic/Makefile11
-rw-r--r--games/xonotic/distinfo6
-rw-r--r--games/xonotic/files/patch-source_darkplaces_makefile.inc10
3 files changed, 14 insertions, 13 deletions
diff --git a/games/xonotic/Makefile b/games/xonotic/Makefile
index 8f1b25abbb9d..497d31359962 100644
--- a/games/xonotic/Makefile
+++ b/games/xonotic/Makefile
@@ -1,13 +1,14 @@
PORTNAME= xonotic
-PORTVERSION= 0.8.5
-PORTREVISION= 2
+PORTVERSION= 0.8.6
CATEGORIES= games
-MASTER_SITES= http://nl.dl.xonotic.org/ \
- http://mirror.bitmissile.com/xonotic/releases/
+MASTER_SITES= https://dl.xonotic.org/ \
+ https://download.evil-ant-colony.org/xonotic/ \
+ https://xonotic.antzucaro.com/ \
+ https://ocv.xonotic.au/downloads/
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Fast-paced, chaotic, and intense multiplayer first person shooter
-WWW= https://www.xonotic.org/
+WWW= https://xonotic.org/
LIB_DEPENDS= libcurl.so:ftp/curl \
libpng.so:graphics/png \
diff --git a/games/xonotic/distinfo b/games/xonotic/distinfo
index fbcf94b3343c..4a5e2f2bd4d0 100644
--- a/games/xonotic/distinfo
+++ b/games/xonotic/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1656693570
-SHA256 (xonotic-0.8.5.zip) = 0f92aa238362aeb059b9d9026a9bd38d6217423a35c19f126fb39e38736e37e5
-SIZE (xonotic-0.8.5.zip) = 1228561792
+TIMESTAMP = 1688474643
+SHA256 (xonotic-0.8.6.zip) = 50850f8d800e7499722f6ea61e478e96464a375494b5a24da93aa0598cbe964d
+SIZE (xonotic-0.8.6.zip) = 1238439495
diff --git a/games/xonotic/files/patch-source_darkplaces_makefile.inc b/games/xonotic/files/patch-source_darkplaces_makefile.inc
index 1101c2469db9..29d3697cd308 100644
--- a/games/xonotic/files/patch-source_darkplaces_makefile.inc
+++ b/games/xonotic/files/patch-source_darkplaces_makefile.inc
@@ -1,11 +1,11 @@
---- source/darkplaces/makefile.inc.orig 2022-06-27 17:32:38 UTC
+--- source/darkplaces/makefile.inc.orig 2023-04-30 08:22:32 UTC
+++ source/darkplaces/makefile.inc
-@@ -194,7 +194,7 @@ OPTIM_DEBUG=$(CPUOPTIMIZATIONS)
- #OPTIM_RELEASE=-O2 -fno-strict-aliasing -fno-math-errno -fno-trapping-math -fno-signaling-nans -fcx-limited-range -funroll-loops $(CPUOPTIMIZATIONS)
+@@ -197,7 +197,7 @@ OPTIM_DEBUG=$(CPUOPTIMIZATIONS)
#OPTIM_RELEASE=-O2 -fno-strict-aliasing -funroll-loops $(CPUOPTIMIZATIONS)
#OPTIM_RELEASE=-O2 -fno-strict-aliasing $(CPUOPTIMIZATIONS)
--OPTIM_RELEASE=-O3 -fno-strict-aliasing $(CPUOPTIMIZATIONS)
-+OPTIM_RELEASE=${CFLAGS} -fno-strict-aliasing $(CPUOPTIMIZATIONS)
+ #OPTIM_RELEASE=-O3 -fno-strict-aliasing $(CPUOPTIMIZATIONS)
+-OPTIM_RELEASE=-O3 -fno-strict-aliasing -fno-math-errno -fno-trapping-math $(CPUOPTIMIZATIONS)
++OPTIM_RELEASE=${CFLAGS} -fno-strict-aliasing -fno-math-errno -fno-trapping-math $(CPUOPTIMIZATIONS)
# NOTE: *never* *ever* use the -ffast-math or -funsafe-math-optimizations flag
# Also, since gcc 5, -ffinite-math-only makes NaN and zero compare equal inside engine code but not inside QC, which causes error spam for seemingly valid QC code like if (x != 0) return 1 / x;