aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-25 16:24:13 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-25 16:24:13 +0000
commit4945f526f0337fb08a381d9bec1b9f26e9acb530 (patch)
tree2a56a8dfaaa9f59efe812793c33cc52f175a1398 /games
parent7011800f9aa695ed1a6da921658e32ddc5b47d24 (diff)
downloadports-4945f526f0337fb08a381d9bec1b9f26e9acb530.tar.gz
ports-4945f526f0337fb08a381d9bec1b9f26e9acb530.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/six/Makefile17
-rw-r--r--games/six/distinfo4
-rw-r--r--games/six/files/patch-lssolve.cpp20
-rw-r--r--games/six/files/patch-six_Makefile.in11
-rw-r--r--games/six/files/patch-sixplayer.cpp10
-rw-r--r--games/six/pkg-plist17
6 files changed, 20 insertions, 59 deletions
diff --git a/games/six/Makefile b/games/six/Makefile
index 768ab3926d8a..84d6d12bed55 100644
--- a/games/six/Makefile
+++ b/games/six/Makefile
@@ -5,20 +5,23 @@
# $FreeBSD$
PORTNAME= six
-PORTVERSION= 0.4.0
-PORTREVISION= 2
+PORTVERSION= 0.5.1
CATEGORIES= games kde
MASTER_SITES= http://six.retes.hu/download/
-MAINTAINER= ports@freebsd.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= KDE HEX clone
USE_KDELIBS_VER= 3
-GNU_CONFIGURE= yes
-USE_REINPLACE= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
post-patch:
- ${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS}," ${WRKSRC}/configure
-
+ @${REINPLACE_CMD} -e 's,-O2,,g ; \
+ s,-pedantic,,g ; \
+ s,-lpthread,${PTHREAD_LIBS},g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's,-lkdeprint$$,$$(LIB_KDEPRINT) $$(LIBPTHREAD),g' \
+ ${WRKSRC}/six/Makefile.in
.include <bsd.port.mk>
diff --git a/games/six/distinfo b/games/six/distinfo
index 77948026f88d..1fe8b4629123 100644
--- a/games/six/distinfo
+++ b/games/six/distinfo
@@ -1,2 +1,2 @@
-MD5 (six-0.4.0.tar.gz) = 40e5014a17ce88aaf5ab3e82c98ed127
-SIZE (six-0.4.0.tar.gz) = 646179
+MD5 (six-0.5.1.tar.gz) = 562b6bb1f574b73a0c5324cfc6676fb2
+SIZE (six-0.5.1.tar.gz) = 815737
diff --git a/games/six/files/patch-lssolve.cpp b/games/six/files/patch-lssolve.cpp
deleted file mode 100644
index 4fe6bb578d97..000000000000
--- a/games/six/files/patch-lssolve.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- six/lssolve.cpp.orig Fri Feb 20 15:34:59 2004
-+++ six/lssolve.cpp Fri Feb 20 15:36:58 2004
-@@ -120,7 +120,7 @@
- double temp;
-
- x(n - 1) = b(n - 1) / U(n - 1, n - 1);
-- if(isnan(x(n - 1)))
-+ if(std::isnan(x(n - 1)))
- x(n - 1) = 0.;
- for(i = n - 2; i >= 0; i--) {
- // Should be: x(i)=((b(i)-U(i,i,i+1,n-1)*x(i+1,n-1))/U(i,i))(0);
-@@ -131,7 +131,7 @@
- temp += U.data()[iPos + j] * x(j);
- }
- x(i) = (b(i) - temp) / U.data()[iPos + i];
-- if(isnan(x(i)))
-+ if(std::isnan(x(i)))
- x(i) = 0.;
- }
- }
diff --git a/games/six/files/patch-six_Makefile.in b/games/six/files/patch-six_Makefile.in
deleted file mode 100644
index 15af6d1e8a28..000000000000
--- a/games/six/files/patch-six_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- six/Makefile.in.orig Tue Jun 1 06:08:14 2004
-+++ six/Makefile.in Tue Jun 1 06:08:53 2004
-@@ -254,7 +254,7 @@
- six_LDFLAGS = $(KDE_RPATH) $(all_libraries)
-
- # the libraries to link against.
--six_LDADD = -lm $(LIB_KFILE) -lkdeprint
-+six_LDADD = -lm $(LIB_KFILE) -lkdeprint $(LIBPTHREAD)
-
- # which sources should be compiled for six
- six_SOURCES = misc.h misc.cpp \
diff --git a/games/six/files/patch-sixplayer.cpp b/games/six/files/patch-sixplayer.cpp
deleted file mode 100644
index ac3374e56e95..000000000000
--- a/games/six/files/patch-sixplayer.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- six/sixplayer.cpp.orig Tue May 25 11:58:16 2004
-+++ six/sixplayer.cpp Tue May 25 11:58:33 2004
-@@ -5,6 +5,7 @@
- #include <cassert>
- #include <algorithm>
- #include <cmath>
-+#include <ctype.h>
-
- using std::endl;
-
diff --git a/games/six/pkg-plist b/games/six/pkg-plist
index 64d12a9f33e6..831e483cf172 100644
--- a/games/six/pkg-plist
+++ b/games/six/pkg-plist
@@ -1,24 +1,23 @@
bin/six
share/applnk/Games/Board/six.desktop
share/apps/six/sixui.rc
-share/icons/hicolor/16x16/apps/six.png
-share/icons/hicolor/16x16/apps/six.png
-share/icons/hicolor/32x32/actions/whiteplayer.png
+share/doc/HTML/en/six/common
+share/doc/HTML/en/six/filter.png
+share/doc/HTML/en/six/index.cache.bz2
+share/doc/HTML/en/six/index.docbook
share/icons/hicolor/32x32/actions/blackplayer.png
share/icons/hicolor/32x32/actions/swap.png
+share/icons/hicolor/32x32/actions/whiteplayer.png
share/icons/hicolor/32x32/apps/six.png
share/icons/hicolor/48x48/apps/six.png
+share/icons/locolor/16x16/actions/blackplayer.png
share/icons/locolor/16x16/actions/swap.png
share/icons/locolor/16x16/actions/whiteplayer.png
-share/icons/locolor/16x16/actions/blackplayer.png
share/icons/locolor/16x16/apps/six.png
-share/icons/locolor/22x22/actions/swap.png
share/icons/locolor/22x22/actions/blackplayer.png
+share/icons/locolor/22x22/actions/swap.png
share/icons/locolor/22x22/actions/whiteplayer.png
share/icons/locolor/32x32/apps/six.png
-share/doc/HTML/en/six/index.docbook
-share/doc/HTML/en/six/index.cache.bz2
-share/doc/HTML/en/six/filter.png
-share/doc/HTML/en/six/common
+share/mimelnk/application/vnd.kde.six.desktop
@dirrm share/doc/HTML/en/six
@dirrm share/apps/six