aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2021-10-28 11:49:10 +0000
committerMikael Urankar <mikael@FreeBSD.org>2021-11-08 08:13:29 +0000
commit58825f8c4599698b6daaae8672d2084aa72a8d4e (patch)
tree3f4cd099270363bbea08dcf825bc55fa5b1dadf7 /games
parente917d1f56355e04bf32fb4af360ad0b0f3d1a99c (diff)
Diffstat (limited to 'games')
-rw-r--r--games/stonesoup/Makefile45
-rw-r--r--games/stonesoup/distinfo6
-rw-r--r--games/stonesoup/files/patch-Makefile41
-rw-r--r--games/stonesoup/files/patch-initfile.cc8
-rw-r--r--games/stonesoup/files/patch-platform.h16
-rw-r--r--games/stonesoup/files/patch-rltiles_Makefile15
-rw-r--r--games/stonesoup/pkg-descr6
-rw-r--r--games/stonesoup/pkg-plist24
8 files changed, 84 insertions, 77 deletions
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index 9a9dfbd74967..7d8aa331085e 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -1,8 +1,7 @@
# Created by: Tobias Rehbein <tobias.rehbein@web.de>
PORTNAME= stonesoup
-PORTVERSION= 0.23.2
-PORTREVISION= 2
+PORTVERSION= 0.27.1
CATEGORIES= games
MAINTAINER= fuz@fuz.su
@@ -13,6 +12,10 @@ LICENSE_FILE= ${WRKSRC}/../../LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
+FLAVORS= console sdl
+FLAVOR?= ${FLAVORS[1]}
+sdl_PKGNAMESUFFIX= -sdl
+
USES= bison compiler:c++11-lib gmake lua:51 perl5 pkgconfig \
python:build shebangfix sqlite tar:xz
@@ -26,30 +29,33 @@ SHEBANG_FILES= util/gen-mi-enum \
util/species-gen.py \
util/txc
+DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
SAVEDIR= \~/.stonesoup
WRKSRC_SUBDIR= crawl-ref/source
+GAME=${PORTNAME}${PKGNAMESUFFIX}
SUB_FILES= pkg-message
-PLIST_SUB= SAVEDIR="${SAVEDIR}"
+PLIST_SUB= SAVEDIR="${SAVEDIR}" GAME="${GAME}" SDL=${"${FLAVOR}" == "sdl":?"":"@comment "}
MAKE_ARGS= prefix=${PREFIX} \
DATADIR=${DATADIR} \
DESTDIR=${STAGEDIR} \
FORCE_CC=${CC} \
FORCE_CXX=${CXX} \
+ GAME=${GAME} \
INSTALL_UGRP=root:games \
LUA_PACKAGE=lua-5.1 \
NO_AUTO_OPT=YesPlease \
NO_OPTIMIZE=YesPlease \
NO_TRY_GOLD=YesPlease \
- NOSSE=YesPlease \
POSIX=YesPlease \
+ PYTHON=${PYTHON_CMD} \
SAVEDIR=${SAVEDIR} \
SQLITE_INCLUDE_DIR=${LOCALBASE}/include \
SQLITE_LIB=-lsqlite3 \
V=yes
-OPTIONS_DEFINE= SDL SOUND NOWIZARD LUA EXAMPLES
+OPTIONS_DEFINE= LUA NOWIZARD SOUND
OPTIONS_DEFAULT=LUA
OPTIONS_SUB= yes
@@ -57,19 +63,24 @@ SOUND_DESC= Sound support
NOWIZARD_DESC= Disable Wizard mode
LUA_DESC= Bindings for LUA user scripts
-SDL_CONFLICTS= ${PORTNAME}-[0-9]*
-SDL_USE= sdl=sdl2,image2,mixer2 gl=gl,glu
-SDL_USES= gl sdl
+.if ${FLAVOR} == sdl
+USES+= gl sdl
+USE_SDL= sdl2 image2 mixer2
+USE_GL= gl glu
SDL_USES_OFF= ncurses
-SDL_MAKE_ARGS= TILES=y SOUND=y
-SDL_BUILD_DEPENDS= \
+MAKE_ARGS+= TILES=y SOUND=y
+BUILD_DEPENDS+= \
+ advpng:archivers/advancecomp \
fc-list:x11-fonts/fontconfig \
- ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:x11-fonts/dejavu
-SDL_RUN_DEPENDS= \
- ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:x11-fonts/dejavu
-SDL_LIB_DEPENDS=libpng.so:graphics/png \
+ ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:x11-fonts/dejavu \
+ pngcrush:graphics/pngcrush
+RUN_DEPENDS+= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:x11-fonts/dejavu
+LIB_DEPENDS+=libpng.so:graphics/png \
libfreetype.so:print/freetype2
-SDL_CONFLICTS_OFF= ${PORTNAME}-sdl-[0-9]*
+DESKTOP_ENTRIES= "Dungeon Crawl Stone Soup" "${COMMENT}" "${DATADIR}/dat/tiles/stone_soup_icon-512x512.png" "${GAME}" "Game;" false
+.else
+USES+= ncurses
+.endif
NOWIZARD_MAKE_ARGS= NOWIZARD=y
SOUND_MAKE_ARGS= SOUND=y
@@ -89,10 +100,6 @@ pre-build:
pre-install:
@${FIND} ${WRKSRC}/dat -type f -name '*.orig' -delete
-post-install-EXAMPLES-on:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${STAGEDIR}${DATADIR}/settings/init.txt ${STAGEDIR}${EXAMPLESDIR}/sample.crawlrc
-
post-install:
@${RM} -r ${STAGEDIR}${DATADIR}/settings/mac
diff --git a/games/stonesoup/distinfo b/games/stonesoup/distinfo
index c415d3c481bf..0d0828583544 100644
--- a/games/stonesoup/distinfo
+++ b/games/stonesoup/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1555547936
-SHA256 (crawl-crawl-0.23.2_GH0.tar.gz) = 9fe2be2befc36f5079125b86b1361fafe109c917221b2394f185e09a332d6859
-SIZE (crawl-crawl-0.23.2_GH0.tar.gz) = 13008415
+TIMESTAMP = 1635418020
+SHA256 (crawl-crawl-0.27.1_GH0.tar.gz) = 062f1285852fced23ecb2f272ad132467e12e7e251e02aaa84f37280b55ba63e
+SIZE (crawl-crawl-0.27.1_GH0.tar.gz) = 14647180
diff --git a/games/stonesoup/files/patch-Makefile b/games/stonesoup/files/patch-Makefile
index a277a8dfdff1..665a1f7b4ffb 100644
--- a/games/stonesoup/files/patch-Makefile
+++ b/games/stonesoup/files/patch-Makefile
@@ -1,22 +1,15 @@
---- Makefile.orig 2019-03-31 00:40:33 UTC
+--- Makefile.orig 2021-08-20 10:45:00 UTC
+++ Makefile
-@@ -73,7 +73,7 @@
- # them; you can also ask for a package with convenience libraries instead --
- # we'll try to provide them somewhere in the near future.
-
--GAME = crawl
-+GAME = stonesoup
-
- # Disable GNU Make implicit rules and variables. Leaving them enabled will slow
- # down MinGW and Cygwin builds by a very VERY noticeable degree. Besides, we have
-@@ -108,16 +108,12 @@ include Makefile.obj
+@@ -131,7 +131,7 @@ include Makefile.obj
# Which C++ standard to support
STDFLAG = -std=c++11
-CFOTHERS := -pipe $(EXTERNAL_FLAGS)
+CFOTHERS := $(EXTERNAL_FLAGS)
- CFWARN :=
- CFWARN_L := -Wall -Wformat-security -Wundef
+ # Build with FORCE_SSE=y to get better seed stability on 32 bit x86 builds. It
+ # is not recommended to do this unless you are building with contrib lua.
+ # On any 64bit builds where the arch supports it, (at least) sse2 is implied.
+@@ -156,10 +156,6 @@ CFWARN_L += -Wextra \
DEFINES := $(EXTERNAL_DEFINES)
@@ -27,7 +20,16 @@
#
# The GCC and GXX variables are set later.
#
-@@ -502,15 +498,6 @@ ifdef USE_ICC
+@@ -503,7 +499,7 @@ endif
+
+ # Attempt to use a full compiler name, to make
+ # distcc builds work nicely.
+-LMACH := $(shell gcc -dumpmachine)-
++LMACH := $(shell $(FORCE_CC) -dumpmachine)-
+ ifeq ($(LMACH),-)
+ LMACH :=
+ endif
+@@ -549,15 +545,6 @@ ifdef USE_ICC
# Some very good optimization flags.
CFOPTIMIZE := -O2 -parallel
@@ -43,16 +45,7 @@
endif
# Define this to automatically generate code optimized for your machine
-@@ -624,7 +611,7 @@ endif
-
- ifndef BUILD_SQLITE
- ifeq ($(shell grep -q sqlite3_prepare $(SQLITE_INCLUDE_DIR)/sqlite3.h 2>/dev/null && echo yes),yes)
-- # INCLUDES_L += -isystem $(SQLITE_INCLUDE_DIR)
-+ INCLUDES_L += -isystem $(SQLITE_INCLUDE_DIR)
- LIBS += $(SQLITE_LIB)
- ifneq ($(shell grep -q sqlite3_prepare_v2 $(SQLITE_INCLUDE_DIR)/sqlite3.h 2>/dev/null && echo yes),yes)
- DEFINES_L += -DANCIENT_SQLITE
-@@ -787,7 +774,7 @@ ifndef NOWIZARD
+@@ -858,7 +845,7 @@ ifndef NOWIZARD
DEFINES += -DWIZARD
endif
ifdef NO_OPTIMIZE
diff --git a/games/stonesoup/files/patch-initfile.cc b/games/stonesoup/files/patch-initfile.cc
index 66f12961e168..d7dc37e77ca9 100644
--- a/games/stonesoup/files/patch-initfile.cc
+++ b/games/stonesoup/files/patch-initfile.cc
@@ -1,6 +1,6 @@
---- initfile.cc.orig 2018-09-24 03:59:12 UTC
+--- initfile.cc.orig 2021-08-20 10:45:00 UTC
+++ initfile.cc
-@@ -4225,7 +4225,7 @@ static void _bones_rewrite(const string
+@@ -4529,7 +4529,7 @@ static void _bones_rewrite(const string filename, cons
if (dups)
cout << ", " << dups << " duplicates removed";
cout << "\n";
@@ -9,8 +9,8 @@
_write_bones(filename, out);
}
else
-@@ -4241,7 +4241,7 @@ static void _bones_merge(const vector<st
- out.insert(out.end(), ghosts.begin(), ghosts.end());
+@@ -4554,7 +4554,7 @@ static void _bones_merge(const vector<string> files, c
+ break;
}
if (file_exists(out_name))
- unlink(out_name.c_str());
diff --git a/games/stonesoup/files/patch-platform.h b/games/stonesoup/files/patch-platform.h
deleted file mode 100644
index b9c501af2fe1..000000000000
--- a/games/stonesoup/files/patch-platform.h
+++ /dev/null
@@ -1,16 +0,0 @@
---- platform.h.orig 2021-10-28 09:13:02 UTC
-+++ platform.h
-@@ -212,13 +212,6 @@
- #endif
-
- #if !defined (OS_DETECTED)
--#if defined (TARGET_CPU_ARM)
--#define OS_DETECTED
--#define TARGET_OS_NDSFIRMWARE
--#endif
--#endif
--
--#if !defined (OS_DETECTED)
- #if defined (MSDOS) || defined (__DOS__) || defined (__DJGPP__)
- #define OS_DETECTED
- #define TARGET_OS_DOS
diff --git a/games/stonesoup/files/patch-rltiles_Makefile b/games/stonesoup/files/patch-rltiles_Makefile
index eab6f997abce..36e4d480d67e 100644
--- a/games/stonesoup/files/patch-rltiles_Makefile
+++ b/games/stonesoup/files/patch-rltiles_Makefile
@@ -1,4 +1,4 @@
---- rltiles/Makefile.orig 2019-02-28 23:45:55 UTC
+--- rltiles/Makefile.orig 2021-08-20 10:45:00 UTC
+++ rltiles/Makefile
@@ -11,7 +11,6 @@ endif
# is not supported. If host=target, contribs are enough.
@@ -8,6 +8,19 @@
ifdef ANDROID
CXXFLAGS :=
+@@ -28,10 +27,10 @@ ifdef TILES
+ PNG_LIB := ../contrib/install/$(ARCH)/lib/libpng.a ../contrib/install/$(ARCH)/lib/libz.a
+ endif
+
+- CFLAGS += $(PNG_INCLUDE)
++ CXXFLAGS += $(PNG_INCLUDE)
+ LDFLAGS += $(PNG_LIB)
+
+- CFLAGS += -DUSE_TILE
++ CXXFLAGS += -DUSE_TILE
+ endif
+
+ ifdef DEBUG
@@ -50,14 +49,14 @@ endif
# Attempt to use a full compiler name, to make
diff --git a/games/stonesoup/pkg-descr b/games/stonesoup/pkg-descr
index 676af47d359f..48be469831e6 100644
--- a/games/stonesoup/pkg-descr
+++ b/games/stonesoup/pkg-descr
@@ -5,9 +5,9 @@ in a quest for the mystifyingly fabulous Orb of Zot.
Dungeon Crawl Stone Soup is a variant of Linley's Dungeon Crawl that's openly
developed and invites participation from the Crawl community.
-This port comes with two interfaces:
+This port comes in two flavours:
- games/stonesoup - the traditional tty interfaced
- games/stonesoup-sdl - the fancy SDL interface
+ games/stonesoup@console - the traditional tty interface
+ games/stonesoup@sdl - the fancy SDL interface
WWW: http://crawl.develz.org/
diff --git a/games/stonesoup/pkg-plist b/games/stonesoup/pkg-plist
index 11aa9f7af75d..e0b25f7bb257 100644
--- a/games/stonesoup/pkg-plist
+++ b/games/stonesoup/pkg-plist
@@ -1,4 +1,4 @@
-bin/stonesoup
+bin/%%GAME%%
%%DATADIR%%/dat/database/el/monflee.txt
%%DATADIR%%/dat/database/el/rand_all.txt
%%DATADIR%%/dat/database/FAQ.txt
@@ -22,21 +22,21 @@ bin/stonesoup
%%DATADIR%%/dat/database/shout.txt
%%DATADIR%%/dat/database/wpnnoise.txt
%%DATADIR%%/dat/defaults/autopickup_exceptions.txt
-%%DATADIR%%/dat/defaults/food_colouring.txt
%%DATADIR%%/dat/defaults/glyph_colours.txt
%%DATADIR%%/dat/defaults/menu_colours.txt
%%DATADIR%%/dat/defaults/messages.txt
%%DATADIR%%/dat/defaults/misc.txt
%%DATADIR%%/dat/defaults/runrest_messages.txt
%%DATADIR%%/dat/defaults/standard_colours.txt
+%%DATADIR%%/dat/des/00init.des
%%DATADIR%%/dat/des/altar/altar.des
%%DATADIR%%/dat/des/altar/ashenzari_visionary.des
+%%DATADIR%%/dat/des/altar/ecumenical.des
%%DATADIR%%/dat/des/altar/kiku_cage.des
%%DATADIR%%/dat/des/altar/lugonu_bribe.des
%%DATADIR%%/dat/des/altar/nemelex_the_gamble.des
%%DATADIR%%/dat/des/altar/okawaru_arena.des
%%DATADIR%%/dat/des/altar/overflow.des
-%%DATADIR%%/dat/des/altar/pakellas_experiments.des
%%DATADIR%%/dat/des/altar/trog_burn_book.des
%%DATADIR%%/dat/des/altar/trog_wizard.des
%%DATADIR%%/dat/des/altar/vehumet_trees.des
@@ -58,6 +58,7 @@ bin/stonesoup
%%DATADIR%%/dat/des/branches/elf.des
%%DATADIR%%/dat/des/branches/geh.des
%%DATADIR%%/dat/des/branches/hell.des
+%%DATADIR%%/dat/des/branches/hilbert_zone.des
%%DATADIR%%/dat/des/branches/lair.des
%%DATADIR%%/dat/des/branches/orc.des
%%DATADIR%%/dat/des/branches/pan.des
@@ -65,6 +66,7 @@ bin/stonesoup
%%DATADIR%%/dat/des/branches/slime.des
%%DATADIR%%/dat/des/branches/snake.des
%%DATADIR%%/dat/des/branches/spider.des
+%%DATADIR%%/dat/des/branches/spider_jumping.des
%%DATADIR%%/dat/des/branches/swamp.des
%%DATADIR%%/dat/des/branches/tar.des
%%DATADIR%%/dat/des/branches/temple_compat.des
@@ -80,7 +82,6 @@ bin/stonesoup
%%DATADIR%%/dat/des/builder/arena.des
%%DATADIR%%/dat/des/builder/decor.des
%%DATADIR%%/dat/des/builder/dummy.des
-%%DATADIR%%/dat/des/builder/food.des
%%DATADIR%%/dat/des/builder/layout_caves.des
%%DATADIR%%/dat/des/builder/layout_cc.des
%%DATADIR%%/dat/des/builder/layout_cellular.des
@@ -165,6 +166,7 @@ bin/stonesoup
%%DATADIR%%/dat/des/variable/polyominoes.des
%%DATADIR%%/dat/des/variable/the_bubble.des
%%DATADIR%%/dat/des/variable/the_grid.des
+%%DATADIR%%/dat/des/variable/winding_woodlands.des
%%DATADIR%%/dat/descript/ability.txt
%%DATADIR%%/dat/descript/backgrounds.txt
%%DATADIR%%/dat/descript/branches.txt
@@ -415,6 +417,7 @@ bin/stonesoup
%%DATADIR%%/dat/descript/zh/backgrounds.txt
%%DATADIR%%/dat/descript/zh/branches.txt
%%DATADIR%%/dat/descript/zh/cards.txt
+%%DATADIR%%/dat/descript/zh/clouds.txt
%%DATADIR%%/dat/descript/zh/commands.txt
%%DATADIR%%/dat/descript/zh/features.txt
%%DATADIR%%/dat/descript/zh/gods.txt
@@ -465,6 +468,7 @@ bin/stonesoup
%%DATADIR%%/dat/dist_bones/README
%%DATADIR%%/dat/dlua/debug.lua
%%DATADIR%%/dat/dlua/dungeon.lua
+%%DATADIR%%/dat/dlua/explorer.lua
%%DATADIR%%/dat/dlua/fnwrap.lua
%%DATADIR%%/dat/dlua/gauntlet.lua
%%DATADIR%%/dat/dlua/ghost.lua
@@ -543,8 +547,8 @@ bin/stonesoup
%%DATADIR%%/docs/crawl_manual.txt
%%DATADIR%%/docs/CREDITS.txt
%%DATADIR%%/docs/develop/android.txt
+%%DATADIR%%/docs/develop/arena.txt
%%DATADIR%%/docs/develop/background_creation.txt
-%%DATADIR%%/docs/develop/coding_conventions.txt
%%DATADIR%%/docs/develop/ctags.txt
%%DATADIR%%/docs/develop/editor_tips.txt
%%DATADIR%%/docs/develop/gdb_tips.txt
@@ -561,7 +565,7 @@ bin/stonesoup
%%DATADIR%%/docs/develop/patch_guide.txt
%%DATADIR%%/docs/develop/save_compatibility.txt
%%DATADIR%%/docs/develop/spells.txt
-%%DATADIR%%/docs/develop/testing.txt
+%%DATADIR%%/docs/develop/test_plug_and_play_cc.txt
%%DATADIR%%/docs/develop/tiles_creation.txt
%%DATADIR%%/docs/develop/translation.txt
%%DATADIR%%/docs/fight_simulator.txt
@@ -574,6 +578,7 @@ bin/stonesoup
%%DATADIR%%/docs/license/worley.txt
%%DATADIR%%/docs/macros_guide.txt
%%DATADIR%%/docs/options_guide.txt
+%%DATADIR%%/docs/quickstart.md
%%DATADIR%%/docs/quickstart.txt
%%DATADIR%%/docs/ssh_guide.txt
%%DATADIR%%/docs/tiles_help.txt
@@ -604,7 +609,6 @@ bin/stonesoup
%%LUA%%%%DATADIR%%/dat/clua/delays.lua
%%LUA%%%%DATADIR%%/dat/clua/kills.lua
%%LUA%%%%DATADIR%%/dat/clua/stash.lua
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sample.crawlrc
%%SDL%%%%DATADIR%%/dat/tiles/feat.png
%%SDL%%%%DATADIR%%/dat/tiles/floor.png
%%SDL%%%%DATADIR%%/dat/tiles/gui.png
@@ -614,8 +618,11 @@ bin/stonesoup
%%SDL%%%%DATADIR%%/dat/tiles/main.png
%%SDL%%%%DATADIR%%/dat/tiles/player.png
%%SDL%%%%DATADIR%%/dat/tiles/stone_soup_icon-32x32.png
+%%SDL%%%%DATADIR%%/dat/tiles/stone_soup_icon-48x48.png
%%SDL%%%%DATADIR%%/dat/tiles/stone_soup_icon-512x512.png
%%SDL%%%%DATADIR%%/dat/tiles/stone_soup_icon-win32.png
+%%SDL%%%%DATADIR%%/dat/tiles/title_anon_octopus_wizard.png
+%%SDL%%%%DATADIR%%/dat/tiles/title_arbituhhh_tesu.png
%%SDL%%%%DATADIR%%/dat/tiles/title_baconkid_duvessa_dowan.png
%%SDL%%%%DATADIR%%/dat/tiles/title_baconkid_gastronok.png
%%SDL%%%%DATADIR%%/dat/tiles/title_baconkid_mnoleg.png
@@ -626,18 +633,21 @@ bin/stonesoup
%%SDL%%%%DATADIR%%/dat/tiles/title_denzi_kitchen_duty.png
%%SDL%%%%DATADIR%%/dat/tiles/title_denzi_summoner.png
%%SDL%%%%DATADIR%%/dat/tiles/title_denzi_undead_warrior.png
+%%SDL%%%%DATADIR%%/dat/tiles/title_e_m_fields.png
%%SDL%%%%DATADIR%%/dat/tiles/title_firemage.png
%%SDL%%%%DATADIR%%/dat/tiles/title_froggy_goodgod_tengu_gold.png
%%SDL%%%%DATADIR%%/dat/tiles/title_froggy_jiyva_felid.png
%%SDL%%%%DATADIR%%/dat/tiles/title_froggy_natasha_and_boris.png
%%SDL%%%%DATADIR%%/dat/tiles/title_froggy_rune_and_run_failed_on_dis.png
%%SDL%%%%DATADIR%%/dat/tiles/title_froggy_thunder_fist_nikola.png
+%%SDL%%%%DATADIR%%/dat/tiles/title_nibiki_octopode.png
%%SDL%%%%DATADIR%%/dat/tiles/title_omndra_zot_demon.png
%%SDL%%%%DATADIR%%/dat/tiles/title_peileppe_bloax_eye.png
%%SDL%%%%DATADIR%%/dat/tiles/title_ploomutoo_ijyb.png
%%SDL%%%%DATADIR%%/dat/tiles/title_pooryurik_knight.png
%%SDL%%%%DATADIR%%/dat/tiles/title_psiweapon_kiku.png
%%SDL%%%%DATADIR%%/dat/tiles/title_psiweapon_roxanne.png
+%%SDL%%%%DATADIR%%/dat/tiles/title_sastrei_chei.png
%%SDL%%%%DATADIR%%/dat/tiles/title_shadyamish_octm.png
%%SDL%%%%DATADIR%%/dat/tiles/title_white_noise_entering_the_dungeon.png
%%SDL%%%%DATADIR%%/dat/tiles/title_white_noise_grabbing_the_orb.png