aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-08-15 23:03:30 +0000
committerSteve Wills <swills@FreeBSD.org>2014-08-15 23:03:30 +0000
commit59e2750e779f85c3ca6f11f1978571a37ee6d21d (patch)
treef7589dd652b8e371b175593a8891949626ebd444 /games
parent77ed61fa52b1b5f7226ce1201f498a55e10a7a23 (diff)
downloadports-59e2750e779f85c3ca6f11f1978571a37ee6d21d.tar.gz
ports-59e2750e779f85c3ca6f11f1978571a37ee6d21d.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/dunelegacy/Makefile28
-rw-r--r--games/dunelegacy/distinfo2
-rw-r--r--games/dunelegacy/files/extra-patch-include__misc__functional.h21
-rw-r--r--games/dunelegacy/files/extra-patch-include__misc__memory.h18
-rw-r--r--games/dunelegacy/files/patch-configure.ac32
-rw-r--r--games/dunelegacy/pkg-descr8
-rw-r--r--games/dunelegacy/pkg-plist33
8 files changed, 143 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 9565b3f8a3b0..3bdc19a91855 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -215,6 +215,7 @@
SUBDIR += duckmaze
SUBDIR += duel
SUBDIR += duke3d-data
+ SUBDIR += dunelegacy
SUBDIR += dungeon
SUBDIR += dungeoncrawl
SUBDIR += dustrac
diff --git a/games/dunelegacy/Makefile b/games/dunelegacy/Makefile
new file mode 100644
index 000000000000..d0a5f4591396
--- /dev/null
+++ b/games/dunelegacy/Makefile
@@ -0,0 +1,28 @@
+# Created by: Steve Wills <swills@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= dunelegacy
+PORTVERSION= 0.96.3
+CATEGORIES= games
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Open source clone of Dune II
+
+LICENSE= GPLv2
+LICENSE_FILES= COPYING
+
+USES= tar:bzip2 compiler:c++11-lib
+USE_AUTOTOOLS= autoconf
+USE_SDL= sdl mixer
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+MAKE_JOBS_UNSAFE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
+EXTRA_PATCHES= files/extra-patch-include__misc__functional.h files/extra-patch-include__misc__memory.h
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/dunelegacy/distinfo b/games/dunelegacy/distinfo
new file mode 100644
index 000000000000..2d7e310e51a6
--- /dev/null
+++ b/games/dunelegacy/distinfo
@@ -0,0 +1,2 @@
+SHA256 (dunelegacy-0.96.3-src.tar.bz2) = 677159c174d9f9e8eb20e5e5cec997decf8e5a7091dc1583dc23fe340c5f6222
+SIZE (dunelegacy-0.96.3-src.tar.bz2) = 1652302
diff --git a/games/dunelegacy/files/extra-patch-include__misc__functional.h b/games/dunelegacy/files/extra-patch-include__misc__functional.h
new file mode 100644
index 000000000000..fc0252ad102e
--- /dev/null
+++ b/games/dunelegacy/files/extra-patch-include__misc__functional.h
@@ -0,0 +1,21 @@
+--- ./include/misc/functional.h.orig 2011-01-07 18:30:22.000000000 +0000
++++ ./include/misc/functional.h 2014-08-15 18:13:48.592575865 +0000
+@@ -1,14 +1,14 @@
+ #ifndef FUNCTIONAL_INCLUDED
+ #define FUNCTIONAL_INCLUDED
+
+-#include <tr1/functional>
++#include <functional>
+
+ namespace std {
+- using std::tr1::bind;
+- using std::tr1::function;
++ using std::bind;
++ using std::function;
+
+ namespace placeholders {
+- using namespace std::tr1::placeholders;
++ using namespace std::placeholders;
+ }
+ }
+
diff --git a/games/dunelegacy/files/extra-patch-include__misc__memory.h b/games/dunelegacy/files/extra-patch-include__misc__memory.h
new file mode 100644
index 000000000000..9f9ed052212f
--- /dev/null
+++ b/games/dunelegacy/files/extra-patch-include__misc__memory.h
@@ -0,0 +1,18 @@
+--- ./include/misc/memory.h.orig 2011-07-15 23:19:01.000000000 +0000
++++ ./include/misc/memory.h 2014-08-15 18:13:48.594576019 +0000
+@@ -1,12 +1,12 @@
+ #ifndef MEMORY_INCLUDED
+ #define MEMORY_INCLUDED
+
+-#include <tr1/memory>
++#include <memory>
+
+ namespace std {
+- using std::tr1::shared_ptr;
++ using std::shared_ptr;
+
+- using std::tr1::dynamic_pointer_cast;
++ using std::dynamic_pointer_cast;
+ }
+
+ #endif //MEMORY_INCLUDED
diff --git a/games/dunelegacy/files/patch-configure.ac b/games/dunelegacy/files/patch-configure.ac
new file mode 100644
index 000000000000..686fd60cb2dc
--- /dev/null
+++ b/games/dunelegacy/files/patch-configure.ac
@@ -0,0 +1,32 @@
+--- configure.ac.orig 2014-08-15 18:38:46.000000000 +0000
++++ configure.ac 2014-08-15 18:40:54.000000000 +0000
+@@ -16,13 +16,25 @@
+
+ AC_SUBST(dunelegacydatadir)
+
+-dnl Some flags for gcc
+-CXXFLAGS="-O3 -pipe -pedantic -Wall -Wextra -Wno-unused-parameter -DNDEBUG"
+ dnl Additional flags: -Wconversion -Wno-sign-conversion
+
+-dnl Some flags for clang
+-dnl CXXFLAGS="-O3 -pipe -pedantic -Weverything -Wno-sign-conversion -Wno-conversion -Wno-shadow -Wno-missing-noreturn -Wno-padded -Wno-packed -Wno-weak-vtables -Wno-c++11-narrowing -Wno-cast-align -Wno-unreachable-code -Wno-missing-prototypes -Wno-float-equal -Wno-global-constructors -Wno-exit-time-destructors -Wno-format-nonliteral -Wno-unused-macros -Wextra -Wno-unused-parameter"
++AC_MSG_CHECKING([if compiling with clang])
+
++AC_COMPILE_IFELSE(
++[AC_LANG_PROGRAM([], [[
++#ifndef __clang__
++ not clang
++#endif
++]])],
++[CLANG=yes], [CLANG=no])
++
++AC_MSG_RESULT([$CLANG])
++
++if test "x$CLANG" = xyes; then
++ CXXFLAGS="-std=c++11 -O3 -pipe -pedantic -Weverything -Wno-sign-conversion -Wno-conversion -Wno-shadow -Wno-missing-noreturn -Wno-padded -Wno-packed -Wno-weak-vtables -Wno-c++11-narrowing -Wno-cast-align -Wno-unreachable-code -Wno-missing-prototypes -Wno-float-equal -Wno-global-constructors -Wno-exit-time-destructors -Wno-format-nonliteral -Wno-unused-macros -Wextra -Wno-unused-parameter"
++else
++ CXXFLAGS="-O3 -pipe -pedantic -Wall -Wextra -Wno-unused-parameter -DNDEBUG"
++fi
+
+ dnl test for -ffp-contract=off (gcc >= 4.6) and use -mno-fused-madd instead
+ oldCFLAGS="$CFLAGS"
diff --git a/games/dunelegacy/pkg-descr b/games/dunelegacy/pkg-descr
new file mode 100644
index 000000000000..08c8f6ee1adf
--- /dev/null
+++ b/games/dunelegacy/pkg-descr
@@ -0,0 +1,8 @@
+Dune Legacy is an effort by a handful of developers to revitalize the
+first-ever real-time strategy game.
+
+It tries to be as similar as possible to the original gameplay but to integrate
+user interface features most modern realtime-strategy games have like selecting
+multiple units
+
+WWW: http://dunelegacy.sourceforge.net/website/
diff --git a/games/dunelegacy/pkg-plist b/games/dunelegacy/pkg-plist
new file mode 100644
index 000000000000..40d8601efdc6
--- /dev/null
+++ b/games/dunelegacy/pkg-plist
@@ -0,0 +1,33 @@
+bin/dunelegacy
+%%DATADIR%%/Dune2-Versions.txt
+%%DATADIR%%/LEGACY.PAK
+%%DATADIR%%/OPENSD2.PAK
+%%DATADIR%%/locale/English.en.po
+%%DATADIR%%/locale/French.fr.po
+%%DATADIR%%/locale/German.de.po
+%%DATADIR%%/locale/dunelegacy.pot
+%%DATADIR%%/maps/multiplayer/2P - 32x32 - X-Factor.ini
+%%DATADIR%%/maps/multiplayer/2P - 64x32 - Cliffs Of Rene.ini
+%%DATADIR%%/maps/multiplayer/2P - 64x64 - Bottle Neck.ini
+%%DATADIR%%/maps/multiplayer/2P - 64x64 - Broken Mountains.ini
+%%DATADIR%%/maps/multiplayer/2P - 64x64 - David's Pass.ini
+%%DATADIR%%/maps/multiplayer/2P - 64x64 - Face Off.ini
+%%DATADIR%%/maps/multiplayer/2P - 64x64 - Great Divide.ini
+%%DATADIR%%/maps/multiplayer/2P - 64x64 - Sanctuarys.ini
+%%DATADIR%%/maps/multiplayer/4P - 128x128 - The Sardaukar Outpost.ini
+%%DATADIR%%/maps/multiplayer/4P - 64x64 - Clear Path.ini
+%%DATADIR%%/maps/multiplayer/4P - 64x64 - Four Chambers.ini
+%%DATADIR%%/maps/multiplayer/4P - 64x64 - Four Courners.ini
+%%DATADIR%%/maps/multiplayer/4P - 64x64 - Sietch Stefan.ini
+%%DATADIR%%/maps/multiplayer/4P - 64x64 - Vast Armies Have Arrived.ini
+%%DATADIR%%/maps/singleplayer/2P - 32x128 - Canyon.ini
+%%DATADIR%%/maps/singleplayer/2P - 64x64 - Duality.ini
+%%DATADIR%%/maps/singleplayer/2P - 64x64 - North vs. South.ini
+%%DATADIR%%/maps/singleplayer/2P - 64x64 - Twin Fists.ini
+%%DATADIR%%/maps/singleplayer/3P - 64x32 - Middle Man.ini
+%%DATADIR%%/maps/singleplayer/5P - 128x128 - All against Atreides.ini
+@dirrmtry %%DATADIR%%/locale
+@dirrmtry %%DATADIR%%/maps/multiplayer
+@dirrmtry %%DATADIR%%/maps/singleplayer
+@dirrmtry %%DATADIR%%/maps
+@dirrmtry %%DATADIR%%