aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorKevin Zheng <kevinz5000@gmail.com>2023-06-17 20:32:28 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-06-26 22:58:23 +0000
commit658a65e0dab377a6bdd4ca9ff792f9e21cad8a53 (patch)
treecccffa7b3f10f6fdb5af63b83694b51cebe76505 /games
parent24897646a2a9a3c351ddd7f8a86c2926da404c60 (diff)
downloadports-658a65e0dab377a6bdd4ca9ff792f9e21cad8a53.tar.gz
ports-658a65e0dab377a6bdd4ca9ff792f9e21cad8a53.zip
Diffstat (limited to 'games')
-rw-r--r--games/assaultcube/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/games/assaultcube/Makefile b/games/assaultcube/Makefile
index e8a45f11bd3d..6a48b1ece42e 100644
--- a/games/assaultcube/Makefile
+++ b/games/assaultcube/Makefile
@@ -18,7 +18,7 @@ LICENSE_PERMS_ACUBE= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LICENSE_PERMS_CUBE= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LICENSE_PERMS_OTHER= dist-mirror pkg-mirror auto-accept
-USES= gmake tar:bzip2
+USES= compiler:c++11-lang gmake tar:bzip2
USE_GITHUB= yes
GH_ACCOUNT= assaultcube
@@ -41,7 +41,7 @@ DEDICATED_DESC= Build dedicated server
CLIENT_LIB_DEPENDS= libvorbisfile.so:audio/libvorbis \
libcurl.so:ftp/curl
-CLIENT_USES= compiler:c++11-lang desktop-file-utils gettext-runtime gl openal:al sdl \
+CLIENT_USES= desktop-file-utils gettext-runtime gl openal:al sdl \
xorg
CLIENT_USE= GL=gl SDL=sdl2,image2 XORG=x11
CLIENT_ALL_TARGET= client
@@ -57,6 +57,12 @@ DEDICATED_PLIST_FILES= bin/${PORTNAME}_server libexec/${PORTNAME}_server
#MASTER_ALL_TARGET= master
#MASTER_PLIST_FILES= bin/${PORTNAME}_master libexec/${PORTNAME}_master
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == "clang" && ${COMPILER_VERSION} >= 150
+LDFLAGS_i386+=--no-check-dynamic-relocations
+.endif
+
post-patch: .SILENT
${REINPLACE_CMD} -e '/^CXXFLAGS=/d ; /^CXX=/d ; /^CLIENT_PCH/d ; \
/^INCLUDES=/s|$$| -I$$(LOCALBASE)/include| ; \
@@ -81,4 +87,4 @@ post-install-${f:S|server|DEDICATED|:tu}-on:
${STAGEDIR}${PREFIX}/libexec/${PORTNAME}_${f}
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>