aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-08-06 05:18:23 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-08-06 05:18:23 +0000
commit66ea81be51316a6e6395efbcbaaf09df78730759 (patch)
treeed1ff9da9037f565dac53b7452df03107ee56494 /games
parent84a7e6a5cf518a9bfe6bc54ce44a3d4483697197 (diff)
downloadports-66ea81be51316a6e6395efbcbaaf09df78730759.tar.gz
ports-66ea81be51316a6e6395efbcbaaf09df78730759.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/hypatia_engine/Makefile22
-rw-r--r--games/hypatia_engine/distinfo2
-rw-r--r--games/hypatia_engine/pkg-descr4
4 files changed, 29 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 60fabbf2b6de..481ffe79b647 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -407,6 +407,7 @@
SUBDIR += hohlin
SUBDIR += hoichess
SUBDIR += holotz-castle
+ SUBDIR += hypatia_engine
SUBDIR += iagno
SUBDIR += icbm3d
SUBDIR += icebreaker
diff --git a/games/hypatia_engine/Makefile b/games/hypatia_engine/Makefile
new file mode 100644
index 000000000000..5cdfa40f8024
--- /dev/null
+++ b/games/hypatia_engine/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= hypatia_engine
+PORTVERSION= 0.2.29
+CATEGORIES= games python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lillian.lynn.lemmer@gmail.com
+COMMENT= Game engine for 2D top-down, tile-based action RPGs
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYGAME} \
+ ${PYTHON_PKGNAMEPREFIX}pyganim>0:${PORTSDIR}/graphics/py-pyganim \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow \
+ ${PYTHON_PKGNAMEPREFIX}enum34>0:${PORTSDIR}/devel/py-enum34
+
+USES= python:2
+USE_PYTHON= autoplist concurrent distutils
+
+.include <bsd.port.mk>
diff --git a/games/hypatia_engine/distinfo b/games/hypatia_engine/distinfo
new file mode 100644
index 000000000000..b38fd34de8af
--- /dev/null
+++ b/games/hypatia_engine/distinfo
@@ -0,0 +1,2 @@
+SHA256 (hypatia_engine-0.2.29.tar.gz) = 2d6cd5adce19326ca8737f211a35e83c65be864e04d51b44236ad72442eca1df
+SIZE (hypatia_engine-0.2.29.tar.gz) = 27005
diff --git a/games/hypatia_engine/pkg-descr b/games/hypatia_engine/pkg-descr
new file mode 100644
index 000000000000..ef920c35fb84
--- /dev/null
+++ b/games/hypatia_engine/pkg-descr
@@ -0,0 +1,4 @@
+Make 2D action adventure games. For programmers and nonprogrammers alike.
+Create a games like Legend of Zelda: Oracle of Ages and Oracle of Seasons.
+
+WWW: http://lillian-lemmer.github.io/hypatia