aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-27 09:30:49 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-27 09:30:49 +0000
commit8d56991bfc17944ce929eda2efed71ce49ea961c (patch)
tree48003a28065b6acb9944ac93f4df428501e54d2e /games
parenta45a4018d6c690c0f8143d1222e85330e32a5f59 (diff)
downloadports-8d56991bfc17944ce929eda2efed71ce49ea961c.tar.gz
ports-8d56991bfc17944ce929eda2efed71ce49ea961c.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/darkplaces/Makefile3
-rw-r--r--games/demonquake/Makefile3
-rw-r--r--games/falconseye/Makefile2
-rw-r--r--games/foobillard/Makefile3
4 files changed, 7 insertions, 4 deletions
diff --git a/games/darkplaces/Makefile b/games/darkplaces/Makefile
index c0d1a05480e2..261702103d50 100644
--- a/games/darkplaces/Makefile
+++ b/games/darkplaces/Makefile
@@ -7,7 +7,7 @@
PORTNAME= darkplaces
PORTVERSION= 20071120
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= http://offload1.icculus.org/twilight/darkplaces/files/
DISTNAME= ${PORTNAME}engine${PORTVERSION}
@@ -17,6 +17,7 @@ COMMENT= Quake engine modification
USE_ZIP= yes
USE_GMAKE= yes
+USE_XORG= xxf86dga
MAKE_ENV= DP_FS_BASEDIR="${Q1DIR}"
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/games/demonquake/Makefile b/games/demonquake/Makefile
index b098a7f7bc20..e35a97d8caeb 100644
--- a/games/demonquake/Makefile
+++ b/games/demonquake/Makefile
@@ -22,7 +22,8 @@ LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg \
USE_GMAKE= yes
USE_DOS2UNIX= yes
-USE_GL= yes
+USE_GL= gl
+USE_XORG= xpm xxf86dga
USE_BZIP2= yes
OPTIONS= GLX "Build OpenGL client" on \
diff --git a/games/falconseye/Makefile b/games/falconseye/Makefile
index 18fee9d8c430..cd02f52bddbe 100644
--- a/games/falconseye/Makefile
+++ b/games/falconseye/Makefile
@@ -24,7 +24,7 @@ NETHACKCONFIG= ${FILESDIR}/x-config
USE_SDL= sdl
USE_PERL5_BUILD=yes
USE_ZIP= yes
-USE_XORG= xpm
+USE_XORG= x11 xpm xaw
MAKE_ENV+= CFLAGS="${CFLAGS} -I${X11BASE}/include -I${LOCALBASE}/include -L${X11BASE}/lib -L${LOCALBASE}/lib -I${LOCALBASE}/include/SDL11" PREFIX="${PREFIX}" X11BASE="${X11BASE}"
WRKSRC= ${WRKDIR}
diff --git a/games/foobillard/Makefile b/games/foobillard/Makefile
index 58551913180d..18614aa22b38 100644
--- a/games/foobillard/Makefile
+++ b/games/foobillard/Makefile
@@ -7,7 +7,7 @@
PORTNAME= foobillard
PORTVERSION= 2.9
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= games
MASTER_SITES= http://foobillard.sunsite.dk/dnl/
@@ -26,6 +26,7 @@ FREETYPE_CONFIG?= ${LOCALBASE}/bin/freetype-config
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_XORG= xaw ice
CPPFLAGS= -I${X11BASE}/include
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \