aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-07-26 05:40:22 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-07-26 05:40:22 +0000
commit9346b215f04cc84bbb7125ff2fcf03978f859a21 (patch)
tree73bea5baa559b61c5e812c50ac96fad638950c75 /games
parent49ac3accb4fc378c681317849f4ae94655a61423 (diff)
downloadports-9346b215f04cc84bbb7125ff2fcf03978f859a21.tar.gz
ports-9346b215f04cc84bbb7125ff2fcf03978f859a21.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/alienarena/Makefile2
-rw-r--r--games/ioquake3/Makefile3
-rw-r--r--games/libfov/Makefile3
-rw-r--r--games/pets/Makefile3
-rw-r--r--games/poker-engine/Makefile4
-rw-r--r--games/poker-eval/Makefile3
-rw-r--r--games/py-poker-eval/Makefile2
-rw-r--r--games/stonesoup/Makefile2
-rw-r--r--games/warzone2100/files/patch-configure22
9 files changed, 31 insertions, 13 deletions
diff --git a/games/alienarena/Makefile b/games/alienarena/Makefile
index d17410f3a461..c70780c53379 100644
--- a/games/alienarena/Makefile
+++ b/games/alienarena/Makefile
@@ -50,7 +50,7 @@ LIBDIR= ${PREFIX}/lib/${PORTNAME}
.include <bsd.port.pre.mk>
.if defined(WITH_CLIENT)
-BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
+USE_PKGCONFIG= yes
LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl \
freetype.9:${PORTSDIR}/print/freetype2 \
jpeg.11:${PORTSDIR}/graphics/jpeg \
diff --git a/games/ioquake3/Makefile b/games/ioquake3/Makefile
index 2714337f1e7b..698d37643ac9 100644
--- a/games/ioquake3/Makefile
+++ b/games/ioquake3/Makefile
@@ -16,9 +16,8 @@ EXTRACT_SUFX?= .zip
MAINTAINER?= kamikaze@bsdforen.de
COMMENT?= Cleaned-up and enhanced version of Quake 3
-BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
-
USE_GMAKE= yes
+USE_PKGCONFIG= yes
.if defined(PKGNAMESUFFIX) && ${PKGNAMESUFFIX:M*-server}
# Server config
diff --git a/games/libfov/Makefile b/games/libfov/Makefile
index 62d83b6ee53c..264181e63205 100644
--- a/games/libfov/Makefile
+++ b/games/libfov/Makefile
@@ -13,10 +13,9 @@ MASTER_SITES= http://libfov.googlecode.com/files/
MAINTAINER= ports@FreeBSD.org
COMMENT= C library for calculating fields of view on low resolution rasters
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
-
USE_GNOME= gnomehack
USE_AUTOTOOLS= libtool
+USE_PKGCONFIG= yes
CONFIGURE_ENV= ac_cv_prog_doxygen=no ac_cv_path_SDL_CONFIG=no
USE_LDCONFIG= yes
diff --git a/games/pets/Makefile b/games/pets/Makefile
index b21a040b86e7..5655481ee556 100644
--- a/games/pets/Makefile
+++ b/games/pets/Makefile
@@ -15,11 +15,10 @@ MASTER_SITES= http://www.loria.fr/~rougier/pub/Software/
MAINTAINER= ports@FreeBSD.org
COMMENT= Funny pets to follow your mouse pointer
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
-
WRKSRC= ${WRKDIR}/pet-${PORTVERSION}
USE_GNOME= gtk20
+USE_PKGCONFIG= yes
SUB_FILES= pkg-message
diff --git a/games/poker-engine/Makefile b/games/poker-engine/Makefile
index f912adb82fb0..8e2291116a75 100644
--- a/games/poker-engine/Makefile
+++ b/games/poker-engine/Makefile
@@ -17,8 +17,7 @@ COMMENT= A python library that implements poker rules
BUILD_DEPENDS= ${LOCALBASE}/bin/rsync:${PORTSDIR}/net/rsync \
${PYTHON_SITELIBDIR}/pokereval.py:${PORTSDIR}/games/py-poker-eval \
${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2 \
- ${PYTHON_SITELIBDIR}/libxslt.py:${PORTSDIR}/textproc/py-libxslt \
- pkg-config>0:${PORTSDIR}/devel/pkg-config
+ ${PYTHON_SITELIBDIR}/libxslt.py:${PORTSDIR}/textproc/py-libxslt
RUN_DEPENDS= ${LOCALBASE}/bin/rsync:${PORTSDIR}/net/rsync \
${PYTHON_SITELIBDIR}/pokereval.py:${PORTSDIR}/games/py-poker-eval \
@@ -29,6 +28,7 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
USE_PYTHON= 2.5-2.7
+USE_PKGCONFIG= yes
USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/games/poker-eval/Makefile b/games/poker-eval/Makefile
index 526ba2ae4c27..c43e8e4a5471 100644
--- a/games/poker-eval/Makefile
+++ b/games/poker-eval/Makefile
@@ -18,11 +18,10 @@ COMMENT= A C library to evaluate poker hands
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
-
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
MAKE_JOBS_SAFE= yes
post-patch:
diff --git a/games/py-poker-eval/Makefile b/games/py-poker-eval/Makefile
index c5a56b3cf8b0..f45e9d8a5fc5 100644
--- a/games/py-poker-eval/Makefile
+++ b/games/py-poker-eval/Makefile
@@ -16,13 +16,13 @@ DISTNAME= py${PORTNAME}-${PORTVERSION:E}.0
MAINTAINER= ports@FreeBSD.org
COMMENT= Python adaptor for the poker-eval toolkit
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= poker-eval.1:${PORTSDIR}/games/poker-eval
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
USE_PYTHON= 2.5-2.7
+USE_PKGCONFIG= yes
USE_AUTOTOOLS= aclocal autoconf automake libtool
ACLOCAL_ARGS= -I config
CONFIGURE_ARGS= PYTHON=""
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index 6cdd98201f76..fe978ab7d671 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -71,7 +71,7 @@ CONFLICTS+= ${PORTNAME}-[0-9]*
MAKE_ARGS+= TILES=y
PLIST_SUB+= SDL=""
PKGNAMESUFFIX= -sdl
-BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
+USE_PKGCONFIG= yes
LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png \
freetype:${PORTSDIR}/print/freetype2
USE_SDL= sdl image
diff --git a/games/warzone2100/files/patch-configure b/games/warzone2100/files/patch-configure
new file mode 100644
index 000000000000..6804debfd238
--- /dev/null
+++ b/games/warzone2100/files/patch-configure
@@ -0,0 +1,22 @@
+--- ./configure.orig 2012-07-25 12:01:59.220711135 +0200
++++ ./configure 2012-07-25 12:02:30.934712586 +0200
+@@ -8603,7 +8603,7 @@
+
+
+ for ac_prog in pkg-config; do
+- ac_prog_version_check=`$ac_prog --version | head -n 1 | sed 's/([^)]*)//g;s/^[a-zA-Z\.\ \-\/]*//;s/ .*$//'`
++ ac_prog_version_check=`$ac_prog --modversion pkg-config | head -n 1 | sed 's/([^)]*)//g;s/^[a-zA-Z\.\ \-\/]*//;s/ .*$//'`
+ ac_prog_major_check=`echo $ac_prog_version_check | cut -d. -f1`
+ ac_prog_minor_check=`echo $ac_prog_version_check | sed s/[-,a-z,A-Z].*// | cut -d. -f2`
+ ac_prog_micro_check=`echo $ac_prog_version_check | sed s/[-,a-z,A-Z].*// | cut -d. -f3`
+--- ./configure.orig 2012-07-25 12:01:59.220711135 +0200
++++ ./configure 2012-07-25 12:02:30.934712586 +0200
+@@ -8603,7 +8603,7 @@
+
+
+ for ac_prog in pkg-config; do
+- ac_prog_version_check=`$ac_prog --version | head -n 1 | sed 's/([^)]*)//g;s/^[a-zA-Z\.\ \-\/]*//;s/ .*$//'`
++ ac_prog_version_check=`$ac_prog --modversion pkg-config | head -n 1 | sed 's/([^)]*)//g;s/^[a-zA-Z\.\ \-\/]*//;s/ .*$//'`
+ ac_prog_major_check=`echo $ac_prog_version_check | cut -d. -f1`
+ ac_prog_minor_check=`echo $ac_prog_version_check | sed s/[-,a-z,A-Z].*// | cut -d. -f2`
+ ac_prog_micro_check=`echo $ac_prog_version_check | sed s/[-,a-z,A-Z].*// | cut -d. -f3`