aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-29 14:44:21 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-29 14:44:21 +0000
commit95d0ada3f364b932fb20cc3feb9430d64f9f2612 (patch)
tree56525414627a38cf792708d3356d96a985aec208 /games
parent73a62517e946ef632d20e80cac4bbe2dacfea548 (diff)
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/tuxpaint-config/Makefile32
-rw-r--r--games/tuxpaint-config/distinfo3
-rw-r--r--games/tuxpaint-config/files/patch-Makefile57
-rw-r--r--games/tuxpaint-config/pkg-descr10
-rw-r--r--games/tuxpaint-config/pkg-plist20
6 files changed, 123 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index ee5ebd9f51f0..2075898e07e3 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -588,6 +588,7 @@
SUBDIR += tuxkart
SUBDIR += tuxmath
SUBDIR += tuxpaint
+ SUBDIR += tuxpaint-config
SUBDIR += tuxpaint-fonts
SUBDIR += tuxpaint-stamps
SUBDIR += tuxpuck
diff --git a/games/tuxpaint-config/Makefile b/games/tuxpaint-config/Makefile
new file mode 100644
index 000000000000..6ef36fb16885
--- /dev/null
+++ b/games/tuxpaint-config/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: tuxpaint-config
+# Date created: 28 Nov 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tuxpaint-config
+PORTVERSION= 0.0.6
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= tuxpaint
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Graphical tool to change TuxPaint settings
+
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+RUN_DEPENDS= tuxpaint:${PORTSDIR}/games/tuxpaint
+
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_REINPLACE= yes
+
+MAN1= tuxpaint-config.1
+MANCOMPRESSED= yes
+
+post-patch:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's|install-doc\([^:]\)|\1|' ${WRKSRC}/${MAKEFILE}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/tuxpaint-config/distinfo b/games/tuxpaint-config/distinfo
new file mode 100644
index 000000000000..baffe8694d81
--- /dev/null
+++ b/games/tuxpaint-config/distinfo
@@ -0,0 +1,3 @@
+MD5 (tuxpaint-config-0.0.6.tar.gz) = 48a72d0c7796c894ccd283498aa751d4
+SHA256 (tuxpaint-config-0.0.6.tar.gz) = a454aa50b91afb336f5af4eb7367b8bb455f6bbb21ee29a307706e40872e8f65
+SIZE (tuxpaint-config-0.0.6.tar.gz) = 81107
diff --git a/games/tuxpaint-config/files/patch-Makefile b/games/tuxpaint-config/files/patch-Makefile
new file mode 100644
index 000000000000..a91594dab55b
--- /dev/null
+++ b/games/tuxpaint-config/files/patch-Makefile
@@ -0,0 +1,57 @@
+--- Makefile.orig Fri Nov 25 21:55:46 2005
++++ Makefile Mon Nov 28 19:07:02 2005
+@@ -18,7 +18,6 @@
+
+ # Where to install things:
+
+-PREFIX=/usr/local
+
+
+ # Program:
+@@ -35,7 +34,7 @@
+ # Docs and man page:
+
+ DOC_PREFIX=$(PREFIX)/share/doc/tuxpaint-config/
+-MAN_PREFIX=$(PREFIX)/share/man/
++MAN_PREFIX=$(PREFIX)/man/
+
+
+ # Tux Paint's 'System-wide' Config file:
+@@ -74,7 +73,7 @@
+
+ # The entire set of CFLAGS:
+
+-CFLAGS=-O2 -Wall $(FLTK_CFLAGS) -DDATA_PREFIX=\"$(DATA_PREFIX)\" \
++CFLAGS+= -Wall $(FLTK_CFLAGS) -DDATA_PREFIX=\"$(DATA_PREFIX)\" \
+ -D$(NOSOUNDFLAG) -DDOC_PREFIX=\"$(DOC_PREFIX)\" \
+ -DLOCALEDIR=\"$(LOCALE_PREFIX)\" -DCONFDIR=\"$(CONFDIR)\" \
+ -DVER_VERSION=\"$(VER_VERSION)\" -DVER_DATE=\"$(VER_DATE)\"
+@@ -140,8 +139,7 @@
+ # to do this as superuser ("root"))
+
+ install: install-bin install-data install-man install-doc \
+- install-gnome install-kde install-kde-icons \
+- install-icon install-gettext
++ install-gettext
+ @echo
+ @echo "All done! Now (preferably NOT as 'root' superuser),"
+ @echo "you can type the command 'tuxpaint-config' to run the"
+@@ -230,9 +228,6 @@
+ install -d $(ICON_PREFIX)
+ cp data/images/icon.png $(ICON_PREFIX)tuxpaint-config.png
+ chmod 644 $(ICON_PREFIX)tuxpaint-config.png
+- install -d $(X11_ICON_PREFIX)
+- cp data/images/icon32x32.xpm $(X11_ICON_PREFIX)tuxpaint-config.xpm
+- chmod 644 $(X11_ICON_PREFIX)tuxpaint-config.xpm
+
+
+ # Install the program:
+@@ -296,7 +291,7 @@
+ obj/defaults.o $(ARCH_LIBS)
+ $(CXX) $(CFLAGS) -o tuxpaint-config obj/tuxpaint-config.o \
+ obj/tuxpaint-config2.o obj/defaults.o $(ARCH_LIBS) \
+- $(FLTK_LIBS) $(ARCH_LINKS)
++ $(FLTK_LIBS) $(ARCH_LINKS) -lintl
+
+
+ # Build the object for the program!
diff --git a/games/tuxpaint-config/pkg-descr b/games/tuxpaint-config/pkg-descr
new file mode 100644
index 000000000000..78c035df03fd
--- /dev/null
+++ b/games/tuxpaint-config/pkg-descr
@@ -0,0 +1,10 @@
+Tux Paint is a free drawing program designed for young children (kids ages 3
+and up). It has a simple, easy-to-use interface, fun sound effects, and an
+encouraging cartoon mascot who helps guide children as they use the program.
+It provides a blank canvas and a variety of drawing tools to help your child
+be creative.
+
+WWW: http://www.newbreedsoftware.com/tuxpaint/
+
+- Alejandro Pulver
+alejandro@varnet.biz
diff --git a/games/tuxpaint-config/pkg-plist b/games/tuxpaint-config/pkg-plist
new file mode 100644
index 000000000000..b810b7ae86dd
--- /dev/null
+++ b/games/tuxpaint-config/pkg-plist
@@ -0,0 +1,20 @@
+bin/tuxpaint-config
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS.txt
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES.txt
+%%PORTDOCS%%%%DOCSDIR%%/COPYING.txt
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/TODO.txt
+%%DATADIR%%/images/icon-win32.ico
+%%DATADIR%%/images/icon.png
+%%DATADIR%%/images/icon16x16.png
+%%DATADIR%%/images/icon32x32.png
+%%DATADIR%%/images/icon32x32.xpm
+%%DATADIR%%/images/icon48x48.png
+%%DATADIR%%/images/win32-icon16x16x16.png
+%%DATADIR%%/images/win32-icon16x16x256.png
+%%DATADIR%%/images/win32-icon32x32x16.png
+%%DATADIR%%/images/win32-icon32x32x256.png
+%%DATADIR%%/images/win32-icon48x48x256.png
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%