aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-09-13 12:15:43 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-09-13 12:15:43 +0000
commit9e66c791183a33bcd3deefe979ba01ab1b7ab384 (patch)
tree617f36ab2692a411e719fcf4dbe64832de82d053 /games
parentd2422522f101962b2221837f9300536e185f3395 (diff)
downloadports-9e66c791183a33bcd3deefe979ba01ab1b7ab384.tar.gz
ports-9e66c791183a33bcd3deefe979ba01ab1b7ab384.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/freesweep/Makefile12
-rw-r--r--games/freesweep/files/patch-Makefile.in24
2 files changed, 9 insertions, 27 deletions
diff --git a/games/freesweep/Makefile b/games/freesweep/Makefile
index 92f519fbe1c1..cd25380b428c 100644
--- a/games/freesweep/Makefile
+++ b/games/freesweep/Makefile
@@ -3,6 +3,7 @@
PORTNAME= freesweep
PORTVERSION= 0.92
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= GOOGLE_CODE
@@ -20,13 +21,18 @@ CONFIGURE_ARGS= --with-prefsdir=${DATADIR} \
ALL_TARGET= ${PORTNAME}
PORTDOCS= CHANGES README
-PLIST_FILES= bin/${PORTNAME} man/man6/${PORTNAME}.6.gz \
- %%DATADIR%%/sweeprc %%DATADIR%%/sweeptimes
+PLIST_FILES= "@(,games,2555) bin/${PORTNAME}" man/man6/${PORTNAME}.6.gz \
+ %%DATADIR%%/sweeprc "@(,games,0664) %%DATADIR%%/sweeptimes"
PLIST_DIRS= %%DATADIR%%
OPTIONS_DEFINE= DOCS
-post-install:
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/freesweep ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${TOUCH} ${STAGEDIR}${DATADIR}/sweeptimes
+ ${INSTALL_DATA} ${WRKSRC}/sweeprc ${STAGEDIR}${DATADIR}
+ ${INSTALL_MAN} ${WRKSRC}/freesweep.6 ${STAGEDIR}${PREFIX}/man/man6
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
diff --git a/games/freesweep/files/patch-Makefile.in b/games/freesweep/files/patch-Makefile.in
deleted file mode 100644
index 7551f9625d49..000000000000
--- a/games/freesweep/files/patch-Makefile.in
+++ /dev/null
@@ -1,24 +0,0 @@
---- Makefile.in.orig 2003-10-11 16:49:24.000000000 -0400
-+++ Makefile.in 2014-02-09 13:35:36.000000000 -0500
-@@ -17,7 +17,7 @@
- srcdir = @srcdir@
- VPATH = @srcdir@
-
--prefix = @prefix@
-+prefix = $(DESTDIR)@prefix@
- exec_prefix = @exec_prefix@
- #bindir = $(exec_prefix)/bin
- bindir = @bindir@
-@@ -61,9 +61,9 @@
- install: $(TARGET) $(TARGET).6
- touch sweeptimes
- ./install-sh -c -m 2555 -o root -g games -s $(TARGET) $(bindir)/$(TARGET)
-- ./install-sh -c -m 0664 -o root -g games sweeptimes @SCORESDIR@/sweeptimes
-- ./install-sh -c -m 0644 -o root -g games sweeprc @PREFSDIR@/sweeprc
-- ./install-sh -c -m 0444 -o root -g games $(TARGET).6 @mandir@/man6/$(TARGET).6
-+ ./install-sh -c -m 0664 -o root -g games sweeptimes $(DESTDIR)@SCORESDIR@/sweeptimes
-+ ./install-sh -c -m 0644 -o root -g games sweeprc $(DESTDIR)@PREFSDIR@/sweeprc
-+ ./install-sh -c -m 0444 -o root -g games $(TARGET).6 $(DESTDIR)@mandir@/man6/$(TARGET).6
-
- distclean:
- @make sterile