aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2012-07-22 23:23:59 +0000
committerDoug Barton <dougb@FreeBSD.org>2012-07-22 23:23:59 +0000
commitce7d0b1f2e20766f2a2bf8a739f73122e2c86c0c (patch)
tree4340b2026c7c38e24a07317c8ba6bded8fdc03e8 /games
parent55b482bb6d366ae343d8e3cb1dc564c3b7480b2d (diff)
downloadports-ce7d0b1f2e20766f2a2bf8a739f73122e2c86c0c.tar.gz
ports-ce7d0b1f2e20766f2a2bf8a739f73122e2c86c0c.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/poker-engine/Makefile8
-rw-r--r--games/poker-eval/Makefile3
-rw-r--r--games/py-poker-eval/Makefile2
3 files changed, 9 insertions, 4 deletions
diff --git a/games/poker-engine/Makefile b/games/poker-engine/Makefile
index 468b331c5a1b..f912adb82fb0 100644
--- a/games/poker-engine/Makefile
+++ b/games/poker-engine/Makefile
@@ -17,13 +17,17 @@ COMMENT= A python library that implements poker rules
BUILD_DEPENDS= ${LOCALBASE}/bin/rsync:${PORTSDIR}/net/rsync \
${PYTHON_SITELIBDIR}/pokereval.py:${PORTSDIR}/games/py-poker-eval \
${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2 \
+ ${PYTHON_SITELIBDIR}/libxslt.py:${PORTSDIR}/textproc/py-libxslt \
+ pkg-config>0:${PORTSDIR}/devel/pkg-config
+
+RUN_DEPENDS= ${LOCALBASE}/bin/rsync:${PORTSDIR}/net/rsync \
+ ${PYTHON_SITELIBDIR}/pokereval.py:${PORTSDIR}/games/py-poker-eval \
+ ${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2 \
${PYTHON_SITELIBDIR}/libxslt.py:${PORTSDIR}/textproc/py-libxslt
-RUN_DEPENDS:= ${BUILD_DEPENDS}
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_GNOME= pkgconfig
USE_PYTHON= 2.5-2.7
USE_GETTEXT= yes
USE_GMAKE= yes
diff --git a/games/poker-eval/Makefile b/games/poker-eval/Makefile
index a58f87a51aea..526ba2ae4c27 100644
--- a/games/poker-eval/Makefile
+++ b/games/poker-eval/Makefile
@@ -18,8 +18,9 @@ COMMENT= A C library to evaluate poker hands
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
+
GNU_CONFIGURE= yes
-USE_GNOME= pkgconfig
USE_GMAKE= yes
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
diff --git a/games/py-poker-eval/Makefile b/games/py-poker-eval/Makefile
index 03ffa1bdb440..c5a56b3cf8b0 100644
--- a/games/py-poker-eval/Makefile
+++ b/games/py-poker-eval/Makefile
@@ -16,12 +16,12 @@ DISTNAME= py${PORTNAME}-${PORTVERSION:E}.0
MAINTAINER= ports@FreeBSD.org
COMMENT= Python adaptor for the poker-eval toolkit
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= poker-eval.1:${PORTSDIR}/games/poker-eval
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_GNOME= pkgconfig
USE_PYTHON= 2.5-2.7
USE_AUTOTOOLS= aclocal autoconf automake libtool
ACLOCAL_ARGS= -I config