aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-12-25 23:29:34 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-12-25 23:29:34 +0000
commit1df9d247be410e0fd8c43e281e7aaa314fef30e5 (patch)
tree5d26acd476642c3b773f75db8040205ff9dc4d29 /games
parent6bf16e73115b4c62539ac4f0a4f6ccf1270eb26f (diff)
downloadports-1df9d247be410e0fd8c43e281e7aaa314fef30e5.tar.gz
ports-1df9d247be410e0fd8c43e281e7aaa314fef30e5.zip
Convert the tree to USES=openal
Approved by: portmgr (bapt)
Notes
Notes: svn path=/head/; revision=337464
Diffstat (limited to 'games')
-rw-r--r--games/0ad/Makefile4
-rw-r--r--games/alienarena/Makefile6
-rw-r--r--games/allacrost/Makefile3
-rw-r--r--games/apricots/Makefile2
-rw-r--r--games/arx-libertatis/Makefile3
-rw-r--r--games/assaultcube/Makefile3
-rw-r--r--games/atr3d/Makefile2
-rw-r--r--games/avp-demo/Makefile3
-rw-r--r--games/battletanks/Makefile3
-rw-r--r--games/blackshadeselite/Makefile3
-rw-r--r--games/chromium-bsu/Makefile2
-rw-r--r--games/deng/Makefile2
-rw-r--r--games/el/Makefile3
-rw-r--r--games/ember/Makefile3
-rw-r--r--games/evq3/Makefile4
-rw-r--r--games/excido/Makefile3
-rw-r--r--games/flightgear/Makefile3
-rw-r--r--games/freeminer/Makefile2
-rw-r--r--games/gemrb/Makefile3
-rw-r--r--games/glest/Makefile4
-rw-r--r--games/ioquake3/Makefile2
-rw-r--r--games/linwarrior/Makefile3
-rw-r--r--games/lugaru/Makefile3
-rw-r--r--games/megaglest/Makefile4
-rw-r--r--games/minecraft-client/Makefile2
-rw-r--r--games/minetest/Makefile2
-rw-r--r--games/naev/Makefile2
-rw-r--r--games/openastromenace/Makefile4
-rw-r--r--games/openlierox/Makefile3
-rw-r--r--games/py-fife/Makefile3
-rw-r--r--games/scorched3d/Makefile3
-rw-r--r--games/solarus/Makefile3
-rw-r--r--games/spring/Makefile5
-rw-r--r--games/springlobby/Makefile2
-rw-r--r--games/sumwars/Makefile3
-rw-r--r--games/supertux-devel/Makefile3
-rw-r--r--games/supertuxkart/Makefile5
-rw-r--r--games/torcs/Makefile3
-rw-r--r--games/tremulous/Makefile2
-rw-r--r--games/trigger/Makefile2
-rw-r--r--games/ufoai/Makefile3
-rw-r--r--games/ultimatestunts/Makefile3
-rw-r--r--games/uqm/Makefile2
-rw-r--r--games/valyriatear/Makefile3
-rw-r--r--games/vamos/Makefile3
-rw-r--r--games/vavoom/Makefile2
-rw-r--r--games/vegastrike/Makefile3
-rw-r--r--games/warsow/Makefile4
-rw-r--r--games/warzone2100/Makefile3
-rw-r--r--games/worldofpadman/Makefile2
-rw-r--r--games/xpilot-ng-server/Makefile2
51 files changed, 58 insertions, 92 deletions
diff --git a/games/0ad/Makefile b/games/0ad/Makefile
index dc1c186c9616..3214677cea5d 100644
--- a/games/0ad/Makefile
+++ b/games/0ad/Makefile
@@ -24,13 +24,11 @@ LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-alpha
BUILD_WRKSRC= ${WRKSRC}/build/workspaces/gcc
MAKE_ARGS= config=release
-USES= compiler:c++11-lang gmake pkgconfig
+USES= compiler:c++11-lang dos2unix gmake openal:al pkgconfig
USE_XZ= yes
USE_SDL= sdl
USE_GNOME= libxml2 gtk20
USE_GL= gl
-USE_OPENAL= al
-USE_DOS2UNIX= yes
DOS2UNIX_REGEX= .*\.([ch]p{0,2}|make)
USE_WX= 2.8
diff --git a/games/alienarena/Makefile b/games/alienarena/Makefile
index 7f5a3ea49c81..d020107460e4 100644
--- a/games/alienarena/Makefile
+++ b/games/alienarena/Makefile
@@ -20,8 +20,7 @@ COMMENT= Alien Arena (native version)
RUN_DEPENDS= ${DATADIR}/data1/default.cfg:${PORTSDIR}/games/alienarena-data
-USE_DOS2UNIX= yes
-USE_GMAKE= yes
+USES= dos2unix gmake
GNU_CONFIGURE= yes
CONFIGURE_WRKSRC=${WRKDIR}/${PORTNAME}-7.66/
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
@@ -52,14 +51,13 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCLIENT}
-USES+= pkgconfig
+USES+= openal:soft,alut pkgconfig
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl \
freetype.9:${PORTSDIR}/print/freetype2 \
jpeg.11:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png \
vorbis.4:${PORTSDIR}/audio/libvorbis
USE_GL= yes
-USE_OPENAL= soft alut
USE_XORG= xxf86dga xxf86vm
.endif
diff --git a/games/allacrost/Makefile b/games/allacrost/Makefile
index 1fc7bcb17bc0..549ab3eca3d2 100644
--- a/games/allacrost/Makefile
+++ b/games/allacrost/Makefile
@@ -20,8 +20,7 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
LICENSE= GPLv2
GNU_CONFIGURE= yes
-USES= gmake gettext
-USE_OPENAL= al
+USES= gettext gmake openal:al
USE_LUA= 5.1
USE_SDL= sdl ttf net
USE_GL= yes
diff --git a/games/apricots/Makefile b/games/apricots/Makefile
index b50fd63caee7..7b383f1e36e2 100644
--- a/games/apricots/Makefile
+++ b/games/apricots/Makefile
@@ -33,7 +33,7 @@ OPTIONS_DEFAULT=OPENAL
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENAL}
-USE_OPENAL= al alut
+USES+= openal:al,alut
CPPFLAGS+= -DAP_AUDIO_OPENAL
LDFLAGS+= -L${LOCALBASE}/lib -lopenal -lalut
.endif
diff --git a/games/arx-libertatis/Makefile b/games/arx-libertatis/Makefile
index d25c42a9116b..aef317c7ae11 100644
--- a/games/arx-libertatis/Makefile
+++ b/games/arx-libertatis/Makefile
@@ -19,10 +19,9 @@ LIB_DEPENDS= libIL.so:${PORTSDIR}/graphics/devil \
libboost_program_options.so:${PORTSDIR}/devel/boost-libs
USE_XZ= yes
-USE_OPENAL= yes
USE_SDL= sdl
USE_GL= gl glu
-USES= cmake
+USES= cmake openal
CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR="man" -DDATA_DIR=arx
SUB_FILES= pkg-message
diff --git a/games/assaultcube/Makefile b/games/assaultcube/Makefile
index 2339b2277c69..53ddec39c115 100644
--- a/games/assaultcube/Makefile
+++ b/games/assaultcube/Makefile
@@ -23,8 +23,7 @@ LICENSE_FILE_OTHER= ${WRKSRC}/docs/package_copyrights.txt
LICENSE_PERMS_OTHER= dist-mirror pkg-mirror auto-accept
USE_BZIP2= yes
-USE_OPENAL= al
-USES= gmake
+USES= gmake openal:al
GNU_CONFIGURE= yes
ALL_TARGET= libenet
WRKSRC= ${WRKDIR}/AssaultCube_v${PORTVERSION}
diff --git a/games/atr3d/Makefile b/games/atr3d/Makefile
index c3e3ac6a2347..84ee1cb441fb 100644
--- a/games/atr3d/Makefile
+++ b/games/atr3d/Makefile
@@ -34,7 +34,7 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENAL}
-USE_OPENAL= alut
+USES+= openal:alut
CONFIGURE_ARGS+= --enable-sound
.else
CONFIGURE_ARGS+= --disable-sound
diff --git a/games/avp-demo/Makefile b/games/avp-demo/Makefile
index 42936926fe7e..fd5f72417654 100644
--- a/games/avp-demo/Makefile
+++ b/games/avp-demo/Makefile
@@ -12,12 +12,11 @@ MAINTAINER= devel@stasyan.com
COMMENT= Aliens versus predator unofficial port from icculus.org
USE_SDL= mixer sdl
-USE_GMAKE= yes
+USES= gmake openal
USE_GL= gl
WRKSRC= ${WRKDIR}
BUILD_WRKSRC= ${WRKDIR}/avp_git
-USE_OPENAL= yes
NO_STAGE= yes
.include <bsd.port.pre.mk>
diff --git a/games/battletanks/Makefile b/games/battletanks/Makefile
index 6450cff63a5e..f9f8428a5435 100644
--- a/games/battletanks/Makefile
+++ b/games/battletanks/Makefile
@@ -16,12 +16,11 @@ LIB_DEPENDS= libsigc-2.0.so:${PORTSDIR}/devel/libsigc++20 \
libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
libsmpeg.so:${PORTSDIR}/multimedia/smpeg
-USES= pkgconfig
+USES= openal:al pkgconfig
USE_BZIP2= yes
USE_GCC= yes
USE_LDCONFIG= yes
USE_LUA= 5.0+
-USE_OPENAL= al
USE_SDL= image sdl
USE_SCONS= yes
USE_PYTHON= yes
diff --git a/games/blackshadeselite/Makefile b/games/blackshadeselite/Makefile
index 3ae8e3516fbd..7eaf9f56dc94 100644
--- a/games/blackshadeselite/Makefile
+++ b/games/blackshadeselite/Makefile
@@ -13,11 +13,10 @@ COMMENT= Psychic Bodyguard FPS - protect the VIP
LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
-USES= gmake
+USES= gmake openal:al,alut
USE_BZIP2= yes
USE_SDL= sdl
USE_GL= yes
-USE_OPENAL= al alut
MAKE_ARGS= CC=${CC} CXX=${CXX}
diff --git a/games/chromium-bsu/Makefile b/games/chromium-bsu/Makefile
index 130afca2349c..607aede3f741 100644
--- a/games/chromium-bsu/Makefile
+++ b/games/chromium-bsu/Makefile
@@ -44,7 +44,7 @@ CONFIGURE_ARGS+=--disable-glut
USE_SDL+= mixer
CONFIGURE_ARGS+=--disable-openal
.else
-USE_OPENAL= al alut
+USES+= openal:al,alut
CONFIGURE_ARGS+=--disable-sdlmixer
.endif
diff --git a/games/deng/Makefile b/games/deng/Makefile
index 98fa76b78e87..48528d06b1dd 100644
--- a/games/deng/Makefile
+++ b/games/deng/Makefile
@@ -34,7 +34,7 @@ OPENAL_DESC= Build OpenAL sound plugin
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENAL}
-USE_OPENAL= al
+USES+= openal:al
CMAKE_ARGS+= -DBUILDOPENAL:BOOL=ON
PLIST_SUB= OPENAL=""
.else
diff --git a/games/el/Makefile b/games/el/Makefile
index 304e7ac63636..190e0017d604 100644
--- a/games/el/Makefile
+++ b/games/el/Makefile
@@ -19,8 +19,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/el.ini:${PORTSDIR}/games/el-data
PROJECTHOST= bsdistfiles
USE_BZIP2= yes
-USE_GMAKE= yes
-USE_OPENAL= al alut
+USES= gmake openal:al,alut
USE_GNOME= libxml2
USE_SDL= sdl net image
USE_GL= yes
diff --git a/games/ember/Makefile b/games/ember/Makefile
index 8dc0ad2663da..43e371915c95 100644
--- a/games/ember/Makefile
+++ b/games/ember/Makefile
@@ -35,8 +35,7 @@ GNU_CONFIGURE= YES
USE_LDCONFIG= YES
USE_LUA= 5.1
LUA_COMPS= toluaxx
-USE_OPENAL= al alut
-USES= pathfix pkgconfig
+USES= openal:al,alut pathfix pkgconfig
USE_BZIP2= YES
CPPFLAGS+= -DBR_NO_MACROS
USE_GCC= 4.7+
diff --git a/games/evq3/Makefile b/games/evq3/Makefile
index e20d22192636..381041d34a36 100644
--- a/games/evq3/Makefile
+++ b/games/evq3/Makefile
@@ -35,6 +35,9 @@ OPENAL_DLOPEN_DESC= Enable dynamic loading of OpenAL
SMP_DESC= Build SMP (threaded) client
VOIP_DESC= Enable Voice Over IP
+# USES must be before bsd.port.pre.mk
+OPENAL_USES= openal:al
+
MAKE_ENV= DEFAULT_BASEDIR="${Q3DIR}" LIBDIR="${LIBDIR}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
PLIST_SUB= LIBDIR="${LIBDIR:S/${PREFIX}\///}"
@@ -67,7 +70,6 @@ MAKE_ENV+= USE_CURL_DLOPEN=1
. endif
# OpenAL
. if ${PORT_OPTIONS:MOPENAL}
-USE_OPENAL= al
MAKE_ENV+= USE_OPENAL=1
. if ${PORT_OPTIONS:MOPENAL_DLOPEN}
MAKE_ENV+= USE_OPENAL_DLOPEN=1
diff --git a/games/excido/Makefile b/games/excido/Makefile
index 1d7942b79645..6f07f980e56c 100644
--- a/games/excido/Makefile
+++ b/games/excido/Makefile
@@ -22,8 +22,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_BZIP2= yes
USE_GL= yes
USE_SDL= image sdl ttf
-USE_OPENAL= al alut
-USES= gmake
+USES= gmake openal:al,alut
OPTIONS_DEFINE= DOCS
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index 8b1f4f52b138..df1a6fa5e85e 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -30,8 +30,7 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
USE_BZIP2= yes
USE_XORG= ice sm x11 xext xft xi xinerama xt xmu
USE_GL= gl glu glut
-USE_OPENAL= al alut
-USES= cmake
+USES= cmake openal:al,alut
CMAKE_ARGS+= -DJPEG_FACTORY:BOOL=ON \
-DENABLE_JS_SERVER:BOOL=ON \
-DFG_DATA_DIR:PATH=${LOCALBASE}/share/${PORTNAME} \
diff --git a/games/freeminer/Makefile b/games/freeminer/Makefile
index 207b4f4c07fc..fa51e87a1039 100644
--- a/games/freeminer/Makefile
+++ b/games/freeminer/Makefile
@@ -63,7 +63,7 @@ LUAJIT_LIB_DEPENDS= libluajit-5.1.so:${PORTSDIR}/lang/luajit
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCLIENT} && ${PORT_OPTIONS:MSOUND}
-USE_OPENAL+= yes
+USES+= openal
LIB_DEPENDS+= libvorbis.so:${PORTSDIR}/audio/libvorbis
.endif
diff --git a/games/gemrb/Makefile b/games/gemrb/Makefile
index d673922eae10..e072c1e8dbec 100644
--- a/games/gemrb/Makefile
+++ b/games/gemrb/Makefile
@@ -15,9 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
libvorbis.so:${PORTSDIR}/audio/libvorbis
-USES= cmake
+USES= cmake openal:al,alut
USE_SDL= sdl mixer ttf
-USE_OPENAL= al alut
USE_LDCONFIG= yes
USE_PYTHON= 2.6+
CFLAGS+= -L${LOCALBASE}/lib -I${LOCALBASE}/include
diff --git a/games/glest/Makefile b/games/glest/Makefile
index ea332d5e99e3..7ce04cf17c35 100644
--- a/games/glest/Makefile
+++ b/games/glest/Makefile
@@ -17,11 +17,9 @@ LIB_DEPENDS= xerces-c.27:${PORTSDIR}/textproc/xerces-c2 \
BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
RUN_DEPENDS= ${DATADIR}/servers.ini:${PORTSDIR}/games/glest-data
-USES= pkgconfig
+USES= dos2unix openal:al,alut pkgconfig
USE_AUTOTOOLS= automake:env autoconf:env
USE_ZIP= yes
-USE_OPENAL= al alut
-USE_DOS2UNIX= yes
USE_LUA= 5.1
USE_SDL= yes
USE_GL= yes
diff --git a/games/ioquake3/Makefile b/games/ioquake3/Makefile
index 3acfb56d5400..966836bea13c 100644
--- a/games/ioquake3/Makefile
+++ b/games/ioquake3/Makefile
@@ -138,7 +138,7 @@ MAKE_ARGS+= USE_CURL=0
.endif
.if ${PORT_OPTIONS:MOPENAL}
-USE_OPENAL= al
+USES+= openal:al
MAKE_ARGS+= USE_OPENAL=1 USE_OPENAL_DLOPEN=0
.else
MAKE_ARGS+= USE_OPENAL=0
diff --git a/games/linwarrior/Makefile b/games/linwarrior/Makefile
index 40a906de5f72..e89d6d0a6faa 100644
--- a/games/linwarrior/Makefile
+++ b/games/linwarrior/Makefile
@@ -12,8 +12,7 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Navigate a mech through a 3D world and fire at enemies
-USES= gmake
-USE_OPENAL= al alut
+USES= gmake openal:al,alut
USE_GL= gl glu
USE_SDL= sdl
diff --git a/games/lugaru/Makefile b/games/lugaru/Makefile
index 758d5a5cec4e..8108eb62c1b8 100644
--- a/games/lugaru/Makefile
+++ b/games/lugaru/Makefile
@@ -19,9 +19,8 @@ LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
libogg.so:${PORTSDIR}/audio/libogg
USE_BZIP2= yes
-USES= cmake pkgconfig
+USES= cmake openal:soft pkgconfig
USE_GL= glu
-USE_OPENAL= soft
USE_SDL= sdl
USE_XORG= sm
USE_GCC= yes
diff --git a/games/megaglest/Makefile b/games/megaglest/Makefile
index 3c0b29c11877..ecb39ba352ae 100644
--- a/games/megaglest/Makefile
+++ b/games/megaglest/Makefile
@@ -23,11 +23,9 @@ RUN_DEPENDS= ${DATADIR}/tutorials/2_basic_tutorial/2_basic_tutorial.xml:${PORTSD
SUB_FILES= pkg-message
USE_XZ= yes
-USES= cmake pkgconfig
-USE_DOS2UNIX= yes
+USES= cmake dos2unix openal:al,alut pkgconfig
USE_GL= glew gl glu
USE_LUA= 5.1
-USE_OPENAL= al alut
USE_SDL= yes
USE_WX= 2.8+
diff --git a/games/minecraft-client/Makefile b/games/minecraft-client/Makefile
index 045aa2b5be84..255182888d8d 100644
--- a/games/minecraft-client/Makefile
+++ b/games/minecraft-client/Makefile
@@ -35,7 +35,7 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNATIVE_LIBS}
-USE_OPENAL= soft
+USES+= openal:soft
RUN_DEPENDS+= ${JAVALIBDIR}/lwjgl/lwjgl_util.jar:${PORTSDIR}/games/lwjgl
JAVA_OS= native
JAVA_VENDOR= openjdk
diff --git a/games/minetest/Makefile b/games/minetest/Makefile
index 0ceff69d4ac4..c10d543b1e91 100644
--- a/games/minetest/Makefile
+++ b/games/minetest/Makefile
@@ -63,7 +63,7 @@ LUAJIT_LIB_DEPENDS= libluajit-5.1.so:${PORTSDIR}/lang/luajit
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCLIENT} && ${PORT_OPTIONS:MSOUND}
-USE_OPENAL+= yes
+USES+= openal
LIB_DEPENDS+= libvorbis.so:${PORTSDIR}/audio/libvorbis
.endif
diff --git a/games/naev/Makefile b/games/naev/Makefile
index 0ddbbef41bf9..e73a99c25f38 100644
--- a/games/naev/Makefile
+++ b/games/naev/Makefile
@@ -41,7 +41,7 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENAL}
-USE_OPENAL= yes
+USES+= openal
CONFIGURE_ARGS+= --with-openal=yes
.else
CONFIGURE_ARGS+= --with-openal=no
diff --git a/games/openastromenace/Makefile b/games/openastromenace/Makefile
index f15ae7ea9e14..efdccf32c157 100644
--- a/games/openastromenace/Makefile
+++ b/games/openastromenace/Makefile
@@ -20,12 +20,10 @@ LIB_DEPENDS+= vorbisfile:${PORTSDIR}/audio/libvorbis \
USE_BZIP2= yes
USE_GL= gl glu
-USE_OPENAL= al alut
WANT_SDL= yes
USE_SDL= sdl
-USES= cmake
+USES= cmake dos2unix openal:al,alut
WRKSRC= ${WRKDIR}/OpenAstroMenaceSVN
-USE_DOS2UNIX= yes
OPTIONS_SINGLE= LANG
OPTIONS_SINGLE_LANG= EN DE RU
diff --git a/games/openlierox/Makefile b/games/openlierox/Makefile
index 34dc0981a9a2..b400ab3bbb8d 100644
--- a/games/openlierox/Makefile
+++ b/games/openlierox/Makefile
@@ -19,14 +19,13 @@ LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd \
USE_BZIP2= yes
USE_SDL= sdl image
USE_GNOME= libxml2
-USE_OPENAL= yes
USE_GCC= yes
CFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USES= cmake pkgconfig
+USES= cmake openal pkgconfig
CMAKE_ARGS= -DHAWKNL_BUILTIN=YES \
-DLIBZIP_BUILTIN=YES \
-DBREAKPAD=NO \
diff --git a/games/py-fife/Makefile b/games/py-fife/Makefile
index 9177752eac52..76690b844c2a 100644
--- a/games/py-fife/Makefile
+++ b/games/py-fife/Makefile
@@ -25,7 +25,6 @@ LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
FETCH_ARGS= -Fpr
USE_SDL= sdl ttf image
-USE_OPENAL= al
USE_SCONS= yes
SCONS_ARGS= --prefix=${PREFIX} --python-prefix=${PYTHON_SITELIBDIR}
@@ -39,7 +38,7 @@ USE_PYTHON= 2.7
USE_XORG= xcursor
USE_GL= gl
-USES= pkgconfig
+USES= openal:al pkgconfig
NO_STAGE= yes
post-patch:
diff --git a/games/scorched3d/Makefile b/games/scorched3d/Makefile
index 1e8f83e79a5b..0b6f5bab2245 100644
--- a/games/scorched3d/Makefile
+++ b/games/scorched3d/Makefile
@@ -26,11 +26,10 @@ OPTIONS_DEFINE= MYSQL
WRKSRC= ${WRKDIR}/scorched
USE_GL= glu
-USE_OPENAL= al alut
USE_SDL= mixer net sdl
USE_WX= 2.4+
WX_CONF_ARGS= absolute
-USES= dos2unix iconv perl5 gmake pkgconfig
+USES= dos2unix gmake iconv openal:al,alut perl5 pkgconfig
USE_AUTOTOOLS= aclocal automake autoconf
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= --add-missing --copy --force --foreign
diff --git a/games/solarus/Makefile b/games/solarus/Makefile
index 22fb80cc828e..40d03f310a8c 100644
--- a/games/solarus/Makefile
+++ b/games/solarus/Makefile
@@ -16,11 +16,10 @@ LIB_DEPENDS= libphysfs.so:${PORTSDIR}/devel/physfs \
libogg.so:${PORTSDIR}/audio/libogg
USE_SDL= sdl ttf image
-USE_OPENAL= yes
PLIST_FILES= bin/solarus
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USES= cmake
+USES= cmake openal
.include <bsd.port.mk>
diff --git a/games/spring/Makefile b/games/spring/Makefile
index a4a00c8ad083..cbef9c7c64c2 100644
--- a/games/spring/Makefile
+++ b/games/spring/Makefile
@@ -27,13 +27,12 @@ ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON= relies on x86 floating-point math and amd64 atomic ops
USE_SDL= sdl
-USE_OPENAL= al
USE_GL= gl glu glew
USE_XORG= x11 xcursor
USE_LDCONFIG= yes
-USE_DOS2UNIX= *.h *.hpp *.cpp
+DOS2UNIX_GLOB= *.h *.hpp *.cpp
-USES= cmake compiler:c++11-lib
+USES= cmake compiler:c++11-lib dos2unix openal:al
CMAKE_ARGS= -DDATADIR:STRING="share/${PORTNAME}" \
-DAI_TYPES:STRING="NATIVE" \
-DDOCDIR:STRING="share/doc/${PORTNAME}" \
diff --git a/games/springlobby/Makefile b/games/springlobby/Makefile
index d9bcf9247810..f9e1b9900a4b 100644
--- a/games/springlobby/Makefile
+++ b/games/springlobby/Makefile
@@ -39,7 +39,7 @@ NLS_USES= gettext
SOUND_CMAKE_ON= -DOPTION_SOUND:BOOL=ON
SOUND_CMAKE_OFF= -DOPTION_SOUND:BOOL=OFF
SOUND_LIB_DEPENDS= libalure.so:${PORTSDIR}/audio/alure
-SOUND_USE= OPENAL=al
+SOUND_USES= openal:al
NOTIFY_CMAKE_ON= -DOPTION_NOTIFY=ON
NOTIFY_CMAKE_OFF= -DOPTION_NOTIFY=OFF
diff --git a/games/sumwars/Makefile b/games/sumwars/Makefile
index a03c93f898f6..71d83e042306 100644
--- a/games/sumwars/Makefile
+++ b/games/sumwars/Makefile
@@ -24,12 +24,11 @@ LIB_DEPENDS= CEGUIBase-0.7.9.0:${PORTSDIR}/graphics/cegui \
PocoNet.12:${PORTSDIR}/devel/poco \
physfs.1:${PORTSDIR}/devel/physfs
-USES= cmake gettext gmake pkgconfig
+USES= cmake gettext gmake openal:al,alut pkgconfig
USE_GL= gl glu
USE_BZIP2= yes
INSTALLS_ICONS= yes
USE_LUA= 5.1
-USE_OPENAL= al alut
FETCH_ARGS?= -pRr
diff --git a/games/supertux-devel/Makefile b/games/supertux-devel/Makefile
index 20d5bac54be1..6ad1a8199146 100644
--- a/games/supertux-devel/Makefile
+++ b/games/supertux-devel/Makefile
@@ -16,9 +16,8 @@ LIB_DEPENDS= libphysfs.so:${PORTSDIR}/devel/physfs \
USE_BZIP2= yes
USE_SDL= image
-USE_OPENAL= al
USE_GL= glew
-USES= cmake:outsource iconv
+USES= cmake:outsource iconv openal:al
LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
post-patch:
diff --git a/games/supertuxkart/Makefile b/games/supertuxkart/Makefile
index f4d6d59ed728..d6986119dfe5 100644
--- a/games/supertuxkart/Makefile
+++ b/games/supertuxkart/Makefile
@@ -18,10 +18,9 @@ LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
USE_BZIP2= yes
USE_GL= gl glu glut
-USE_OPENAL= al alut
-USES= cmake gettext gmake pkgconfig
+USES= cmake dos2unix gettext gmake openal:al,alut pkgconfig
USE_SDL= sdl
-USE_DOS2UNIX= lib/irrlicht/source/Irrlicht/Makefile
+DOS2UNIX_FILES= lib/irrlicht/source/Irrlicht/Makefile
CMAKE_ARGS= -DUSE_WIIUSE=NO
WRKSRC= ${WRKDIR}/SuperTuxKart-${PORTVERSION}
diff --git a/games/torcs/Makefile b/games/torcs/Makefile
index 522fa21f6cea..1dfe381feed7 100644
--- a/games/torcs/Makefile
+++ b/games/torcs/Makefile
@@ -18,14 +18,13 @@ LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
libvorbis.so:${PORTSDIR}/audio/libvorbis
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
-USES= gmake shebangfix
+USES= gmake openal:al,alut shebangfix
SHEBANG_FILES= src/tools/accc/accc.in src/tools/nfsperf/nfsperf.in \
src/tools/texmapper/texmapper.in src/tools/nfs2ac/nfs2ac.in \
src/tools/trackgen/trackgen.in \
src/modules/telemetry/telemetry.sh robotgen
USE_XORG= xrender xmu ice xext x11 xxf86vm xrandr
USE_GL= glut
-USE_OPENAL= al alut
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/games/tremulous/Makefile b/games/tremulous/Makefile
index 82fc9c81d8dc..836254727e98 100644
--- a/games/tremulous/Makefile
+++ b/games/tremulous/Makefile
@@ -52,7 +52,7 @@ MAKE_ENV+= HAVE_VM_COMPILED=true
.if ${PORT_OPTIONS:MCLIENT} || ${PORT_OPTIONS:MSMP_CLIENT}
# OpenAL
. if ${PORT_OPTIONS:MOPENAL}
-USE_OPENAL= al
+USES+= openal:al
MAKE_ENV+= USE_OPENAL=1
. if ${PORT_OPTIONS:MOPENAL_DLOPEN}
MAKE_ENV+= USE_OPENAL_DLOPEN=1
diff --git a/games/trigger/Makefile b/games/trigger/Makefile
index 8b7eb129f2d9..72d2e9d026a0 100644
--- a/games/trigger/Makefile
+++ b/games/trigger/Makefile
@@ -15,7 +15,7 @@ COMMENT= Rally car racing game
BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
LIB_DEPENDS= libphysfs.so:${PORTSDIR}/devel/physfs
-USE_OPENAL= al alut
+USES= openal:al,alut
USE_SDL= sdl image
USE_GL= glu
USE_BZIP2= yes
diff --git a/games/ufoai/Makefile b/games/ufoai/Makefile
index ce3c8926501a..ce0907e100a0 100644
--- a/games/ufoai/Makefile
+++ b/games/ufoai/Makefile
@@ -26,8 +26,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/base/default.cfg:${PORTSDIR}/games/u
USE_BZIP2= yes
USE_GL= yes
USE_SDL= sdl image mixer ttf
-USES= gettext gmake pkgconfig
-USE_OPENAL= soft
+USES= gettext gmake openal:soft pkgconfig
HAS_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-release
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
diff --git a/games/ultimatestunts/Makefile b/games/ultimatestunts/Makefile
index 47d08935a1d4..0de3d8140258 100644
--- a/games/ultimatestunts/Makefile
+++ b/games/ultimatestunts/Makefile
@@ -17,8 +17,7 @@ LIB_DEPENDS= vorbisfile.6:${PORTSDIR}/audio/libvorbis
OPTIONS_DEFINE= DOCS
-USES= pkgconfig gettext
-USE_OPENAL= al alut
+USES= gettext openal:al,alut pkgconfig
USE_GL= gl glu
USE_SDL= sdl image
GNU_CONFIGURE= yes
diff --git a/games/uqm/Makefile b/games/uqm/Makefile
index 6c5efc8ba241..da8247d3b80d 100644
--- a/games/uqm/Makefile
+++ b/games/uqm/Makefile
@@ -37,7 +37,7 @@ OPTIONS_SUB= yes
VOICE_DISTFILES= ${PORTNAME}-${DATAVERSION}-voice.uqm
MUSIC_DISTFILES= ${PORTNAME}-${DATAVERSION}-3domusic.uqm
-OPENAL_USE= OPENAL=al
+OPENAL_USES= openal:al
.include <bsd.port.options.mk>
diff --git a/games/valyriatear/Makefile b/games/valyriatear/Makefile
index 3c41b5e8eed5..6440bd4dd955 100644
--- a/games/valyriatear/Makefile
+++ b/games/valyriatear/Makefile
@@ -22,11 +22,10 @@ GH_ACCOUNT= Bertram25
GH_PROJECT= ValyriaTear
GH_COMMIT= a324297
-USES= cmake iconv
+USES= cmake iconv openal
CMAKE_ARGS= -DUSE_PCH_COMPILATION=OFF
USE_SDL= sdl image ttf
USE_GL= gl
-USE_OPENAL= yes
USE_LUA= 5.1
INSTALLS_ICONS= yes
LDFLAGS= -L${LOCALBASE}/lib ${ICONV_LIB} -lintl
diff --git a/games/vamos/Makefile b/games/vamos/Makefile
index b8022346d229..64284eaf6b5f 100644
--- a/games/vamos/Makefile
+++ b/games/vamos/Makefile
@@ -17,8 +17,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libboost_date_time.so:${PORTSDIR}/devel/boost-libs \
libpng15.so:${PORTSDIR}/graphics/png
-USES= pkgconfig
-USE_OPENAL= al alut
+USES= openal:al,alut pkgconfig
USE_XORG= sm ice x11 xi xext xmu
USE_GL= glut
USE_SDL= sdl
diff --git a/games/vavoom/Makefile b/games/vavoom/Makefile
index b51ea41fa074..8c2b8a9c0767 100644
--- a/games/vavoom/Makefile
+++ b/games/vavoom/Makefile
@@ -75,7 +75,7 @@ CMAKE_ARGS+= -DWITH_MIKMOD=N
.endif
.if ${PORT_OPTIONS:MOPENAL}
-USE_OPENAL= al
+USES+= openal:al
CMAKE_ARGS+= -DWITH_OPENAL=Y
.else
CMAKE_ARGS+= -DWITH_OPENAL=N
diff --git a/games/vegastrike/Makefile b/games/vegastrike/Makefile
index 4955a6317169..46af1355ef9e 100644
--- a/games/vegastrike/Makefile
+++ b/games/vegastrike/Makefile
@@ -15,10 +15,9 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
vorbis.4:${PORTSDIR}/audio/libvorbis \
ogg:${PORTSDIR}/audio/libogg
-USE_OPENAL= al
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake openal:al
USE_PYTHON= yes
USE_SDL= sdl
USE_XORG= sm ice xi x11 xext xrender xinerama xi xrandr xcursor \
diff --git a/games/warsow/Makefile b/games/warsow/Makefile
index a2f1056be955..5cd0ba21400b 100644
--- a/games/warsow/Makefile
+++ b/games/warsow/Makefile
@@ -40,6 +40,9 @@ OPENAL_DESC= Build OpenAL sound module
IRC_DESC= Build IRC client module
TV_SRV_DESC= Build Warsow TV server
+# USES needs to be before bsd.port.pre.mk
+OPENAL_USES= openal:al
+
NO_STAGE= yes
.include <bsd.port.pre.mk>
@@ -63,7 +66,6 @@ PLIST_FILES+= %%DATADIR%%/libs/snd_qf_${ARCH}.so
. endif
. if ${PORT_OPTIONS:MOPENAL}
-USE_OPENAL= al
ALL_TARGET+= openal
PLIST_FILES+= %%DATADIR%%/libs/snd_openal_${ARCH}.so
. endif
diff --git a/games/warzone2100/Makefile b/games/warzone2100/Makefile
index 2e8a40da3a54..d821dcdaef57 100644
--- a/games/warzone2100/Makefile
+++ b/games/warzone2100/Makefile
@@ -25,9 +25,8 @@ LIB_DEPENDS= libphysfs.so:${PORTSDIR}/devel/physfs \
RUN_DEPENDS= ${LOCALBASE}/lib/X11/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-fonts/dejavu
USE_XZ= yes
-USES= bison gmake pkgconfig compiler:c++11-lang # actually, old gcc fails on unknown -W flag
+USES= bison gmake openal:al pkgconfig compiler:c++11-lang # actually, old gcc fails on unknown -W flag
GNU_CONFIGURE= yes
-USE_OPENAL= al
USE_GL= yes
USE_SDL= sdl
USE_QT4= corelib network script gui moc_build
diff --git a/games/worldofpadman/Makefile b/games/worldofpadman/Makefile
index 0c523b4f917b..4c2d0ce5a949 100644
--- a/games/worldofpadman/Makefile
+++ b/games/worldofpadman/Makefile
@@ -65,7 +65,7 @@ MAKE_ENV+= USE_CURL_DLOPEN=1
. endif
# OpenAL
. if ${PORT_OPTIONS:MOPENAL}
-USE_OPENAL= al
+USES+= openal:al
MAKE_ENV+= USE_OPENAL=1
. if ${PORT_OPTIONS:MOPENAL_DLOPEN}
MAKE_ENV+= USE_OPENAL_DLOPEN=1
diff --git a/games/xpilot-ng-server/Makefile b/games/xpilot-ng-server/Makefile
index 60f51f32ec04..368960c60c4b 100644
--- a/games/xpilot-ng-server/Makefile
+++ b/games/xpilot-ng-server/Makefile
@@ -80,7 +80,7 @@ PLIST_SUB+= SDL="@comment "
.endif
.if ${PORT_OPTIONS:MSOUND}
-USE_OPENAL= al alut
+USES+= openal:al,alut
CONFIGURE_ARGS+=--enable-sound
CPPFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}