aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2013-03-02 22:32:48 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2013-03-02 22:32:48 +0000
commitddb097c515164665524ac44bdad0a760e6d7e9cc (patch)
tree189a0a82202d8273b3544d953ccfd229c1eb7faf /games
parent2a1a40c8bffa56d60449805274bebe889eb98fc8 (diff)
downloadports-ddb097c515164665524ac44bdad0a760e6d7e9cc.tar.gz
ports-ddb097c515164665524ac44bdad0a760e6d7e9cc.zip
- Update *_DEPENDS on x11-toolkits/py-tkinter after _tkinter.so relocation
Notes
Notes: svn path=/head/; revision=313303
Diffstat (limited to 'games')
-rw-r--r--games/ptkei/Makefile10
-rw-r--r--games/pyching/Makefile9
-rw-r--r--games/pysol/Makefile10
-rw-r--r--games/pysolfc/Makefile4
-rw-r--r--games/pythonchess/Makefile10
-rw-r--r--games/thudboard/Makefile9
6 files changed, 17 insertions, 35 deletions
diff --git a/games/ptkei/Makefile b/games/ptkei/Makefile
index ca85e6f08d96..c869c87e2b01 100644
--- a/games/ptkei/Makefile
+++ b/games/ptkei/Makefile
@@ -1,20 +1,16 @@
-# New ports collection makefile for: ptkei
-# Date created: 26 October 1999
-# Whom: Daniel O'Connor <darius@dons.net.au>
-#
+# Created by: Daniel O'Connor <darius@dons.net.au>
# $FreeBSD$
-#
PORTNAME= ptkei
PORTVERSION= 1.18.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= http://www.lfmm.org/ptkei/
MAINTAINER= ports@FreeBSD.org
COMMENT= A Python/Tk graphical client for Wolfpack Empire servers
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter \
${PYTHON_SITELIBDIR}/Pmw/__init__.py:${PORTSDIR}/x11-toolkits/py-Pmw
USE_PYTHON= yes
diff --git a/games/pyching/Makefile b/games/pyching/Makefile
index 061a566a5d65..d9444b165e9b 100644
--- a/games/pyching/Makefile
+++ b/games/pyching/Makefile
@@ -1,19 +1,16 @@
-# New ports collection makefile for: pyching
-# Date created: 5 July 2001
-# Whom: Hye-Shik Chang <perky@python.or.kr>
-#
+# Created by: Hye-Shik Chang <perky@python.or.kr>
# $FreeBSD$
-#
PORTNAME= pyching
PORTVERSION= 1.2.2
+PORTREVISION= 1
CATEGORIES= games python
MASTER_SITES= SF/${PORTNAME}/pyChing/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Consult a I Ching, an ancient Chinese book of wisdom
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
diff --git a/games/pysol/Makefile b/games/pysol/Makefile
index 6bbc52531823..7a9c081ba1ce 100644
--- a/games/pysol/Makefile
+++ b/games/pysol/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: PySol
-# Date created: 11 September 1998
-# Whom: Thomas Gellekum <tg@FreeBSD.org>
-#
+# Created by: Thomas Gellekum <tg@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= pysol
PORTVERSION= 4.82
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= http://www.pysol.org/download/pysol/:source \
${MASTER_SITE_LOCAL:S/$/:support/}
@@ -19,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Solitaire game, written in Python
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pysolsoundserver.so:${PORTSDIR}/audio/pysol-sound-server \
- ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+ ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
USE_BZIP2= yes
USE_PYTHON= yes
diff --git a/games/pysolfc/Makefile b/games/pysolfc/Makefile
index 858b0f3daf54..09601e9ee2f2 100644
--- a/games/pysolfc/Makefile
+++ b/games/pysolfc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pysolfc
PORTVERSION= 2.0
-PORTREVISION= 3
+PORTREVISION= 5
CATEGORIES= games python
MASTER_SITES= SF/${PORTNAME}/PySolFC/PySolFC-${PORTVERSION} \
SF/${PORTNAME}/PySolFC-Cardsets/PySolFC-Cardsets-${PORTVERSION}:cardsets
@@ -15,7 +15,7 @@ COMMENT= Solitaire game, written in Python and the successor of PySol
LICENSE= GPLv3
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter \
${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging
USE_BZIP2= yes
diff --git a/games/pythonchess/Makefile b/games/pythonchess/Makefile
index fbdc3cb250c6..f548f16f0945 100644
--- a/games/pythonchess/Makefile
+++ b/games/pythonchess/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: pythonchess
-# Date created: 24 November 2005
-# Whom: Alejandro Pulver <alejandro@varnet.biz>
-#
+# Created by: Alejandro Pulver <alejandro@varnet.biz>
# $FreeBSD$
-#
PORTNAME= pythonchess
PORTVERSION= 0.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= alepulver
@@ -16,7 +12,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Small program for playing chess against the computer
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
USE_PYTHON= yes
diff --git a/games/thudboard/Makefile b/games/thudboard/Makefile
index 706eac47a016..d66c17a9f353 100644
--- a/games/thudboard/Makefile
+++ b/games/thudboard/Makefile
@@ -1,19 +1,16 @@
-# New ports collection makefile for: ThudBoard
-# Date created: 04 Januar 2004
-# Whom: Jan Stocker <Jan.Stocker@t-online.de>
-#
+# Created by: Jan Stocker <Jan.Stocker@t-online.de>
# $FreeBSD$
-#
PORTNAME= thudboard
PORTVERSION= 1.8
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.million.nl/file/
MAINTAINER= lme@FreeBSD.org
COMMENT= The Discworld Boardgame Board
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
NO_WRKSUBDIR= yes
USE_PYTHON= yes