aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-27 13:41:11 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-27 13:41:11 +0000
commitd254b381ada7d95a5b06b3f02c1c764b14a7443c (patch)
tree8e55110f90c5797bdb619e427a77a1b346e492b5 /games
parentbffcd412adccdff52b62619113f179effc646e1e (diff)
downloadports-d254b381ada7d95a5b06b3f02c1c764b14a7443c.tar.gz
ports-d254b381ada7d95a5b06b3f02c1c764b14a7443c.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/boswars/Makefile30
1 files changed, 11 insertions, 19 deletions
diff --git a/games/boswars/Makefile b/games/boswars/Makefile
index 04270cc03133..0a8f6adc7be3 100644
--- a/games/boswars/Makefile
+++ b/games/boswars/Makefile
@@ -13,15 +13,14 @@ COMMENT= Futuristic real-time strategy game
LICENSE= GPLv2
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- theora:${PORTSDIR}/multimedia/libtheora \
- vorbis:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libtheora.so:${PORTSDIR}/multimedia/libtheora \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis
-USES= lua:51
+USES= lua:51 scons
USE_SDL= sdl
USE_GL= yes
-USE_SCONS= yes
-SCONS_ARGS+= opengl=1
+MAKE_ARGS+= opengl=1
CPPPATH= ${LOCALBASE}/include ${LUA_INCDIR}
LIBPATH= ${LOCALBASE}/lib ${LUA_LIBDIR}
CFLAGS+= -DSTRATAGUS_LIB_PATH='"\"${DATADIR}\""'
@@ -31,12 +30,8 @@ DESKTOP_ENTRIES= "Bos Wars" "${COMMENT}" "" \
PORTDOCS= *
-NO_STAGE= yes
-
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e '\
s|-pthread|${PTHREAD_LIBS}|g; \
@@ -45,16 +40,13 @@ post-patch:
${WRKSRC}/SConstruct
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${MKDIR} ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DATADIR}
.for f in campaigns graphics intro languages maps patches scripts sounds units
- ${CP} -R ${WRKSRC}/${f} ${DATADIR}
+ ${CP} -R ${WRKSRC}/${f} ${STAGEDIR}${DATADIR}
.endfor
-
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/CHANGELOG ${WRKSRC}/README.txt ${DOCSDIR}
- ${COPYTREE_SHARE} ${WRKSRC}/doc/* ${DOCSDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CHANGELOG ${WRKSRC}/README.txt ${STAGEDIR}${DOCSDIR}
+ ${COPYTREE_SHARE} ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>