aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-09-19 16:25:04 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-09-19 16:25:04 +0000
commitf58d5676302cdab98150674a94dd7b8152fdc7ca (patch)
tree6297d8278ac0fc7fb277537618c4c38af87e57e8 /games
parentbeb87541edf7a2d60443184f09a61282161fbcf8 (diff)
downloadports-f58d5676302cdab98150674a94dd7b8152fdc7ca.tar.gz
ports-f58d5676302cdab98150674a94dd7b8152fdc7ca.zip
- Fix build for spark64
PR: 240641 Submitted by: pkubaj@FreeBSD.org
Notes
Notes: svn path=/head/; revision=512358
Diffstat (limited to 'games')
-rw-r--r--games/openspades/Makefile6
-rw-r--r--games/openspades/files/patch-Sources_AngelScript_source_as__config.h11
2 files changed, 15 insertions, 2 deletions
diff --git a/games/openspades/Makefile b/games/openspades/Makefile
index c2aa449897f8..4039fd617224 100644
--- a/games/openspades/Makefile
+++ b/games/openspades/Makefile
@@ -15,7 +15,7 @@ COMMENT= Compatible client of Ace of Spades
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS= amd64 powerpc64
ONLY_FOR_ARCHS_REASON= bundles non-portable AngelScript
BUILD_DEPENDS= convert:graphics/ImageMagick6 # for building icons
@@ -25,11 +25,13 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
USE_GITHUB= yes
GH_ACCOUNT= yvt
-USES= cmake:insource compiler:c++11-lib desktop-file-utils gl gnome openal
+USES= cmake:insource compiler:c++11-lib desktop-file-utils dos2unix \
+ gl gnome openal sdl xorg
CMAKE_ARGS= -DOPENSPADES_RESOURCES=OFF \
-DOPENSPADES_INSTALL_MAN="man/man6" \
-DOPENSPADES_INSTALL_BINARY="bin" \
-DOPENSPADES_INSTALL_RESOURCES="${DATADIR_REL}"
+DOS2UNIX_FILES= Sources/AngelScript/source/as_config.h
USE_SDL= sdl2 image2
USE_GL= gl glew
INSTALLS_ICONS= yes
diff --git a/games/openspades/files/patch-Sources_AngelScript_source_as__config.h b/games/openspades/files/patch-Sources_AngelScript_source_as__config.h
new file mode 100644
index 000000000000..023389277959
--- /dev/null
+++ b/games/openspades/files/patch-Sources_AngelScript_source_as__config.h
@@ -0,0 +1,11 @@
+--- Sources/AngelScript/source/as_config.h.orig 2019-09-17 11:18:51 UTC
++++ Sources/AngelScript/source/as_config.h
+@@ -947,6 +947,8 @@
+ #define COMPLEX_RETURN_MASK (asOBJ_APP_CLASS_DESTRUCTOR | asOBJ_APP_CLASS_COPY_CONSTRUCTOR | asOBJ_APP_ARRAY)
+ #define THISCALL_PASS_OBJECT_POINTER_ON_THE_STACK
+ #define AS_X86
++ #elif defined(__powerpc64__)
++ #define AS_MAX_PORTABILITY
+ #elif defined(__LP64__)
+ #define AS_X64_GCC
+ #define HAS_128_BIT_PRIMITIVES