aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-08-11 19:09:02 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-08-11 19:09:02 +0000
commit62bdd749b054dcff40fcd17442066b1afe060207 (patch)
tree6130adb64e1fcc5ac189d0b104e3e3e7f0d1b720 /games
parented6a67b6a92b741db852acc3e930555ae0f8de8b (diff)
downloadports-62bdd749b054dcff40fcd17442066b1afe060207.tar.gz
ports-62bdd749b054dcff40fcd17442066b1afe060207.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/quake2forge/Makefile41
-rw-r--r--games/quake2forge/distinfo4
-rw-r--r--games/quake2forge/files/patch-configure10
-rw-r--r--games/quake2forge/files/patch-configure.in18
-rw-r--r--games/quake2forge/files/patch-main.c42
-rw-r--r--games/quake2forge/pkg-plist6
6 files changed, 54 insertions, 67 deletions
diff --git a/games/quake2forge/Makefile b/games/quake2forge/Makefile
index 2c82b015d258..534caaf3e423 100644
--- a/games/quake2forge/Makefile
+++ b/games/quake2forge/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= quake2forge
-PORTVERSION= 0.2.1
-PORTREVISION= 2
+PORTVERSION= 0.3
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= quake
+MASTER_SITES= ftp://ftp.quakeforge.net/quake2forge/
DISTNAME= quake2-${PORTVERSION}
MAINTAINER= q@uni.de
@@ -18,16 +16,16 @@ COMMENT= First Person Shooter with many addons available
USE_BZIP2= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
+USE_AUTOCONF_VER=259
USE_XLIB= yes
-INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
WANT_SDL= yes
-LDCONFIG_DIRS= ${PREFIX}/lib/quake2 ${PREFIX}/lib/quake2/baseq2 ${PREFIX}/lib/quake2/ctf
.include <bsd.port.pre.mk>
-CONFIGURE_ARGS= --enable-static=no --program-transform-name='s/^quake2$$/q2f/'
-CONFIGURE_TARGET=
+CONFIGURE_ARGS= --program-transform-name='s/^quake2$$/q2f/'
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
.if ${HAVE_SDL:Msdl}!=""
WITH_SDL= yes
@@ -37,6 +35,19 @@ WITH_SDL= yes
WITH_SVGALIB= yes
.endif
+.if exists(${LOCALBASE}/lib/libao.so.3)
+WITH_LIBAO= yes
+.endif
+
+.if !defined (WITHOUT_LIBAO) && defined(WITH_LIBAO)
+LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao
+CONFIGURE_ARGS+=--with-ao=${LOCALBASE}
+PLIST_SUB+= AO:=""
+.else
+CONFIGURE_ARGS+=--without-ao
+PLIST_SUB+= AO:="@comment "
+.endif
+
.if !defined (WITHOUT_SVGALIB) && defined(WITH_SVGALIB)
LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
CONFIGURE_ARGS+=--with-svgalib=${LOCALBASE}
@@ -70,6 +81,9 @@ PLIST_SUB+= SDLGL:="@comment "
.endif
pre-everything::
+.if !defined(WITH_LIBAO)
+ @${ECHO_MSG} "Define WITH_LIBAO to use libao"
+.endif
.if !defined(WITH_SVGALIB)
@${ECHO_MSG} "Define WITH_SVGALIB to use svgalib"
.endif
@@ -80,13 +94,18 @@ pre-everything::
@${ECHO_MSG} "Define WITHOUT_GL to disable GL"
.endif
+.if ( ${OSVERSION} < 500000 )
+post-patch:
+ @${REINPLACE_CMD} -e 's/%zu/%u/g' ${WRKSRC}/src/main.c
+.endif
+
do-install:
@(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/quake2
${MKDIR} ${PREFIX}/share/doc/quake2/ctf
${INSTALL_MAN} ${WRKSRC}/docs/README.* ${WRKSRC}/docs/*.txt ${PREFIX}/share/doc/quake2
- ${INSTALL_MAN} ${WRKSRC}/docs/ctf/* ${PREFIX}/share/doc/quake2/ctf
+ ${INSTALL_MAN} ${WRKSRC}/docs/ctf/*.html ${WRKSRC}/docs/ctf/*.gif \
+ ${WRKSRC}/docs/ctf/*.jpg ${PREFIX}/share/doc/quake2/ctf
.endif
post-install:
diff --git a/games/quake2forge/distinfo b/games/quake2forge/distinfo
index 29ad28858225..a6d8dc9e6db2 100644
--- a/games/quake2forge/distinfo
+++ b/games/quake2forge/distinfo
@@ -1,2 +1,2 @@
-MD5 (quake2-0.2.1.tar.bz2) = 564bef79bd83f3b9fc1d34a19b29ae2c
-SIZE (quake2-0.2.1.tar.bz2) = 1286703
+MD5 (quake2-0.3.tar.bz2) = af115d76a2f09d5847acb10e55bfa850
+SIZE (quake2-0.3.tar.bz2) = 1383644
diff --git a/games/quake2forge/files/patch-configure b/games/quake2forge/files/patch-configure
deleted file mode 100644
index 17234f191498..000000000000
--- a/games/quake2forge/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Mon Mar 10 16:54:16 2003
-+++ configure Mon Mar 10 16:54:17 2003
-@@ -7829,6 +7829,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/games/quake2forge/files/patch-configure.in b/games/quake2forge/files/patch-configure.in
new file mode 100644
index 000000000000..054b34a97af5
--- /dev/null
+++ b/games/quake2forge/files/patch-configure.in
@@ -0,0 +1,18 @@
+--- configure.in.orig Tue Mar 16 11:07:38 2004
++++ configure.in Thu Aug 5 09:59:56 2004
+@@ -109,6 +109,7 @@
+ # test for the library first, for people who may have the libs
+ # installed but no headers
+ AC_CHECK_LIB(vga, vga_getmousetype,
++ SVGALIB_LIBS="$SVGALIB_LIBS -lvga"
+ HAVE_SVGALIB=maybe,
+ HAVE_SVGALIB=no,
+ [ $SVGALIB_LIBS ]
+@@ -125,7 +126,6 @@
+ # if it's all there, define the relevant bits
+ if test "x$HAVE_SVGALIB" = xyes ; then
+ AC_DEFINE(HAVE_SVGALIB, 1, [Define this if you have SVGAlib])
+- SVGALIB_LIBS="-lvga"
+ AC_SUBST(SVGALIB_CFLAGS)
+ AC_SUBST(SVGALIB_LIBS)
+ else
diff --git a/games/quake2forge/files/patch-main.c b/games/quake2forge/files/patch-main.c
deleted file mode 100644
index ca04bcd5b26b..000000000000
--- a/games/quake2forge/files/patch-main.c
+++ /dev/null
@@ -1,42 +0,0 @@
---- src/main.c.orig Fri Feb 7 14:25:46 2003
-+++ src/main.c Fri Feb 7 14:34:14 2003
-@@ -49,12 +49,21 @@
- #include <mntent.h>
- #elif defined(__FreeBSD__) || defined(__bsd__) || defined (__NetBSD__)
- #include <fstab.h>
-+ #include <pthread.h>
- #elif defined(__sun__)
- #include <sys/file.h>
- #endif
-
- #ifdef HAVE_DLOPEN
- # include <dlfcn.h>
-+#endif
-+
-+/* This should probably go into configure
-+ * BSDs and Linux have SIGIO, Solaris needs SIGPOLL
-+ * This should probably be changed the other way round
-+ * SIGIO as default and SIGPOLL only for Solrais */
-+#ifndef SIGPOLL
-+#define SIGPOLL SIGIO
- #endif
-
- #include "qcommon.h"
-@@ -518,7 +527,7 @@
- ret = fread(ptr, size, nitems, fp);
- err = errno;
- if (ret != nitems) {
-- printf("verify_fread(...,%d,%d,...): return value: %d\n", size, nitems, ret);
-+ printf("verify_fread(...,%lu,%lu,...): return value: %lu\n", (unsigned long)size, (unsigned long)nitems, (unsigned long)ret);
- if (ret == 0 && ferror(fp)) {
- printf(" error: %s\n", strerror(err));
- printf(" fileno=%d\n", fileno(fp));
-@@ -536,7 +545,7 @@
- ret = fwrite(ptr, size, nitems, fp);
- err = errno;
- if (ret != nitems) {
-- printf("verify_fwrite(...,%d,%d,...) = %d\n", size, nitems, ret);
-+ printf("verify_fwrite(...,%lu,%lu,...) = %lu\n", (unsigned long)size, (unsigned long)nitems, (unsigned long)ret);
- if (ret == 0 && ferror(fp)) {
- printf(" error: %s\n", strerror(err));
- printf(" fileno=%d\n", fileno(fp));
diff --git a/games/quake2forge/pkg-plist b/games/quake2forge/pkg-plist
index b6266134aa1e..8bce7870d3b0 100644
--- a/games/quake2forge/pkg-plist
+++ b/games/quake2forge/pkg-plist
@@ -5,6 +5,9 @@ bin/q2f
%%GL:%%lib/quake2/ref_glx.so
%%SVGA:%%%%GL:%%lib/quake2/ref_tdfx.so
lib/quake2/ref_softx.so
+lib/quake2/snd_oss.so
+%%SDL:%%lib/quake2/snd_sdl.so
+%%AO:%%lib/quake2/snd_ao.so
lib/quake2/baseq2/game.so
lib/quake2/ctf/game.so
%%PORTDOCS%%share/doc/quake2/README.axp
@@ -14,6 +17,7 @@ lib/quake2/ctf/game.so
%%PORTDOCS%%share/doc/quake2/README.sdl
%%PORTDOCS%%share/doc/quake2/README.solaris
%%PORTDOCS%%share/doc/quake2/README.Solaris
+%%PORTDOCS%%share/doc/quake2/README.sound
%%PORTDOCS%%share/doc/quake2/TODO-ctf.txt
%%PORTDOCS%%share/doc/quake2/changes-ctf.txt
%%PORTDOCS%%share/doc/quake2/changes.txt
@@ -37,8 +41,6 @@ lib/quake2/ctf/game.so
%%PORTDOCS%%@dirrm share/doc/quake2/ctf
%%PORTDOCS%%@dirrm share/doc/quake2
@dirrm lib/quake2/baseq2
-@dirrm lib/quake2/xatrix
-@dirrm lib/quake2/rogue
@dirrm lib/quake2/ctf
@dirrm lib/quake2
@unexec rm %D/share/quake2/baseq2/config.cfg 2>/dev/null || true