aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-21 00:04:12 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-21 00:04:12 +0000
commit253b26c1a15a3ff8abd201fd64c2552c200dd19f (patch)
tree5f46ae752fc9cde08d32609752335fc8ab3337ec /games
parent5104e2f410ebdef6de24a6fdd9575890d1e361c6 (diff)
downloadports-253b26c1a15a3ff8abd201fd64c2552c200dd19f.tar.gz
ports-253b26c1a15a3ff8abd201fd64c2552c200dd19f.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/qgo/Makefile2
-rw-r--r--games/qgo/distinfo6
-rw-r--r--games/qgo/files/patch-src::mainwin.cpp15
-rw-r--r--games/qgo/files/patch-src__mainwin.cpp15
-rw-r--r--games/qgo/files/patch-src__parser.cpp18
-rw-r--r--games/qgo/pkg-plist2
6 files changed, 37 insertions, 21 deletions
diff --git a/games/qgo/Makefile b/games/qgo/Makefile
index 8adb7ed0caae..713ae56ce427 100644
--- a/games/qgo/Makefile
+++ b/games/qgo/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= qgo
-PORTVERSION= 1.0.3.2
+PORTVERSION= 1.0.4.2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/games/qgo/distinfo b/games/qgo/distinfo
index 9dd2ee9da460..41e4e99e291b 100644
--- a/games/qgo/distinfo
+++ b/games/qgo/distinfo
@@ -1,3 +1,3 @@
-MD5 (qgo-1.0.3-r2.tar.gz) = 575deb5a2b4a34820c389b5cec361e28
-SHA256 (qgo-1.0.3-r2.tar.gz) = 8d9ae3e825857156fa131b796e51883976af80fb677214af2967c8658d158d7f
-SIZE (qgo-1.0.3-r2.tar.gz) = 2208465
+MD5 (qgo-1.0.4-r2.tar.gz) = 49da743ca769d8d18fc3a4b7a6aa0bf8
+SHA256 (qgo-1.0.4-r2.tar.gz) = b57c07b8270b0da8ea15a146b637e1a9c2c550f306d80ed700ead97ef76244da
+SIZE (qgo-1.0.4-r2.tar.gz) = 2316848
diff --git a/games/qgo/files/patch-src::mainwin.cpp b/games/qgo/files/patch-src::mainwin.cpp
deleted file mode 100644
index 389c041e1d8c..000000000000
--- a/games/qgo/files/patch-src::mainwin.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/mainwin.cpp.orig Mon Nov 29 15:42:39 2004
-+++ src/mainwin.cpp Tue Dec 14 19:37:16 2004
-@@ -1571,10 +1571,10 @@
- //set the params of "who command"
- if ((whoBox1->currentItem() >1) || (whoBox2->currentItem() >1))
- {
-- wparam.append(whoBox1->currentItem()==1 ? "9p" : whoBox1->currentText());
-+ wparam.append(whoBox1->currentItem()==1 ? QString("9p") : whoBox1->currentText());
- if ((whoBox1->currentItem()) && (whoBox2->currentItem()))
- wparam.append("-");
-- wparam.append(whoBox2->currentItem()==1 ? "9p" : whoBox2->currentText());
-+ wparam.append(whoBox2->currentItem()==1 ? QString("9p") : whoBox2->currentText());
- }
- else if ((whoBox1->currentItem()) || (whoBox2->currentItem()))
- wparam.append("1p-9p");
diff --git a/games/qgo/files/patch-src__mainwin.cpp b/games/qgo/files/patch-src__mainwin.cpp
new file mode 100644
index 000000000000..d8ce8705035e
--- /dev/null
+++ b/games/qgo/files/patch-src__mainwin.cpp
@@ -0,0 +1,15 @@
+--- src/mainwin.cpp.orig Thu Nov 24 08:38:33 2005
++++ src/mainwin.cpp Wed Jan 18 03:09:52 2006
+@@ -1604,10 +1604,10 @@
+ //set the params of "who command"
+ if ((whoBox1->currentItem() >1) || (whoBox2->currentItem() >1))
+ {
+- wparam.append(whoBox1->currentItem()==1 ? "9p" : whoBox1->currentText());
++ wparam.append(whoBox1->currentItem()==1 ? QString("9p") : whoBox1->currentText());
+ if ((whoBox1->currentItem()) && (whoBox2->currentItem()))
+ wparam.append("-");
+- wparam.append(whoBox2->currentItem()==1 ? "9p" : whoBox2->currentText());
++ wparam.append(whoBox2->currentItem()==1 ? QString("9p") : whoBox2->currentText());
+ }
+ else if ((whoBox1->currentItem()) || (whoBox2->currentItem()))
+ wparam.append("1p-9p");
diff --git a/games/qgo/files/patch-src__parser.cpp b/games/qgo/files/patch-src__parser.cpp
new file mode 100644
index 000000000000..808b76151330
--- /dev/null
+++ b/games/qgo/files/patch-src__parser.cpp
@@ -0,0 +1,18 @@
+--- src/parser.cpp.orig Tue Dec 27 17:49:01 2005
++++ src/parser.cpp Wed Jan 18 03:20:10 2006
+@@ -1176,13 +1176,13 @@
+ {
+ aGameInfo->wname = element(line, 1, ":","(");
+ aGameInfo->wtime = (time1.toInt()==0 ? time2 : time1);
+- aGameInfo->wstones = (time1.toInt()==0 ?stones: "-1") ;
++ aGameInfo->wstones = (time1.toInt()==0 ? stones : QString("-1")) ;
+ }
+ else if (line.contains("(B)"))
+ {
+ aGameInfo->bname = element(line, 1, ":","(");
+ aGameInfo->btime = (time1.toInt()==0 ? time2 : time1);
+- aGameInfo->bstones = (time1.toInt()==0 ? stones:"-1") ;
++ aGameInfo->bstones = (time1.toInt()==0 ? stones : QString("-1")) ;
+ }
+ else //never know with IGS ...
+ return IT_OTHER;
diff --git a/games/qgo/pkg-plist b/games/qgo/pkg-plist
index a731d404f619..f8cc9375a0d7 100644
--- a/games/qgo/pkg-plist
+++ b/games/qgo/pkg-plist
@@ -13,7 +13,6 @@ share/qGo/pics/synthetic_1.png
share/qGo/pics/synthetic_2.png
share/qGo/sounds/click.wav
share/qGo/sounds/connect.wav
-share/qGo/sounds/connect2.wav
share/qGo/sounds/enter.wav
share/qGo/sounds/gameend.wav
share/qGo/sounds/leave.wav
@@ -21,7 +20,6 @@ share/qGo/sounds/match.wav
share/qGo/sounds/pass.wav
share/qGo/sounds/say.wav
share/qGo/sounds/stone.wav
-share/qGo/sounds/stone2.wav
share/qGo/sounds/talk.wav
share/qGo/sounds/tictoc.wav
share/qGo/translations/qgo_cz.qm