aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-12-04 01:20:10 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-12-04 01:20:10 +0000
commit356f504d8bd25fd970152ee2cae2d6a41c5e086d (patch)
treeba39a78fec89756ac5bba1138bdc3a4e7678df92 /games
parent15d05e49d81eb8401313d504e002b5a35056ace9 (diff)
downloadports-356f504d8bd25fd970152ee2cae2d6a41c5e086d.tar.gz
ports-356f504d8bd25fd970152ee2cae2d6a41c5e086d.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/xmoto/Makefile20
-rw-r--r--games/xmoto/distinfo5
-rw-r--r--games/xmoto/files/patch-Makefile.in13
-rw-r--r--games/xmoto/files/patch-configure20
-rw-r--r--games/xmoto/files/patch-src-VCommon.h12
5 files changed, 26 insertions, 44 deletions
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index 6e7f76b58bbd..f589bd112c14 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xmoto
-PORTVERSION= 0.1.6
+PORTVERSION= 0.1.10
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,13 +17,15 @@ COMMENT= Challenging 2D motocross platform game
LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
png.5:${PORTSDIR}/graphics/png \
- jpeg.9:${PORTSDIR}/graphics/jpeg
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ lua.5:${PORTSDIR}/lang/lua
+BUILD_DEPENDS= ${X11BASE}/lib/libode.a:${PORTSDIR}/devel/ode
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GL= yes
USE_REINPLACE= yes
-USE_SDL= sdl
+USE_SDL= sdl mixer
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
@@ -34,15 +36,15 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PORTDOCS= README ChangeLog
-# game is still in alpha state, other archs are untested
-ONLY_FOR_ARCHS= i386
-
-post-patch:
+post-extract:
@${FIND} ${WRKSRC}/src -name "*.cpp" -o -name "*.h" | \
${XARGS} ${REINPLACE_CMD} -e "s|$$(${PRINTF} '\r')||g"
+
+post-patch:
@${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/src/VCommon.h
- @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/src/ode/config.h \
- ${WRKSRC}/src/image/tim_memory_crt.cpp
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/src/image/tim_memory_crt.cpp
+ @${REINPLACE_CMD} -e 's|-lSDL |`${SDL_CONFIG} --libs` |' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|endian.h|sys/endian.h|' ${WRKSRC}/src/VCommon.h
.if !defined(NOPORTDOCS)
post-install:
diff --git a/games/xmoto/distinfo b/games/xmoto/distinfo
index bbb4d3f6a7d8..b3c804db14ee 100644
--- a/games/xmoto/distinfo
+++ b/games/xmoto/distinfo
@@ -1,2 +1,3 @@
-MD5 (xmoto-0.1.6-src.tar.gz) = b5d11e0f90ab5ff886c1dc90fa15cb2e
-SIZE (xmoto-0.1.6-src.tar.gz) = 2780752
+MD5 (xmoto-0.1.10-src.tar.gz) = bd91f049fc60e5036112090f8d89ecea
+SHA256 (xmoto-0.1.10-src.tar.gz) = 794870e45736402fd95090e436fe9eed863b8f5036b6b4290a1bd470fcc0a6a7
+SIZE (xmoto-0.1.10-src.tar.gz) = 2776333
diff --git a/games/xmoto/files/patch-Makefile.in b/games/xmoto/files/patch-Makefile.in
deleted file mode 100644
index d739d2ee4394..000000000000
--- a/games/xmoto/files/patch-Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.in.orig Thu Oct 6 19:21:49 2005
-+++ Makefile.in Fri Oct 7 18:25:32 2005
-@@ -76,8 +76,8 @@
- am__quote = @am__quote@
- install_sh = @install_sh@
- INCLUDES = -Isrc
--CXXFLAGS = -w -O3 -DGAMEDATADIR=\"$(datadir)/@PACKAGE@\"
--CFLAGS = -w -O3 -DGAMEDATADIR=\"$(datadir)/@PACKAGE@\"
-+CXXFLAGS = @CXXFLAGS@ -DGAMEDATADIR=\"$(datadir)/@PACKAGE@\"
-+CFLAGS = @CFLAGS@ -DGAMEDATADIR=\"$(datadir)/@PACKAGE@\"
- SUBDIRS = bin
-
- image_SOURCES = src/image/tim.cpp src/image/tim_io_stdio.cpp \
diff --git a/games/xmoto/files/patch-configure b/games/xmoto/files/patch-configure
deleted file mode 100644
index 23ee491762f2..000000000000
--- a/games/xmoto/files/patch-configure
+++ /dev/null
@@ -1,20 +0,0 @@
---- configure.orig Thu Oct 6 19:21:49 2005
-+++ configure Fri Oct 7 04:53:57 2005
-@@ -3377,7 +3377,7 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lSDL $LIBS"
-+LIBS="`$SDL_CONFIG --libs` $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
-@@ -3439,7 +3439,7 @@
- #define HAVE_LIBSDL 1
- _ACEOF
-
-- LIBS="-lSDL $LIBS"
-+ LIBS="`$SDL_CONFIG --libs` $LIBS"
-
- else
-
diff --git a/games/xmoto/files/patch-src-VCommon.h b/games/xmoto/files/patch-src-VCommon.h
new file mode 100644
index 000000000000..867637048475
--- /dev/null
+++ b/games/xmoto/files/patch-src-VCommon.h
@@ -0,0 +1,12 @@
+--- src/VCommon.h.orig Sun Dec 4 01:53:03 2005
++++ src/VCommon.h Sun Dec 4 01:53:35 2005
+@@ -69,8 +69,7 @@
+
+ #include <string>
+ #include <vector>
+-#include <ostream>
+-#include <istream>
++#include <iostream>
+
+ #include <stdio.h>
+ #include <math.h>