aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDaniel Eischen <deischen@FreeBSD.org>2013-07-26 18:38:38 +0000
committerDaniel Eischen <deischen@FreeBSD.org>2013-07-26 18:38:38 +0000
commit720530561de96d6bc9a347c1fce27f69baa6c259 (patch)
tree35046818f63a16d77717586bce6584ee646a40c7 /games
parentcd9e944e392cc38399e17f3951741611cc035862 (diff)
downloadports-720530561de96d6bc9a347c1fce27f69baa6c259.tar.gz
ports-720530561de96d6bc9a347c1fce27f69baa6c259.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/vamos/Makefile51
-rw-r--r--games/vamos/distinfo2
-rw-r--r--games/vamos/pkg-descr4
-rw-r--r--games/vamos/pkg-plist6
4 files changed, 48 insertions, 15 deletions
diff --git a/games/vamos/Makefile b/games/vamos/Makefile
index 736c6d1ef196..28dcada294f0 100644
--- a/games/vamos/Makefile
+++ b/games/vamos/Makefile
@@ -1,21 +1,19 @@
-# Ports collection makefile for: vamos
-# Date created: Mar 15, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= vamos
PORTVERSION= 0.7.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
-MASTER_SITES= SF
+MASTER_SITES= SF \
+ SF/nemysisfreebsdp/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}_icons${EXTRACT_SUFX}:icons
-MAINTAINER= ports@FreeBSD.org
-COMMENT= An automotive simulation framework
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Automotive simulation framework
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
@@ -23,18 +21,32 @@ USE_OPENAL= al alut
USE_XORG= sm ice x11 xi xext xmu
USE_GL= glut
USE_SDL= sdl
-USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= ac_cv_header_boost_test_unit_test_hpp=no \
ac_cv_lib_freeglut_glutGetModifiers=no
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
-INFO= vamos
-
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+# Wrong versioning upstream
+PORTSCOUT= skipv:0.7.1
+
+INFO= vamos
+
+PORTDOCS= AUTHORS ChangeLog README TODO
+
+INSTALLS_ICONS= yes
+ICON_SIZES= 32x32 48x48 64x64 72x72 96x96
+
+DESKTOP_ENTRIES="Vamos" "${COMMENT}" ${PORTNAME} \
+ "${PORTNAME}" "Game;ArcadeGame;" false
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-extract:
@${CHMOD} ${BINMODE} ${WRKSRC}/config/install-sh
@@ -46,4 +58,17 @@ post-patch:
/^AM_CXXFLAGS/s| -DBOOST_TEST_DYN_LINK|| ; \
/^AM_CXXFLAGS/s| -L/usr/lib/boost||'
+post-install:
+.for s in ${ICON_SIZES}
+ ${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
+ ${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+.endfor
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps
+
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/games/vamos/distinfo b/games/vamos/distinfo
index a3a0c32914b3..880848dc4e97 100644
--- a/games/vamos/distinfo
+++ b/games/vamos/distinfo
@@ -1,2 +1,4 @@
SHA256 (vamos-0.7.0.tar.gz) = ee4d6bf92c1769ed1cf47cb000316df02815dc866f91e22450d1a008f65d6af9
SIZE (vamos-0.7.0.tar.gz) = 1648589
+SHA256 (vamos_icons.tar.gz) = 52bc6a4fea63c8a23a76b059ee942dda6738483e04d1e5afb10a8184f875f803
+SIZE (vamos_icons.tar.gz) = 15360
diff --git a/games/vamos/pkg-descr b/games/vamos/pkg-descr
index 3d9c85ab5470..4cc95a61c6dc 100644
--- a/games/vamos/pkg-descr
+++ b/games/vamos/pkg-descr
@@ -1,5 +1,5 @@
Vamos is an automotive simulation framework with an emphasis on thorough
-physical modeling and good C++ design. Vamos includes a real-time, first-
-person, 3D driving application.
+physical modeling and good C++ design. Vamos includes a real-time,
+first-person, 3D driving application.
WWW: http://vamos.sourceforge.net/
diff --git a/games/vamos/pkg-plist b/games/vamos/pkg-plist
index f1880e2982e1..28b4d5c6eb0c 100644
--- a/games/vamos/pkg-plist
+++ b/games/vamos/pkg-plist
@@ -70,6 +70,12 @@ lib/libvamos-world.a
lib/libvamos-world.la
lib/libvamos-world.so
lib/libvamos-world.so.0
+share/icons/hicolor/32x32/apps/vamos.png
+share/icons/hicolor/48x48/apps/vamos.png
+share/icons/hicolor/64x64/apps/vamos.png
+share/icons/hicolor/72x72/apps/vamos.png
+share/icons/hicolor/96x96/apps/vamos.png
+share/pixmaps/vamos.png
%%DATADIR%%/cars/F1-1967-arm.ac
%%DATADIR%%/cars/F1-1967-interior.ac
%%DATADIR%%/cars/F1-1967-stator.ac