aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDejan Lesjak <lesi@FreeBSD.org>2005-07-25 02:11:13 +0000
committerDejan Lesjak <lesi@FreeBSD.org>2005-07-25 02:11:13 +0000
commitb5d9a988e5cf6aad3596b7c2f5d0634973d54799 (patch)
tree785ae0af69c0ffbbad800e0631957c4468bcbd67 /games
parentfe34be1887c5b4310d9914feb09ce76d1116eb62 (diff)
downloadports-b5d9a988e5cf6aad3596b7c2f5d0634973d54799.tar.gz
ports-b5d9a988e5cf6aad3596b7c2f5d0634973d54799.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/ruby-exmars/Makefile24
-rw-r--r--games/ruby-exmars/distinfo2
-rw-r--r--games/ruby-exmars/pkg-descr26
-rw-r--r--games/ruby-exmars/pkg-plist3
5 files changed, 56 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 38f2d21f5228..beb461d24570 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -445,6 +445,7 @@
SUBDIR += rtcw
SUBDIR += rtcw-paks
SUBDIR += rubix
+ SUBDIR += ruby-exmars
SUBDIR += sarien
SUBDIR += scare
SUBDIR += scid
diff --git a/games/ruby-exmars/Makefile b/games/ruby-exmars/Makefile
new file mode 100644
index 000000000000..5cbe04a7c0bf
--- /dev/null
+++ b/games/ruby-exmars/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: ruby-exmars
+# Date created: 22 Jul 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= exmars
+PORTVERSION= 0.01
+CATEGORIES= games ruby
+MASTER_SITES= http://martinus.geekisp.com/files/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Ruby interface to the exMARS Memory Array Redcode Simulator
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+post-install:
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/test.rb ${RUBY_MODEXAMPLESDIR}/Mars.rb
+
+.include <bsd.port.mk>
diff --git a/games/ruby-exmars/distinfo b/games/ruby-exmars/distinfo
new file mode 100644
index 000000000000..30bb03577582
--- /dev/null
+++ b/games/ruby-exmars/distinfo
@@ -0,0 +1,2 @@
+MD5 (exmars-0.01.tar.gz) = eccab4367bea768763e4a15cddbbe23f
+SIZE (exmars-0.01.tar.gz) = 67047
diff --git a/games/ruby-exmars/pkg-descr b/games/ruby-exmars/pkg-descr
new file mode 100644
index 000000000000..ec157301bcda
--- /dev/null
+++ b/games/ruby-exmars/pkg-descr
@@ -0,0 +1,26 @@
+exMARS combines the latest advance in corewar simulation technology, with
+proactive performance optimizations.
+
+Actually exMARS is a redcode simulator, just like exhaust and pMARS. In fact,
+I have shamelessly taken sourcecode from pMARS, exhaust, some ideas from
+qMars, a shot of optimizations, shook everything well, and garnished
+everything with a high level interface for Ruby.
+
+The resulting program has the following main features:
+
+* Uses the parser from pMARS, so no previous parsing is neccessary. At first
+ this was my main motivation for exMARS.
+* Speed: 50% faster than pmars on a Pentium III, and often more than twice as
+ fast than pmars on a Pentium 4 (using gcc 3.3.1, and the same compiler
+ options).
+* Rewritten the code in a more object oriented way, which allows different
+ Mars at the same time in the same program, it should also be thread save.
+
+NOTE: This is only Ruby interface part. To install exmars use games/exmars port.
+
+Author: Martin Ankerl
+
+WWW: http://martinus.geekisp.com/rublog.cgi/Projects/CoreWar/exMARS
+
+- Alejandro Pulver
+alejandro@varnet.biz
diff --git a/games/ruby-exmars/pkg-plist b/games/ruby-exmars/pkg-plist
new file mode 100644
index 000000000000..3e6966c095fc
--- /dev/null
+++ b/games/ruby-exmars/pkg-plist
@@ -0,0 +1,3 @@
+%%RUBY_SITEARCHLIBDIR%%/Mars.so
+%%RUBY_MODEXAMPLESDIR%%/Mars.rb
+@dirrm %%RUBY_MODEXAMPLESDIR%%