aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-03-12 22:29:53 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-03-12 22:29:53 +0000
commitdfc4e3da44e3dd018e5dd344f82da6a6795ebb93 (patch)
tree3883eb5333d4b95b325ef9bd7631024041b6d34a /games
parent37b97ad1275580529a11d7ca04397281458e2be2 (diff)
downloadports-dfc4e3da44e3dd018e5dd344f82da6a6795ebb93.tar.gz
ports-dfc4e3da44e3dd018e5dd344f82da6a6795ebb93.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/crrcsim/Makefile33
-rw-r--r--games/crrcsim/distinfo6
-rw-r--r--games/crrcsim/files/patch-interface_parallel-parallel.cpp11
-rw-r--r--games/crrcsim/files/patch-src-mod_inputdev-inputdev_parallel-inputdev_parallel.cpp11
-rw-r--r--games/crrcsim/pkg-descr2
-rw-r--r--games/crrcsim/pkg-plist35
6 files changed, 51 insertions, 47 deletions
diff --git a/games/crrcsim/Makefile b/games/crrcsim/Makefile
index eff88e71d2e1..6a29edc8e334 100644
--- a/games/crrcsim/Makefile
+++ b/games/crrcsim/Makefile
@@ -6,45 +6,34 @@
#
PORTNAME= crrcsim
-PORTVERSION= 0.9.9
+PORTVERSION= 0.9.10
CATEGORIES= games
-MASTER_SITES= SF
+MASTER_SITES= BERLIOS
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Model-airplane flight simulation program
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
+LIB_DEPENDS= portaudio.2:${PORTSDIR}/audio/portaudio2 \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_SDL= sdl
USE_GL= gl glu
-PORTDOCS= *
-
-OPTIONS= PORTAUDIO19 "Use portaudio19 instead of portaudio18" off
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib/portaudio2 -L${LOCALBASE}/lib"\
+ CPPFLAGS="-I${LOCALBASE}/include/portaudio2 -I${LOCALBASE}/include"
-.include <bsd.port.pre.mk>
+PORTDOCS= *
-.if defined(WITH_PORTAUDIO19)
-LIB_DEPENDS+= portaudio.2:${PORTSDIR}/audio/portaudio2
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib/portaudio2 -L${LOCALBASE}/lib"\
- CPPFLAGS="-I${LOCALBASE}/include/portaudio2 -I${LOCALBASE}/include"
-.else
-LIB_DEPENDS+= portaudio.0:${PORTSDIR}/audio/portaudio
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
-.endif
+MAN1= crrcsim.1
post-patch:
@${REINPLACE_CMD} -e '/portaudio/ s|==|=|' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|/usr/local/share/games|${PREFIX}/share|' \
- ${WRKSRC}/config.cpp
- @cd ${WRKSRC} && ${FIND} . -name Makefile.in -print0 | ${XARGS} -0 \
- ${REINPLACE_CMD} -e 's|share/games|share|; \
- s|$$(datadir)/games|$$(datadir)|'
.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e '/SUBDIRS/ s|documentation||' \
- ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-pkgdataDATA||; \
+ /^SUBDIRS =/ s|=.*|= man|' ${WRKSRC}/documentation/Makefile.in
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/crrcsim/distinfo b/games/crrcsim/distinfo
index 22c983ee9dd8..be8900543077 100644
--- a/games/crrcsim/distinfo
+++ b/games/crrcsim/distinfo
@@ -1,3 +1,3 @@
-MD5 (crrcsim-0.9.9.tar.gz) = 5ac9bc6e186339c6e8c1cbfd30c763b5
-SHA256 (crrcsim-0.9.9.tar.gz) = bc43768aa20812d888d6bf5c6343305a62fff95acbb0c0813a6eb3aa5d46107d
-SIZE (crrcsim-0.9.9.tar.gz) = 5276552
+MD5 (crrcsim-0.9.10.tar.gz) = 86845736dcee89f7c2861cafc87f6115
+SHA256 (crrcsim-0.9.10.tar.gz) = f4f24abd1ff0deb804d371b0aaf8493802a8ca004bca6389bbc0798875fa7c81
+SIZE (crrcsim-0.9.10.tar.gz) = 6679182
diff --git a/games/crrcsim/files/patch-interface_parallel-parallel.cpp b/games/crrcsim/files/patch-interface_parallel-parallel.cpp
deleted file mode 100644
index 23ef52da9802..000000000000
--- a/games/crrcsim/files/patch-interface_parallel-parallel.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- interface_parallel/parallel.cpp.orig 2008-04-30 00:00:35.000000000 +0400
-+++ interface_parallel/parallel.cpp 2008-06-17 03:49:23.000000000 +0400
-@@ -5,7 +5,7 @@
- #if defined(__APPLE__) || defined(MACOSX)
- #else
- # if defined(WIN32)
--# elif defined(__powerpc__)
-+# elif defined(__powerpc__) || defined(__FreeBSD__)
- # define ioperm(a,b,c) -1
- # define inb(a) 0
- # define outb(a,b)
diff --git a/games/crrcsim/files/patch-src-mod_inputdev-inputdev_parallel-inputdev_parallel.cpp b/games/crrcsim/files/patch-src-mod_inputdev-inputdev_parallel-inputdev_parallel.cpp
new file mode 100644
index 000000000000..a4c48d7fa4e6
--- /dev/null
+++ b/games/crrcsim/files/patch-src-mod_inputdev-inputdev_parallel-inputdev_parallel.cpp
@@ -0,0 +1,11 @@
+--- src/mod_inputdev/inputdev_parallel/inputdev_parallel.cpp.orig 2009-03-07 19:41:23.000000000 +0300
++++ src/mod_inputdev/inputdev_parallel/inputdev_parallel.cpp 2009-03-12 01:47:06.000000000 +0300
+@@ -28,7 +28,7 @@
+ #if defined(__APPLE__) || defined(MACOSX)
+ #else
+ # if defined(WIN32)
+-# elif defined(__powerpc__)
++# elif defined(__powerpc__) || defined (__FreeBSD__)
+ # define ioperm(a,b,c) -1
+ # define inb(a) 0
+ # define outb(a,b)
diff --git a/games/crrcsim/pkg-descr b/games/crrcsim/pkg-descr
index 0aa58f3595c1..64918a17f2bd 100644
--- a/games/crrcsim/pkg-descr
+++ b/games/crrcsim/pkg-descr
@@ -8,4 +8,4 @@ aircraft. Stalls are properly modelled as well. Model control is
possible with your own rc transmitter, or any input device such as
joystick, mouse, keyboard.
-WWW: http://crrcsim.sourceforge.net/
+WWW: http://crrcsim.berlios.de/wiki/
diff --git a/games/crrcsim/pkg-plist b/games/crrcsim/pkg-plist
index c187f349de15..37d92bb5e3ff 100644
--- a/games/crrcsim/pkg-plist
+++ b/games/crrcsim/pkg-plist
@@ -2,11 +2,13 @@ bin/crrcsim
%%DATADIR%%/icons/crrcsim.ico
%%DATADIR%%/icons/crrcsim.png
%%DATADIR%%/icons/crrcsim.xpm
+%%DATADIR%%/models/Crossfire.xml
+%%DATADIR%%/models/Erwin.xml
%%DATADIR%%/models/FlexiflyXLM.xml
+%%DATADIR%%/models/PilatusB4.xml
%%DATADIR%%/models/Skorpion.xml
%%DATADIR%%/models/allegro.xml
%%DATADIR%%/models/apogee.xml
-%%DATADIR%%/models/arkanj-mg11.xml
%%DATADIR%%/models/battery/nimh12_2400.xml
%%DATADIR%%/models/battery/nimh7_kan1050.xml
%%DATADIR%%/models/biplane2.xml
@@ -14,43 +16,51 @@ bin/crrcsim
%%DATADIR%%/models/engine/Mabuchi_380_FR.xml
%%DATADIR%%/models/engine/astro_cobalt_10.xml
%%DATADIR%%/models/engine/turbo_550_8.xml
+%%DATADIR%%/models/fireworks3_d.xml
%%DATADIR%%/models/gap65.xml
+%%DATADIR%%/models/heli.xml
%%DATADIR%%/models/k2.xml
%%DATADIR%%/models/mav.xml
-%%DATADIR%%/models/mav0.xml
+%%DATADIR%%/models/melyan_01.xml
%%DATADIR%%/models/outrage.xml
%%DATADIR%%/models/quickie01.xml
%%DATADIR%%/models/sovereign.xml
%%DATADIR%%/models/sport.xml
%%DATADIR%%/models/superzagi.xml
+%%DATADIR%%/models/supra_a.xml
%%DATADIR%%/models/zagi-xs.xml
-%%DATADIR%%/models/zagi.xml
-%%DATADIR%%/models/zip60.xml
%%DATADIR%%/models/zipper.xml
+%%DATADIR%%/objects/Crossfire.ac
+%%DATADIR%%/objects/Erwin.ac
+%%DATADIR%%/objects/Fireworks_C.ac
+%%DATADIR%%/objects/PilatusB4.ac
%%DATADIR%%/objects/Skorpion.ac
%%DATADIR%%/objects/allegro.ac
%%DATADIR%%/objects/apogee.ac
-%%DATADIR%%/objects/arkanj-mg11.ac
%%DATADIR%%/objects/biplane2.ac
%%DATADIR%%/objects/flexifly_xlm.ac
+%%DATADIR%%/objects/freqboard.ac
%%DATADIR%%/objects/gap65.ac
%%DATADIR%%/objects/gap65_raven.ac
+%%DATADIR%%/objects/heli.ac
%%DATADIR%%/objects/k2.ac
+%%DATADIR%%/objects/log.ac
%%DATADIR%%/objects/mav.ac
+%%DATADIR%%/objects/melyan_01.ac
+%%DATADIR%%/objects/outhouse.ac
%%DATADIR%%/objects/outrage.ac
%%DATADIR%%/objects/quickie01.ac
+%%DATADIR%%/objects/small.ac
%%DATADIR%%/objects/sovereign.ac
%%DATADIR%%/objects/sport.ac
+%%DATADIR%%/objects/supra.ac
+%%DATADIR%%/objects/trashcan.ac
%%DATADIR%%/objects/zagi-xs.ac
%%DATADIR%%/objects/zagi.ac
-%%DATADIR%%/objects/zip60.ac
%%DATADIR%%/objects/zipper.ac
%%DATADIR%%/scenery/cape_cod-orig.xml
-%%DATADIR%%/scenery/cape_cod.xml
-%%DATADIR%%/scenery/coast.tga
-%%DATADIR%%/scenery/coast.xml
%%DATADIR%%/scenery/davis-orig.xml
-%%DATADIR%%/scenery/davis.xml
+%%DATADIR%%/scenery/simple.xml
%%DATADIR%%/sounds/electric.wav
%%DATADIR%%/sounds/f3f/default/base1.wav
%%DATADIR%%/sounds/f3f/default/base10.wav
@@ -83,6 +93,10 @@ bin/crrcsim
%%DATADIR%%/sounds/f3f/sport/start.wav
%%DATADIR%%/sounds/fan.wav
%%DATADIR%%/sounds/glider.wav
+%%DATADIR%%/textures/CrossfireTexture.rgb
+%%DATADIR%%/textures/Erwin.rgb
+%%DATADIR%%/textures/Fireworks2.rgb
+%%DATADIR%%/textures/PilB4Texture.rgb
%%DATADIR%%/textures/beachsand.rgb
%%DATADIR%%/textures/clouds.bw
%%DATADIR%%/textures/clouds.rgb
@@ -113,6 +127,7 @@ bin/crrcsim
%%DATADIR%%/textures/south.rgb
%%DATADIR%%/textures/sovereign_tex.rgb
%%DATADIR%%/textures/sport_tex.rgb
+%%DATADIR%%/textures/supra_texture_256.rgb
%%DATADIR%%/textures/terrain.bw
%%DATADIR%%/textures/water.rgb
%%DATADIR%%/textures/waves.rgb