aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2002-11-24 23:48:28 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2002-11-24 23:48:28 +0000
commit8484d010980872e5e936871f5534c9c590949551 (patch)
tree13a12ef45e5d7cd69a99c75c91e2c2f831cea72d /games
parentd160c9a8010680f4c17aebc93741c66663b5686a (diff)
downloadports-8484d010980872e5e936871f5534c9c590949551.tar.gz
ports-8484d010980872e5e936871f5534c9c590949551.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/grhino/Makefile30
-rw-r--r--games/grhino/distinfo1
-rw-r--r--games/grhino/files/patch-aa10
-rw-r--r--games/grhino/files/patch-ab11
-rw-r--r--games/grhino/pkg-comment1
-rw-r--r--games/grhino/pkg-descr3
-rw-r--r--games/grhino/pkg-plist14
8 files changed, 71 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 160a147ccd69..7d44a7182e7b 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -125,6 +125,7 @@
SUBDIR += gracer
SUBDIR += grande
SUBDIR += greed
+ SUBDIR += grhino
SUBDIR += groundhog
SUBDIR += gru
SUBDIR += grubinvaders
diff --git a/games/grhino/Makefile b/games/grhino/Makefile
new file mode 100644
index 000000000000..ed4016dd3306
--- /dev/null
+++ b/games/grhino/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: grhino
+# Date created: 21 Sep 2002
+# Whom: UMENO Takashi <umeno@rr.iij4u.or.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= grhino
+PORTVERSION= 0.7.0
+CATEGORIES= games gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= rhino
+
+MAINTAINER= umeno@rr.iij4u.or.jp
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomelibs gnomeprefix
+USE_PERL5_BUILD=yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+PLIST_SUB+= VERSION=${PORTVERSION}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/games/grhino/distinfo b/games/grhino/distinfo
new file mode 100644
index 000000000000..53ce84d9e261
--- /dev/null
+++ b/games/grhino/distinfo
@@ -0,0 +1 @@
+MD5 (grhino-0.7.0.tar.gz) = 501614a2ef3d6a2ce2edd66fe7c1cb82
diff --git a/games/grhino/files/patch-aa b/games/grhino/files/patch-aa
new file mode 100644
index 000000000000..7abbdf730457
--- /dev/null
+++ b/games/grhino/files/patch-aa
@@ -0,0 +1,10 @@
+--- pattern.cc.orig Thu Aug 1 23:10:02 2002
++++ pattern.cc Tue Aug 20 23:34:37 2002
+@@ -25,6 +25,7 @@
+ #include <fcntl.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
++#include <string.h>
+
+ // These are not correct in terms of symmetry but provide better
+ // opening moves
diff --git a/games/grhino/files/patch-ab b/games/grhino/files/patch-ab
new file mode 100644
index 000000000000..223e916ff29e
--- /dev/null
+++ b/games/grhino/files/patch-ab
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Tue Sep 24 23:30:09 2002
++++ Makefile.in Thu Sep 26 09:34:21 2002
+@@ -43,7 +43,7 @@
+ etcdir = @sysconfdir@
+ localedir = @datadir@/locale
+
+-pattern_dir = ${libdir}/${PACKAGE}-${VERSION}
++pattern_dir = @datadir@/${PACKAGE}/${VERSION}
+
+ CC = @CC@
+ CXX = @CXX@
diff --git a/games/grhino/pkg-comment b/games/grhino/pkg-comment
new file mode 100644
index 000000000000..c355b1085db6
--- /dev/null
+++ b/games/grhino/pkg-comment
@@ -0,0 +1 @@
+GRhino Othello/Reversi Program
diff --git a/games/grhino/pkg-descr b/games/grhino/pkg-descr
new file mode 100644
index 000000000000..24af54587715
--- /dev/null
+++ b/games/grhino/pkg-descr
@@ -0,0 +1,3 @@
+GRhino Othello/Reversi Program
+
+WWW: http://rhino.sourceforge.net/
diff --git a/games/grhino/pkg-plist b/games/grhino/pkg-plist
new file mode 100644
index 000000000000..df0c8745a989
--- /dev/null
+++ b/games/grhino/pkg-plist
@@ -0,0 +1,14 @@
+bin/grhino
+share/gnome/grhino/%%VERSION%%/row1.bin
+share/gnome/grhino/%%VERSION%%/row2.bin
+share/gnome/grhino/%%VERSION%%/row3.bin
+share/gnome/grhino/%%VERSION%%/row4.bin
+share/gnome/grhino/%%VERSION%%/diag1.bin
+share/gnome/grhino/%%VERSION%%/diag2.bin
+share/gnome/grhino/%%VERSION%%/diag3.bin
+share/gnome/grhino/%%VERSION%%/diag4.bin
+share/gnome/grhino/%%VERSION%%/diag5.bin
+share/gnome/grhino/%%VERSION%%/corner5x2.bin
+share/gnome/grhino/%%VERSION%%/book.bin
+@dirrm share/gnome/grhino/%%VERSION%%
+@dirrm share/gnome/grhino