aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-18 19:50:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-18 19:50:35 +0000
commit09642a7911d2972e9145b55503a415c3ddc6f378 (patch)
treea523842741864002233efd2a75c48a3de2f9cdc2 /games
parentcf643ddc0b672c1f840f542cdeb298e2833f92a6 (diff)
downloadports-09642a7911d2972e9145b55503a415c3ddc6f378.tar.gz
ports-09642a7911d2972e9145b55503a415c3ddc6f378.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/biloba/Makefile6
-rw-r--r--games/biloba/distinfo6
-rw-r--r--games/biloba/files/patch-src-keyboard.c12
-rw-r--r--games/biloba/files/patch-src-player.c18
-rw-r--r--games/biloba/pkg-plist27
5 files changed, 29 insertions, 40 deletions
diff --git a/games/biloba/Makefile b/games/biloba/Makefile
index 2fe408e27d2a..3340bdd50d64 100644
--- a/games/biloba/Makefile
+++ b/games/biloba/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= biloba
-PORTVERSION= 0.4
-PORTREVISION= 2
+PORTVERSION= 0.6
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= amdmi3@amdmi3.ru
COMMENT= A strategy board game for 2 to 4 players
diff --git a/games/biloba/distinfo b/games/biloba/distinfo
index 1c6fb5f0709c..d57b3c6a11a1 100644
--- a/games/biloba/distinfo
+++ b/games/biloba/distinfo
@@ -1,3 +1,3 @@
-MD5 (biloba-0.4.tar.gz) = 6259bea5aabed19f8587f89f3a1c0648
-SHA256 (biloba-0.4.tar.gz) = 4e44099bd2d0ce1e049bd311391a05e1f2af3781813661db89a6aba634ef6fc5
-SIZE (biloba-0.4.tar.gz) = 1987832
+MD5 (biloba-0.6.tar.gz) = a92a73e84ec1b62abeae8b3855d0220c
+SHA256 (biloba-0.6.tar.gz) = 657fb707e4743b67c333d94e64b952d591241eb06189f73401edc233a100b479
+SIZE (biloba-0.6.tar.gz) = 3346864
diff --git a/games/biloba/files/patch-src-keyboard.c b/games/biloba/files/patch-src-keyboard.c
deleted file mode 100644
index 0e045cb25064..000000000000
--- a/games/biloba/files/patch-src-keyboard.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/keyboard.c.orig Fri Sep 23 15:45:22 2005
-+++ src/keyboard.c Mon Oct 3 03:52:28 2005
-@@ -60,8 +60,8 @@
- int mcode = 0;
- SDL_LockMutex(keyb_mutex);
- if (event_list) {
-- mcode = (int)event_list->data;
- LList *next = event_list->next;
-+ mcode = (int)event_list->data;
- free(event_list);
- event_list = next;
- #ifdef DEBUG
diff --git a/games/biloba/files/patch-src-player.c b/games/biloba/files/patch-src-player.c
deleted file mode 100644
index 6e18b480cb68..000000000000
--- a/games/biloba/files/patch-src-player.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/player.c.orig Fri Sep 23 19:09:02 2005
-+++ src/player.c Mon Oct 3 03:53:01 2005
-@@ -259,6 +259,7 @@
- {
- int i;
- char *msg;
-+ char num[2] = {((int)player->color)+1+'0', 0};
- for (i = 0; i < game_num_players(); i++) {
- LList *pawns = pawn_get_all((PawnColor)i);
- for (; pawns; pawns = pawns->next) {
-@@ -268,7 +269,6 @@
- }
- pawn_show_eaten();
- }
-- char num[2] = {((int)player->color)+1+'0', 0};
- if (player->name == NULL) {
- msg = malloc(strlen(get_msg(M_PLAYER_LEAVES))+1);
- strcpy(msg, get_msg(M_PLAYER));
diff --git a/games/biloba/pkg-plist b/games/biloba/pkg-plist
index c225abcf8c5d..87aacb557146 100644
--- a/games/biloba/pkg-plist
+++ b/games/biloba/pkg-plist
@@ -2,11 +2,17 @@ bin/biloba
%%DATADIR%%/en/2play.png
%%DATADIR%%/en/3play.png
%%DATADIR%%/en/4play.png
+%%DATADIR%%/en/aide1-maemo.png
%%DATADIR%%/en/aide1.png
+%%DATADIR%%/en/aide2-maemo.png
%%DATADIR%%/en/aide2.png
+%%DATADIR%%/en/aide3-maemo.png
%%DATADIR%%/en/aide3.png
+%%DATADIR%%/en/aide4-maemo.png
%%DATADIR%%/en/aide4.png
+%%DATADIR%%/en/aide5-maemo.png
%%DATADIR%%/en/aide5.png
+%%DATADIR%%/en/aide6-maemo.png
%%DATADIR%%/en/aide6.png
%%DATADIR%%/en/arrow-down-left.png
%%DATADIR%%/en/arrow-down-right.png
@@ -18,6 +24,7 @@ bin/biloba
%%DATADIR%%/en/arrow-up.png
%%DATADIR%%/en/biloba-title.png
%%DATADIR%%/en/black-highlighter.png
+%%DATADIR%%/en/border-maemo.png
%%DATADIR%%/en/border.png
%%DATADIR%%/en/computer.png
%%DATADIR%%/en/create-game.png
@@ -55,11 +62,17 @@ bin/biloba
%%DATADIR%%/es/2play.png
%%DATADIR%%/es/3play.png
%%DATADIR%%/es/4play.png
+%%DATADIR%%/es/aide1-maemo.png
%%DATADIR%%/es/aide1.png
+%%DATADIR%%/es/aide2-maemo.png
%%DATADIR%%/es/aide2.png
+%%DATADIR%%/es/aide3-maemo.png
%%DATADIR%%/es/aide3.png
+%%DATADIR%%/es/aide4-maemo.png
%%DATADIR%%/es/aide4.png
+%%DATADIR%%/es/aide5-maemo.png
%%DATADIR%%/es/aide5.png
+%%DATADIR%%/es/aide6-maemo.png
%%DATADIR%%/es/aide6.png
%%DATADIR%%/es/arrow-down-left.png
%%DATADIR%%/es/arrow-down-right.png
@@ -71,6 +84,7 @@ bin/biloba
%%DATADIR%%/es/arrow-up.png
%%DATADIR%%/es/biloba-title.png
%%DATADIR%%/es/black-highlighter.png
+%%DATADIR%%/es/border-maemo.png
%%DATADIR%%/es/border.png
%%DATADIR%%/es/computer.png
%%DATADIR%%/es/create-game.png
@@ -108,11 +122,17 @@ bin/biloba
%%DATADIR%%/fr/2play.png
%%DATADIR%%/fr/3play.png
%%DATADIR%%/fr/4play.png
+%%DATADIR%%/fr/aide1-maemo.png
%%DATADIR%%/fr/aide1.png
+%%DATADIR%%/fr/aide2-maemo.png
%%DATADIR%%/fr/aide2.png
+%%DATADIR%%/fr/aide3-maemo.png
%%DATADIR%%/fr/aide3.png
+%%DATADIR%%/fr/aide4-maemo.png
%%DATADIR%%/fr/aide4.png
+%%DATADIR%%/fr/aide5-maemo.png
%%DATADIR%%/fr/aide5.png
+%%DATADIR%%/fr/aide6-maemo.png
%%DATADIR%%/fr/aide6.png
%%DATADIR%%/fr/arrow-down-left.png
%%DATADIR%%/fr/arrow-down-right.png
@@ -124,6 +144,7 @@ bin/biloba
%%DATADIR%%/fr/arrow-up.png
%%DATADIR%%/fr/biloba-title.png
%%DATADIR%%/fr/black-highlighter.png
+%%DATADIR%%/fr/border-maemo.png
%%DATADIR%%/fr/border.png
%%DATADIR%%/fr/computer.png
%%DATADIR%%/fr/create-game.png
@@ -160,8 +181,8 @@ bin/biloba
%%DATADIR%%/fr/tile.png
%%DATADIR%%/snd/eat.wav
%%DATADIR%%/snd/type.wav
-@dirrm %%DATADIR%%/en
-@dirrm %%DATADIR%%/es
-@dirrm %%DATADIR%%/fr
@dirrm %%DATADIR%%/snd
+@dirrm %%DATADIR%%/fr
+@dirrm %%DATADIR%%/es
+@dirrm %%DATADIR%%/en
@dirrm %%DATADIR%%