aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-09-29 05:45:34 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-09-29 05:45:34 +0000
commit90abb24f53e9d8c2428c70b483b38627d2bae3ae (patch)
tree039e88512c84bb0c19d7d2204a18150ecd6574ab /games
parent57ecc8add154f672ce9d853fb180da502d262718 (diff)
downloadports-90abb24f53e9d8c2428c70b483b38627d2bae3ae.tar.gz
ports-90abb24f53e9d8c2428c70b483b38627d2bae3ae.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/tank/Makefile8
-rw-r--r--games/trophy/Makefile8
-rw-r--r--games/tvp/Makefile8
-rw-r--r--games/vavoom/Makefile8
4 files changed, 28 insertions, 4 deletions
diff --git a/games/tank/Makefile b/games/tank/Makefile
index 99549cf5d07b..d3c7ed51b1f6 100644
--- a/games/tank/Makefile
+++ b/games/tank/Makefile
@@ -22,10 +22,16 @@ USE_GMAKE= yes
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}"
ALL_TARGET= linux-mesa-elf
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tank ${PREFIX}/bin
${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/*.tga ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/*.au ${DATADIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/trophy/Makefile b/games/trophy/Makefile
index 9bc81799af99..b1cc5fd8802e 100644
--- a/games/trophy/Makefile
+++ b/games/trophy/Makefile
@@ -25,6 +25,12 @@ BUILD_WRKSRC= ${WRKSRC}/trophy
MAKE_ENV= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
PTHREAD_LIBS=${PTHREAD_LIBS}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-extract:
@${FIND} ${BUILD_WRKSRC}/resources -name .cvsignore -exec ${RM} -f {} \;
@@ -45,4 +51,4 @@ do-install:
${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/tvp/Makefile b/games/tvp/Makefile
index 6ff4d2b224cc..dd22737dd31a 100644
--- a/games/tvp/Makefile
+++ b/games/tvp/Makefile
@@ -32,6 +32,12 @@ MLINKS= tvp.6 xprez.6 - aprez.6 - prez.6
DOCFILES= aprez.txt libass.txt president.txt prez.txt xprez.txt
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/tvp
@@ -44,4 +50,4 @@ post-install:
${PREFIX}/man/man6/tvp.6
${STRIP_CMD} ${PREFIX}/bin/aprez ${PREFIX}/bin/prez ${PREFIX}/bin/xpwish
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/vavoom/Makefile b/games/vavoom/Makefile
index 223b70bd0036..529102fde164 100644
--- a/games/vavoom/Makefile
+++ b/games/vavoom/Makefile
@@ -33,6 +33,12 @@ EXTRACT_AFTER_ARGS= -d ${WRKSRC}
MAKE_ARGS= "USE_AL=1"
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.ifndef (WITH_OPENAL)
pre-everything::
@${ECHO_CMD} "********************************************************************"
@@ -73,4 +79,4 @@ post-install:
@${SED} -e 's|%%PREFIX%%|${PREFIX}|; s|%%DATADIR%%|${DATADIR}|' \
<${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>